summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.2.2.bb')
-rw-r--r--meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.2.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.2.2.bb b/meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.2.2.bb
new file mode 100644
index 000000000..047f70110
--- /dev/null
+++ b/meta-oe/recipes-support/engine-pkcs11/engine-pkcs11_0.2.2.bb
@@ -0,0 +1,31 @@
1SUMMARY = "A PKCS"
2DESCRIPTION = "\
3Engine_pkcs11 is an implementation of an engine for OpenSSL. It can be \
4loaded using code, config file or command line and will pass any function \
5call by openssl to a PKCS cards and software for using smart cards in PKCS"
6HOMEPAGE = "https://github.com/OpenSC/engine_pkcs11"
7SECTION = "Development/Libraries"
8LICENSE = "LGPLv2.1+"
9LIC_FILES_CHKSUM = "file://src/engine_pkcs11.h;startline=1;endline=26;md5=973a19f8a6105de047f2adfbbfc04c33"
10DEPENDS = "openssl libp11"
11
12SRC_URI = "git://github.com/OpenSC/engine_pkcs11.git"
13SRCREV = "132fcf2c8b319f9f4b2ebdc8dcb54ff496dc0519"
14
15S = "${WORKDIR}/git"
16
17inherit autotools pkgconfig
18
19EXTRA_OECONF = "\
20 --disable-static \
21 --libdir ${libdir}/engines \
22"
23
24do_install_append () {
25 rm -f ${D}${libdir}/engines/libpkcs11.la
26}
27
28FILES_${PN} += "${libdir}/engines/libpkcs11${SOLIBSDEV}"
29FILES_${PN}-dbg += "${libdir}/engines/.debug/"
30
31RDEPENDS_${PN} += "openssl libp11 opensc"