summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch')
-rw-r--r--meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch b/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch
new file mode 100644
index 000000000..c0d552d54
--- /dev/null
+++ b/meta-oe/recipes-support/digitemp/digitemp/makefile-fix.patch
@@ -0,0 +1,20 @@
1digitemp: allow override of CC and CFLAGS vars
2
3Upstream-Status: Inappropriate [embedded specific]
4
5Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
6
7--- a/Makefile 2008-08-28 21:37:00.000000000 +0000
8+++ b/Makefile 2011-11-24 22:22:39.882511272 +0000
9@@ -11,8 +11,9 @@
10
11 VERSION = 3.6.0
12
13-CC = gcc
14-CFLAGS = -I./src -I./userial -O2 -Wall # -g
15+CC ?= gcc
16+CFLAGS ?= -O2 -Wall # -g
17+CFLAGS += -I./src -I./userial
18
19 OBJS = src/digitemp.o src/device_name.o src/ds2438.o
20 HDRS = src/digitemp.h src/device_name.h