summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cxxopts/cxxopts_3.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/cxxopts/cxxopts_3.2.1.bb')
-rw-r--r--meta-oe/recipes-support/cxxopts/cxxopts_3.2.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cxxopts/cxxopts_3.2.1.bb b/meta-oe/recipes-support/cxxopts/cxxopts_3.2.1.bb
new file mode 100644
index 0000000000..6077220151
--- /dev/null
+++ b/meta-oe/recipes-support/cxxopts/cxxopts_3.2.1.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "A header-only lightweight C++ command line option parser."
2HOMEPAGE = "https://github.com/jarro2783/cxxopts"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8de00431559a76a1b43f6fd44f8f6689"
6
7SRC_URI = "git://github.com/jarro2783/cxxopts.git;protocol=https;branch=master"
8SRCREV = "4bf61f08697b110d9e3991864650a405b3dd515d"
9
10S = "${WORKDIR}/git"
11
12inherit cmake
13
14EXTRA_OECMAKE:append = " \
15-DCXXOPTS_BUILD_EXAMPLES=OFF \
16-DCXXOPTS_BUILD_TESTS=OFF \
17-DCXXOPTS_ENABLE_INSTALL=ON \
18-DCXXOPTS_ENABLE_WARNINGS=OFF \
19-DCXXOPTS_USE_UNICODE_HELP=OFF \
20"