summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/boost-sml/boost-sml_1.1.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/boost-sml/boost-sml_1.1.11.bb')
-rw-r--r--meta-oe/recipes-support/boost-sml/boost-sml_1.1.11.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/boost-sml/boost-sml_1.1.11.bb b/meta-oe/recipes-support/boost-sml/boost-sml_1.1.11.bb
new file mode 100644
index 000000000..a48195a15
--- /dev/null
+++ b/meta-oe/recipes-support/boost-sml/boost-sml_1.1.11.bb
@@ -0,0 +1,25 @@
1SUMMARY = "[Boost::ext].SML (State Machine Language)"
2DESCRIPTION = "Your scalable C++14 one header only State Machine Library with no dependencies"
3HOMEPAGE = "https://github.com/boost-ext/sml"
4BUGTRACKER = "https://github.com/boost-ext/sml/issues"
5SECTION = "libs"
6LICENSE = "BSL-1.0"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=e4224ccaecb14d942c71d31bef20d78c"
8
9DEPENDS += "boost qemu-native"
10
11SRC_URI = "git://github.com/boost-ext/sml.git;protocol=https;branch=master"
12SRCREV = "b7df6180d20422b2724d26007aebb24066f2a6a9"
13
14S = "${WORKDIR}/git"
15
16inherit cmake
17
18# Building benchmarks takes a lot of time and requires additional headers (euml2.hpp)
19# Building examples fail with gcc-12
20EXTRA_OECMAKE:append = " -DSML_BUILD_BENCHMARKS:bool=OFF -DSML_BUILD_EXAMPLES=OFF"
21
22# [boost::ext].XML is a header only C++ library, so the main package will be empty.
23ALLOW_EMPTY:${PN} = "1"
24
25BBCLASSEXTEND = "nativesdk"