summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/bdwgc/bdwgc_7.6.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/bdwgc/bdwgc_7.6.8.bb')
-rw-r--r--meta-oe/recipes-support/bdwgc/bdwgc_7.6.8.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/bdwgc/bdwgc_7.6.8.bb b/meta-oe/recipes-support/bdwgc/bdwgc_7.6.8.bb
new file mode 100644
index 000000000..bb7897138
--- /dev/null
+++ b/meta-oe/recipes-support/bdwgc/bdwgc_7.6.8.bb
@@ -0,0 +1,40 @@
1SUMMARY = "A garbage collector for C and C++"
2
3DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
4 used as a garbage collecting replacement for C malloc or C++ new. It allows\
5 you to allocate memory basically as you normally would, without explicitly\
6 deallocating memory that is no longer useful. The collector automatically\
7 recycles memory when it determines that it can no longer be otherwise\
8 accessed.\
9 The collector is also used by a number of programming language\
10 implementations that either use C as intermediate code, want to facilitate\
11 easier interoperation with C libraries, or just prefer the simple collector\
12 interface.\
13 Alternatively, the garbage collector may be used as a leak detector for C\
14 or C++ programs, though that is not its primary goal.\
15 Empirically, this collector works with most unmodified C programs, simply\
16 by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
17 calls, and removing free calls."
18
19HOMEPAGE = "http://www.hboehm.info/gc/"
20SECTION = "devel"
21LICENSE = "MIT"
22LIC_FILES_CHKSUM = "file://README.QUICK;md5=728501f233050290314d33fb07d883eb"
23
24SRCREV = "8b2a98209a59c92e1be318e4acda507d83175f4d"
25SRC_URI = "git://github.com/ivmai/bdwgc.git;branch=release-7_6 \
26 "
27
28FILES_${PN}-doc = "${datadir}"
29
30S = "${WORKDIR}/git"
31
32ARM_INSTRUCTION_SET = "arm"
33
34inherit autotools pkgconfig
35
36# by default use external libatomic-ops
37PACKAGECONFIG ??= "libatomic-ops"
38PACKAGECONFIG[libatomic-ops] = "--with-libatomic-ops=yes,--with-libatomic-ops=no,libatomic-ops"
39
40BBCLASSEXTEND = "native nativesdk"