summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-security/nmap/nmap_7.70.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-security/nmap/nmap_7.70.bb')
-rw-r--r--meta-oe/recipes-security/nmap/nmap_7.70.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-security/nmap/nmap_7.70.bb b/meta-oe/recipes-security/nmap/nmap_7.70.bb
new file mode 100644
index 000000000..e47d09f17
--- /dev/null
+++ b/meta-oe/recipes-security/nmap/nmap_7.70.bb
@@ -0,0 +1,46 @@
1SUMMARY = "network auditing tool"
2DESCRIPTION = "Nmap ("Network Mapper") is a free and open source (license) utility for network discovery and security auditing.\nGui support via appending to IMAGE_FEATURES x11-base in local.conf"
3SECTION = "security"
4LICENSE = "GPL-2.0"
5
6LIC_FILES_CHKSUM = "file://COPYING;beginline=7;endline=12;md5=1489288f46af415fadc4e8b6345ab9f4"
7
8SRC_URI = "http://nmap.org/dist/${BP}.tar.bz2 \
9 file://nmap-redefine-the-python-library-dir.patch \
10 file://nmap-replace-shtool-mkdir-with-coreutils-mkdir-command.patch \
11"
12
13SRC_URI[md5sum] = "84eb6fbe788e0d4918c2b1e39421bf79"
14SRC_URI[sha256sum] = "847b068955f792f4cc247593aca6dc3dc4aae12976169873247488de147a6e18"
15
16inherit autotools-brokensep pkgconfig python3native
17
18PACKAGECONFIG ?= "ncat nping ndiff pcap"
19
20PACKAGECONFIG[pcap] = "--with-pcap=linux, --without-pcap, libpcap, libpcap"
21PACKAGECONFIG[pcre] = "--with-libpcre=${STAGING_LIBDIR}/.., --with-libpcre=included, libpre"
22PACKAGECONFIG[ssl] = "--with-openssl=${STAGING_LIBDIR}/.., --without-openssl, openssl, openssl"
23PACKAGECONFIG[ssh2] = "--with-openssh2=${STAGING_LIBDIR}/.., --without-openssh2, libssh2, libssh2"
24PACKAGECONFIG[libz] = "--with-libz=${STAGING_LIBDIR}/.., --without-libz, zlib, zlib"
25
26#disable/enable packages
27PACKAGECONFIG[nping] = ",--without-nping,"
28PACKAGECONFIG[ncat] = ",--without-ncat,"
29PACKAGECONFIG[ndiff] = ",--without-ndiff,python"
30PACKAGECONFIG[update] = ",--without-nmap-update,"
31
32EXTRA_OECONF = "--with-libdnet=included --with-liblinear=included --without-subversion --with-liblua=included"
33
34# zenmap needs python-pygtk which has been removed
35# it also only works with python2
36# disable for now until py3 is supported
37EXTRA_OECONF += "--without-zenmap"
38
39do_configure() {
40 autoconf
41 oe_runconf
42}
43
44FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
45
46RDEPENDS_${PN} = "python"