summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation/omgps/omgps/fix.capability.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-navigation/omgps/omgps/fix.capability.patch')
-rw-r--r--meta-oe/recipes-navigation/omgps/omgps/fix.capability.patch62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/omgps/omgps/fix.capability.patch b/meta-oe/recipes-navigation/omgps/omgps/fix.capability.patch
new file mode 100644
index 000000000..3ed86d8a9
--- /dev/null
+++ b/meta-oe/recipes-navigation/omgps/omgps/fix.capability.patch
@@ -0,0 +1,62 @@
1Upstream-Status: Submitted
2https://code.google.com/p/omgps/issues/detail?id=15
3
4we need to include config.h first to know if HAVE_SYS_CAPABILITY_H is enabled or no, otherwise
5sys/capability.h is not included and later used
6| src/network.c: In function 'can_ping':
7| src/network.c:198:2: error: 'cap_flag_value_t' undeclared (first use in this function)
8| src/network.c:198:2: note: each undeclared identifier is reported only once for each function it appears in
9| src/network.c:198:19: error: expected ';' before 'cap'
10| src/network.c:199:2: error: 'cap_t' undeclared (first use in this function)
11| src/network.c:199:8: error: expected ';' before 'caps'
12| src/network.c:200:6: error: 'caps' undeclared (first use in this function)
13| cc1: warnings being treated as errors
14| src/network.c:203:2: error: implicit declaration of function 'cap_get_flag'
15| src/network.c:203:21: error: 'CAP_SYS_NICE' undeclared (first use in this function)
16| src/network.c:203:35: error: 'CAP_EFFECTIVE' undeclared (first use in this function)
17| src/network.c:203:51: error: 'cap' undeclared (first use in this function)
18| src/network.c:204:17: error: 'CAP_CLEAR' undeclared (first use in this function)
19| src/network.c:210:1: error: control reaches end of non-void function
20| make[1]: *** [omgps-network.o] Error 1
21
22and -lcap is needed for 2 functions later (should be added only for HAVE_SYS_CAPABILITY_H enabled, but I don't care enough)
23| omgps-network.o: In function `can_ping':
24| /OE/tmpdir-shr/work/armv4t-oe-linux-gnueabi/omgps-0.1+svnr109-r1/omgps/src/network.c:199: undefined reference to `cap_get_proc'
25| /OE/tmpdir-shr/work/armv4t-oe-linux-gnueabi/omgps-0.1+svnr109-r1/omgps/src/network.c:203: undefined reference to `cap_get_flag'
26| collect2: ld returned 1 exit status
27
28--- omgps.orig/src/network.c 2009-10-28 18:51:16.000000000 +0100
29+++ omgps/src/network.c 2011-05-09 09:59:11.637676772 +0200
30@@ -19,16 +19,16 @@
31 #include <assert.h>
32 #include <glib.h>
33
34-#if (HAVE_SYS_CAPABILITY_H)
35-#undef _POSIX_SOURCE
36-#include <sys/capability.h>
37-#endif
38-
39 #include "config.h"
40 #include "util.h"
41 #include "network.h"
42 #include "customized.h"
43
44+#if (HAVE_SYS_CAPABILITY_H)
45+#undef _POSIX_SOURCE
46+#include <sys/capability.h>
47+#endif
48+
49 /**
50 * Ping: reference <Unix network programming>, volume 1, third edition.
51 */
52--- omgps.orig/Makefile.am 2009-10-28 18:51:17.000000000 +0100
53+++ omgps/Makefile.am 2011-05-09 10:04:58.578676679 +0200
54@@ -33,7 +33,7 @@
55
56 omgps_CFLAGS = $(common_CFLAGS) -O2
57 omgps_LDFLAGS =
58-omgps_LDADD = @DEPENDENCIES_LIBS@ -lpython$(PY_VERSION)
59+omgps_LDADD = @DEPENDENCIES_LIBS@ -lcap -lpython$(PY_VERSION)
60
61 omgps_SOURCES = \
62 src/ctx_agps_online.c \