summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-multimedia')
-rw-r--r--meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb1
-rw-r--r--meta-oe/recipes-multimedia/cdrkit/files/fix-incompatible-pointer-type-error.patch44
-rw-r--r--meta-oe/recipes-multimedia/libass/libass_0.17.2.bb (renamed from meta-oe/recipes-multimedia/libass/libass_0.17.1.bb)4
-rw-r--r--meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb9
-rw-r--r--meta-oe/recipes-multimedia/live555/live555_20210824.bb2
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx/libvpx-configure-support-blank-prefix.patch8
-rw-r--r--meta-oe/recipes-multimedia/webm/libvpx_1.14.1.bb (renamed from meta-oe/recipes-multimedia/webm/libvpx_1.14.0.bb)2
7 files changed, 60 insertions, 10 deletions
diff --git a/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb b/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb
index 9fd91114d..bbce3e3bf 100644
--- a/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb
+++ b/meta-oe/recipes-multimedia/cdrkit/cdrkit_1.1.11.bb
@@ -13,6 +13,7 @@ SRC_URI = "${DEBIAN_MIRROR}/main/c/${BPN}/${BPN}_${PV}.orig.tar.gz \
13 file://0001-genisoimage-Add-missing-extern-definition.patch \ 13 file://0001-genisoimage-Add-missing-extern-definition.patch \
14 file://0001-add-new-option-eltorito-platform.patch \ 14 file://0001-add-new-option-eltorito-platform.patch \
15 file://0001-genisoimage-Add-checksum.h-and-md5.h-for-function-pr.patch \ 15 file://0001-genisoimage-Add-checksum.h-and-md5.h-for-function-pr.patch \
16 file://fix-incompatible-pointer-type-error.patch \
16 " 17 "
17SRC_URI:append:class-nativesdk = " \ 18SRC_URI:append:class-nativesdk = " \
18 file://0001-install-netscsid-to-bin-for-nativesdk.patch \ 19 file://0001-install-netscsid-to-bin-for-nativesdk.patch \
diff --git a/meta-oe/recipes-multimedia/cdrkit/files/fix-incompatible-pointer-type-error.patch b/meta-oe/recipes-multimedia/cdrkit/files/fix-incompatible-pointer-type-error.patch
new file mode 100644
index 000000000..887a54f7f
--- /dev/null
+++ b/meta-oe/recipes-multimedia/cdrkit/files/fix-incompatible-pointer-type-error.patch
@@ -0,0 +1,44 @@
1Fix incompatible pointer type error when gcc option '-Wincompatible-pointer-types' set:
2
3cdrkit-1.1.11/genisoimage/eltorito.c:399:41: error: passing argument 1 of 'set_721' from incompatible pointer type [-Wincompatible-pointer-types]
4 399 | set_721(&last_section_header->entry_count, nentries);
5 | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
6 | |
7 | char (*)[2]
8In file included from cdrkit/1.1.11/cdrkit-1.1.11/genisoimage/eltorito.c:39:
9cdrkit-1.1.11/genisoimage/genisoimage.h:507:21: note: expected 'char *' but argument is of type 'char (*)[2]'
10 507 | extern void set_721(char *, unsigned int);
11 | ^~~~~~
12
13Upstream-Status: Inactive-Upstream [lastrelease: 2010]
14
15[1]: https://en.wikipedia.org/wiki/Cdrkit
16
17Signed-off-by: Kai Kang <kai.kang@windriver.com>
18
19---
20 genisoimage/eltorito.c | 4 ++--
21 1 file changed, 2 insertions(+), 2 deletions(-)
22
23diff --git a/genisoimage/eltorito.c b/genisoimage/eltorito.c
24index a804988..e48d58c 100644
25--- a/genisoimage/eltorito.c
26+++ b/genisoimage/eltorito.c
27@@ -396,7 +396,7 @@ get_torito_desc(struct eltorito_boot_descriptor *boot_desc)
28 (arch != newarch) ||
29 (current_boot_entry->type & ELTORITO_SECTION_HEADER)) {
30 if (last_section_header)
31- set_721(&last_section_header->entry_count, nentries);
32+ set_721((char *)(&last_section_header->entry_count), nentries);
33 nentries = 1;
34 last_section_header = (struct eltorito_sectionheader_entry *)
35 (de2->table + offset);
36@@ -419,7 +419,7 @@ get_torito_desc(struct eltorito_boot_descriptor *boot_desc)
37 }
38
39 if (last_section_header) {
40- set_721(&last_section_header->entry_count, nentries);
41+ set_721((char *)(&last_section_header->entry_count), nentries);
42 last_section_header->header_id[0] = EL_TORITO_SHDR_ID_LAST_SHDR;
43 }
44
diff --git a/meta-oe/recipes-multimedia/libass/libass_0.17.1.bb b/meta-oe/recipes-multimedia/libass/libass_0.17.2.bb
index 800ad1b15..e239d028e 100644
--- a/meta-oe/recipes-multimedia/libass/libass_0.17.1.bb
+++ b/meta-oe/recipes-multimedia/libass/libass_0.17.2.bb
@@ -7,8 +7,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=a42532a0684420bdb15556c3cdd49a75"
7 7
8DEPENDS = "fontconfig freetype fribidi harfbuzz" 8DEPENDS = "fontconfig freetype fribidi harfbuzz"
9 9
10SRC_URI = "git://github.com/libass/libass.git;protocol=https;branch=0.17.1-branch" 10SRC_URI = "git://github.com/libass/libass.git;protocol=https;branch=master"
11SRCREV = "e8ad72accd3a84268275a9385beb701c9284e5b3" 11SRCREV = "cbb48cc4f2f076300004b8b06a86bec55281d0c2"
12S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13 13
14inherit autotools pkgconfig 14inherit autotools pkgconfig
diff --git a/meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb b/meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb
index eced6c772..8df0e9a2c 100644
--- a/meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb
+++ b/meta-oe/recipes-multimedia/libjxl/libjxl_0.10.2.bb
@@ -18,7 +18,6 @@ EXTRA_OECMAKE = " \
18 -DJPEGXL_ENABLE_PLUGINS=ON \ 18 -DJPEGXL_ENABLE_PLUGINS=ON \
19 -DBUILD_TESTING=OFF \ 19 -DBUILD_TESTING=OFF \
20 -DJPEGXL_WARNINGS_AS_ERRORS=OFF \ 20 -DJPEGXL_WARNINGS_AS_ERRORS=OFF \
21 -DJPEGXL_ENABLE_SIZELESS_VECTORS=ON \
22 -DJPEGXL_ENABLE_SJPEG=OFF \ 21 -DJPEGXL_ENABLE_SJPEG=OFF \
23 -DJPEGXL_ENABLE_BENCHMARK=OFF \ 22 -DJPEGXL_ENABLE_BENCHMARK=OFF \
24 -DJPEGXL_ENABLE_EXAMPLES=OFF \ 23 -DJPEGXL_ENABLE_EXAMPLES=OFF \
@@ -31,9 +30,15 @@ EXTRA_OECMAKE = " \
31 -DJPEGXL_ENABLE_TOOLS=OFF \ 30 -DJPEGXL_ENABLE_TOOLS=OFF \
32" 31"
33 32
34PACKAGECONFIG ?= "mime gdk-pixbuf-loader" 33PACKAGECONFIG ?= "mime gdk-pixbuf-loader sizeless-vectors"
34# libjxl/0.10.2/recipe-sysroot/usr/include/hwy/ops/rvv-inl.h:591:17: error: use
35# of undeclared identifier '__riscv_vsetvlmax_e8mf8'
36# 591 | HWY_RVV_FOREACH(HWY_RVV_LANES, Lanes, setvlmax_e, _ALL)
37# | ^
38PACKAGECONFIG:remove:riscv64 = "sizeless-vectors"
35PACKAGECONFIG[gdk-pixbuf-loader] = "-DJPEGXL_ENABLE_PLUGIN_GDKPIXBUF=ON,-DJPEGXL_ENABLE_PLUGIN_GDKPIXBUF=OFF,gdk-pixbuf" 39PACKAGECONFIG[gdk-pixbuf-loader] = "-DJPEGXL_ENABLE_PLUGIN_GDKPIXBUF=ON,-DJPEGXL_ENABLE_PLUGIN_GDKPIXBUF=OFF,gdk-pixbuf"
36PACKAGECONFIG[gimp] = "-DJPEGXL_ENABLE_PLUGIN_GIMP210=ON,-DJPEGXL_ENABLE_PLUGIN_GIMP210=OFF,gimp" 40PACKAGECONFIG[gimp] = "-DJPEGXL_ENABLE_PLUGIN_GIMP210=ON,-DJPEGXL_ENABLE_PLUGIN_GIMP210=OFF,gimp"
37PACKAGECONFIG[mime] = "-DJPEGXL_ENABLE_PLUGIN_MIME=ON,-DJPEGXL_ENABLE_PLUGIN_MIME=OFF" 41PACKAGECONFIG[mime] = "-DJPEGXL_ENABLE_PLUGIN_MIME=ON,-DJPEGXL_ENABLE_PLUGIN_MIME=OFF"
42PACKAGECONFIG[sizeless-vectors] = "-DJPEGXL_ENABLE_SIZELESS_VECTORS=ON,-DJPEGXL_ENABLE_SIZELESS_VECTORS=OFF"
38 43
39FILES:${PN} += "${libdir}/gdk-pixbuf-2.0 ${datadir}" 44FILES:${PN} += "${libdir}/gdk-pixbuf-2.0 ${datadir}"
diff --git a/meta-oe/recipes-multimedia/live555/live555_20210824.bb b/meta-oe/recipes-multimedia/live555/live555_20210824.bb
index a899049b7..80c770c3e 100644
--- a/meta-oe/recipes-multimedia/live555/live555_20210824.bb
+++ b/meta-oe/recipes-multimedia/live555/live555_20210824.bb
@@ -27,7 +27,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
27TARGET_CC_ARCH += "${LDFLAGS}" 27TARGET_CC_ARCH += "${LDFLAGS}"
28 28
29do_configure() { 29do_configure() {
30 cp ${WORKDIR}/config.linux-cross . 30 cp ${UNPACKDIR}/config.linux-cross .
31 echo "COMPILE_OPTS+=" -fPIC -DXLOCALE_NOT_USED"" >> config.linux-cross 31 echo "COMPILE_OPTS+=" -fPIC -DXLOCALE_NOT_USED"" >> config.linux-cross
32 ./genMakefiles linux-cross 32 ./genMakefiles linux-cross
33} 33}
diff --git a/meta-oe/recipes-multimedia/webm/libvpx/libvpx-configure-support-blank-prefix.patch b/meta-oe/recipes-multimedia/webm/libvpx/libvpx-configure-support-blank-prefix.patch
index 463651aa4..bd3d69788 100644
--- a/meta-oe/recipes-multimedia/webm/libvpx/libvpx-configure-support-blank-prefix.patch
+++ b/meta-oe/recipes-multimedia/webm/libvpx/libvpx-configure-support-blank-prefix.patch
@@ -1,4 +1,4 @@
1From 2829e6998b7595dd2108c1497fdd02485ef99e2c Mon Sep 17 00:00:00 2001 1From 1bbbf27a23c91dcc271b773a97153063461b986d Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net> 2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Tue, 16 Aug 2011 16:04:35 +0200 3Date: Tue, 16 Aug 2011 16:04:35 +0200
4Subject: [PATCH] Upstream: not yet 4Subject: [PATCH] Upstream: not yet
@@ -11,10 +11,10 @@ Upstream-Status: Pending
11 1 file changed, 16 insertions(+), 4 deletions(-) 11 1 file changed, 16 insertions(+), 4 deletions(-)
12 12
13diff --git a/build/make/configure.sh b/build/make/configure.sh 13diff --git a/build/make/configure.sh b/build/make/configure.sh
14index b645a666f..0b99a8b38 100644 14index 93643f3de..e84198200 100644
15--- a/build/make/configure.sh 15--- a/build/make/configure.sh
16+++ b/build/make/configure.sh 16+++ b/build/make/configure.sh
17@@ -658,6 +658,8 @@ process_common_cmdline() { 17@@ -692,6 +692,8 @@ process_common_cmdline() {
18 ;; 18 ;;
19 --prefix=*) 19 --prefix=*)
20 prefix="${optval}" 20 prefix="${optval}"
@@ -23,7 +23,7 @@ index b645a666f..0b99a8b38 100644
23 ;; 23 ;;
24 --libdir=*) 24 --libdir=*)
25 libdir="${optval}" 25 libdir="${optval}"
26@@ -687,13 +689,23 @@ process_cmdline() { 26@@ -721,13 +723,23 @@ process_cmdline() {
27 } 27 }
28 28
29 post_process_common_cmdline() { 29 post_process_common_cmdline() {
diff --git a/meta-oe/recipes-multimedia/webm/libvpx_1.14.0.bb b/meta-oe/recipes-multimedia/webm/libvpx_1.14.1.bb
index b4d49842e..f32c7842c 100644
--- a/meta-oe/recipes-multimedia/webm/libvpx_1.14.0.bb
+++ b/meta-oe/recipes-multimedia/webm/libvpx_1.14.1.bb
@@ -7,7 +7,7 @@ LICENSE = "BSD-3-Clause"
7 7
8LIC_FILES_CHKSUM = "file://LICENSE;md5=d5b04755015be901744a78cc30d390d4" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=d5b04755015be901744a78cc30d390d4"
9 9
10SRCREV = "602e2e8979d111b02c959470da5322797dd96a19" 10SRCREV = "12f3a2ac603e8f10742105519e0cd03c3b8f71dd"
11SRC_URI += "git://chromium.googlesource.com/webm/libvpx;protocol=https;branch=main \ 11SRC_URI += "git://chromium.googlesource.com/webm/libvpx;protocol=https;branch=main \
12 file://libvpx-configure-support-blank-prefix.patch \ 12 file://libvpx-configure-support-blank-prefix.patch \
13 " 13 "