summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/webp/libwebp_0.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-multimedia/webp/libwebp_0.4.0.bb')
-rw-r--r--meta-oe/recipes-multimedia/webp/libwebp_0.4.0.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/webp/libwebp_0.4.0.bb b/meta-oe/recipes-multimedia/webp/libwebp_0.4.0.bb
new file mode 100644
index 000000000..7663b3b0b
--- /dev/null
+++ b/meta-oe/recipes-multimedia/webp/libwebp_0.4.0.bb
@@ -0,0 +1,47 @@
1SUMMARY = "WebP is an image format designed for the Web"
2DESCRIPTION = "WebP is a method of lossy and lossless compression that can be \
3 used on a large variety of photographic, translucent and \
4 graphical images found on the web. The degree of lossy \
5 compression is adjustable so a user can choose the trade-off \
6 between file size and image quality. WebP typically achieves \
7 an average of 30% more compression than JPEG and JPEG 2000, \
8 without loss of image quality."
9HOMEPAGE = "https://developers.google.com/speed/webp/"
10SECTION = "libs"
11
12LICENSE = "BSD"
13LIC_FILES_CHKSUM = "file://PATENTS;md5=7ec8a34de2073ea13ea2991006246d20"
14
15DEPENDS = "giflib"
16
17SRC_URI = "https://webp.googlecode.com/files/${BP}.tar.gz"
18SRC_URI[md5sum] = "c8dd1d26eb9566833aba269b86d97e68"
19SRC_URI[sha256sum] = "31913577e96386556855b41d210736449445fe96cfbe9289014e9b8afa944d69"
20
21EXTRA_OECONF = " \
22 --disable-experimental \
23 --disable-wic \
24 --enable-libwebpmux \
25 --enable-libwebpdemux \
26 --enable-threading \
27"
28
29inherit autotools lib_package
30
31PACKAGECONFIG ??= ""
32
33# libwebpdecoder is a subset of libwebp, don't build it unless requested
34PACKAGECONFIG[decoder] = "--enable-libwebpdecoder,--disable-libwebpdecoder"
35
36# Apply for examples programs: cwebp and dwebp
37PACKAGECONFIG[jpeg] = ",ac_cv_header_jpeglib_h=no,jpeg"
38PACKAGECONFIG[png] = ",ac_cv_header_png_h=no,libpng"
39PACKAGECONFIG[tiff] = ",ac_cv_header_tiffio_h=no,tiff"
40
41# Apply only for example program vwebp
42PACKAGECONFIG[gl] = ",,mesa-glut"
43
44PACKAGES =+ "${PN}-gif2webp"
45
46DESCRIPTION_${PN}-gif2webp = "Simple tool to convert animated GIFs to WebP"
47FILES_${PN}-gif2webp = "${bindir}/gif2webp"