summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb')
-rw-r--r--meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb145
1 files changed, 145 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb b/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb
new file mode 100644
index 000000000..7c04ff178
--- /dev/null
+++ b/meta-oe/recipes-multimedia/mplayer/mplayer2_git.bb
@@ -0,0 +1,145 @@
1SUMMARY = "Open Source multimedia player"
2SECTION = "multimedia"
3HOMEPAGE = "http://www.mplayerhq.hu/"
4DEPENDS = "libvpx libdvdread libtheora virtual/libsdl ffmpeg xsp zlib \
5 libpng jpeg liba52 freetype fontconfig alsa-lib lzo ncurses \
6 libxv virtual/libx11 libass speex faad2"
7
8RDEPENDS_${PN} = "mplayer-common"
9PROVIDES = "mplayer"
10RPROVIDES_${PN} = "mplayer"
11RCONFLICTS_${PN} = "mplayer"
12
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=d32239bcb673463ab874e80d47fae504"
15
16PNBLACKLIST[mplayer2] ?= "Requires newer libav which has negative D_P"
17
18SRC_URI = "git://repo.or.cz/mplayer.git \
19 file://0001-configure-don-t-disable-ASS-support-when-explicitly-.patch \
20"
21
22SRCREV = "2c378c71a4d9b1df382db9aa787b646628b4e3f9"
23
24ARM_INSTRUCTION_SET = "arm"
25
26PV = "2.0+gitr${SRCPV}"
27PR = "r13"
28
29PARALLEL_MAKE = ""
30
31S = "${WORKDIR}/git"
32
33FILES_${PN} = "${bindir}/mplayer ${libdir} /usr/etc/mplayer/"
34CONFFILES_${PN} += "/usr/etc/mplayer/input.conf \
35 /usr/etc/mplayer/example.conf \
36 /usr/etc/mplayer/codecs.conf \
37"
38
39inherit autotools-brokensep pkgconfig
40
41EXTRA_OECONF = " \
42 --prefix=/usr \
43 --mandir=${mandir} \
44 --target=${SIMPLE_TARGET_SYS} \
45 \
46 --disable-lirc \
47 --disable-lircc \
48 --disable-joystick \
49 --disable-vm \
50 --disable-xf86keysym \
51 --enable-tv \
52 --enable-tv-v4l2 \
53 --disable-tv-bsdbt848 \
54 --enable-rtc \
55 --enable-networking \
56 --disable-smb \
57 --disable-dvdnav \
58 --enable-dvdread \
59 --disable-dvdread-internal \
60 --disable-libdvdcss-internal \
61 --disable-enca \
62 --disable-ftp \
63 --disable-vstream \
64 \
65 --disable-gif \
66 --enable-png \
67 --enable-jpeg \
68 --disable-libcdio \
69 --disable-qtx \
70 --disable-xanim \
71 --disable-real \
72 --disable-xvid \
73 \
74 --enable-speex \
75 --enable-theora \
76 --disable-ladspa \
77 --disable-libdv \
78 --enable-mad \
79 --disable-xmms \
80 --disable-musepack \
81 \
82 --disable-gl \
83 --enable-sdl \
84 --disable-caca \
85 --disable-directx \
86 --disable-dvb \
87 --enable-xv \
88 --disable-vm \
89 --disable-xinerama \
90 --enable-x11 \
91 --disable-directfb \
92 --disable-tga \
93 --disable-pnm \
94 --disable-md5sum \
95 \
96 --enable-alsa \
97 --enable-ossaudio \
98 --disable-pulse \
99 --disable-jack \
100 --disable-openal \
101 --enable-select \
102 --enable-libass \
103 \
104 --extra-libs=' -lXext -lX11 -lvorbis -ltheoradec -lasound ' \
105"
106# -ltheoradec is missing in:
107# libmpcodecs/vd_theora.o: undefined reference to symbol 'theora_decode_init@@libtheora.so.1.0'
108
109EXTRA_OECONF_append_armv6 = " --enable-armv6"
110EXTRA_OECONF_append_armv7a = " --enable-armv6 --enable-neon"
111
112PACKAGECONFIG[mad] = "--enable-mad,--disable-mad,libmad"
113PACKAGECONFIG[a52] = "--enable-liba52,--disable-liba52,liba52"
114PACKAGECONFIG[lame] = ",,lame"
115
116FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O4 -ffast-math"
117BUILD_OPTIMIZATION = "${FULL_OPTIMIZATION}"
118
119CFLAGS_append = " -I${S}/libdvdread4 "
120
121do_configure() {
122 sed -i 's|/usr/include|${STAGING_INCDIR}|g' ${S}/configure
123 sed -i 's|/usr/lib|${STAGING_LIBDIR}|g' ${S}/configure
124 sed -i 's|/usr/\S*include[\w/]*||g' ${S}/configure
125 sed -i 's|/usr/\S*lib[\w/]*||g' ${S}/configure
126 sed -i 's|_install_strip="-s"|_install_strip=""|g' ${S}/configure
127 sed -i 's|HOST_CC|BUILD_CC|' ${S}/Makefile
128
129 export SIMPLE_TARGET_SYS="$(echo ${TARGET_SYS} | sed s:${TARGET_VENDOR}::g)"
130 ./configure ${EXTRA_OECONF}
131
132}
133
134do_compile () {
135 oe_runmake
136}
137
138do_install() {
139 oe_runmake 'DESTDIR=${D}' install-no-man
140 install -d ${D}/usr/etc/mplayer
141 install ${S}/etc/input.conf ${D}/usr/etc/mplayer/
142 install ${S}/etc/example.conf ${D}/usr/etc/mplayer/
143 install ${S}/etc/codecs.conf ${D}/usr/etc/mplayer/
144 [ -e ${D}/usr/lib ] && rmdir ${D}/usr/lib
145}