diff options
Diffstat (limited to 'meta-oe/recipes-graphics/spir')
-rw-r--r-- | meta-oe/recipes-graphics/spir/files/0001-Add-install-PHONY-target-in-Makefile.patch | 31 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/spir/spirv-shader-generator_git.bb | 22 |
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/spir/files/0001-Add-install-PHONY-target-in-Makefile.patch b/meta-oe/recipes-graphics/spir/files/0001-Add-install-PHONY-target-in-Makefile.patch new file mode 100644 index 000000000..78598ea1e --- /dev/null +++ b/meta-oe/recipes-graphics/spir/files/0001-Add-install-PHONY-target-in-Makefile.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 8d9870b66c3cfcf12ce7e8e013946e2a215bb722 Mon Sep 17 00:00:00 2001 | ||
2 | From: Ankit Navik <ankit.tarot@gmail.com> | ||
3 | Date: Sat, 22 Dec 2018 19:16:02 +0530 | ||
4 | Subject: [PATCH] Add install PHONY target in Makefile | ||
5 | |||
6 | --- | ||
7 | Makefile | 8 +++++++- | ||
8 | 1 file changed, 7 insertions(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/Makefile b/Makefile | ||
11 | index 0564b65..0993372 100644 | ||
12 | --- a/Makefile | ||
13 | +++ b/Makefile | ||
14 | @@ -35,7 +35,13 @@ $(STATIC_LIB): $(OBJECTS) | ||
15 | %.o: %.cpp | ||
16 | $(CXX) -c -o $@ $< $(CXXFLAGS) -MMD | ||
17 | |||
18 | +install: | ||
19 | + mkdir -p $(TARGET_DIR_BIN) | ||
20 | + mkdir -p $(TARGET_DIR_LIB) | ||
21 | + cp $(TARGET) $(TARGET_DIR_BIN)/ | ||
22 | + cp $(STATIC_LIB) $(TARGET_DIR_LIB)/ | ||
23 | + | ||
24 | clean: | ||
25 | rm -f $(TARGET) $(OBJECTS) $(CLI_OBJECTS) $(STATIC_LIB) $(DEPS) | ||
26 | |||
27 | -.PHONY: clean | ||
28 | +.PHONY: all install clean | ||
29 | -- | ||
30 | 2.7.4 | ||
31 | |||
diff --git a/meta-oe/recipes-graphics/spir/spirv-shader-generator_git.bb b/meta-oe/recipes-graphics/spir/spirv-shader-generator_git.bb new file mode 100644 index 000000000..b787972da --- /dev/null +++ b/meta-oe/recipes-graphics/spir/spirv-shader-generator_git.bb | |||
@@ -0,0 +1,22 @@ | |||
1 | SUMMARY = "SPIRV-Cross is a tool designed for parsing and converting SPIR-V \ | ||
2 | to other shader languages" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
5 | SECTION = "graphics" | ||
6 | |||
7 | S = "${WORKDIR}/git" | ||
8 | SRCREV = "ed16b3e69985feaf565efbecea70a1cc2fca2a58" | ||
9 | SRC_URI = "git://github.com/KhronosGroup/SPIRV-Cross.git \ | ||
10 | file://0001-Add-install-PHONY-target-in-Makefile.patch \ | ||
11 | " | ||
12 | |||
13 | EXTRA_OEMAKE += 'TARGET_DIR_LIB="${D}${libdir}"' | ||
14 | EXTRA_OEMAKE += 'TARGET_DIR_BIN="${D}${bindir}"' | ||
15 | |||
16 | do_compile () { | ||
17 | cd ${S} && oe_runmake | ||
18 | } | ||
19 | |||
20 | do_install () { | ||
21 | cd ${S} && oe_runmake install | ||
22 | } | ||