summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/panel-mipi-dbi/panel-mipi-dbi-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/panel-mipi-dbi/panel-mipi-dbi-native_git.bb')
-rw-r--r--meta-oe/recipes-graphics/panel-mipi-dbi/panel-mipi-dbi-native_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/panel-mipi-dbi/panel-mipi-dbi-native_git.bb b/meta-oe/recipes-graphics/panel-mipi-dbi/panel-mipi-dbi-native_git.bb
new file mode 100644
index 000000000..0e88e84af
--- /dev/null
+++ b/meta-oe/recipes-graphics/panel-mipi-dbi/panel-mipi-dbi-native_git.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Firmware file compiler for the panel-mipi-dbi display driver"
2DESCRIPTION = "The panel-mipi-dbi Linux display driver allows using the same \
3 driver for most MIPI DBI based display panels. \
4 This means many displays attached via SPI, even if the \
5 datasheet does not explicitly mention DBI support. \
6 To do so it uses tiny firmware files that contain \
7 display/controller-specific initialization commands. \
8 The mipi-dbi-cmd tool compiles these firmware files from a \
9 text format to a firmware blob format."
10HOMEPAGE = "https://github.com/notro/panel-mipi-dbi"
11SECTION = "graphics"
12LICENSE = "CC0-1.0"
13LIC_FILES_CHKSUM = "file://mipi-dbi-cmd;beginline=4;endline=13;md5=5e3d3f14cc87aa9e8976d728520cbcae"
14SRCREV = "1cbd40135a8c7f25d7b444a7fac77fd3c3ad471e"
15
16SRC_URI = "git://github.com/notro/panel-mipi-dbi.git;protocol=https;branch=main"
17
18S = "${WORKDIR}/git"
19
20inherit native
21
22do_configure[noexec] = "1"
23do_compile[noexec] = "1"
24do_install () {
25 install -D -p -m 0755 ${S}/mipi-dbi-cmd ${D}${bindir}/mipi-dbi-cmd
26}
27
28RDEPENDS:${PN} += "python3-native"