summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/lvgl/lvgl_8.3.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/lvgl/lvgl_8.3.11.bb')
-rw-r--r--meta-oe/recipes-graphics/lvgl/lvgl_8.3.11.bb44
1 files changed, 0 insertions, 44 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lvgl_8.3.11.bb b/meta-oe/recipes-graphics/lvgl/lvgl_8.3.11.bb
deleted file mode 100644
index 252368061..000000000
--- a/meta-oe/recipes-graphics/lvgl/lvgl_8.3.11.bb
+++ /dev/null
@@ -1,44 +0,0 @@
1# SPDX-FileCopyrightText: Huawei Inc.
2#
3# SPDX-License-Identifier: MIT
4
5HOMEPAGE = "https://lvgl.io/"
6DESCRIPTION = "LVGL is an OSS graphics library to create embedded GUI"
7SUMMARY = "Light and Versatile Graphics Library"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a"
10
11SRC_URI = "git://github.com/lvgl/lvgl;protocol=https;branch=release/v8.3"
12SRCREV = "74d0a816a440eea53e030c4f1af842a94f7ce3d3"
13
14inherit cmake
15
16EXTRA_OECMAKE = "-DLIB_INSTALL_DIR=${baselib}"
17S = "${WORKDIR}/git"
18
19ALLOW_EMPTY:${PN} = "1"
20
21LVGL_CONFIG_LV_MEM_CUSTOM ?= "0"
22LVGL_CONFIG_LV_COLOR_DEPTH ?= "32"
23
24# Upstream does not support a default configuration
25# but propose a default "disabled" template, which is used as reference
26# More configuration can be done using external configuration variables
27do_configure:prepend() {
28 [ -r "${S}/lv_conf.h" ] \
29 || sed -e 's|#if 0 .*Set it to "1" to enable .*|#if 1 // Enabled|g' \
30 -e "s|\(#define LV_COLOR_DEPTH \).*|\1 ${LVGL_CONFIG_LV_COLOR_DEPTH}|g" \
31 \
32 -e "s|\(#define LV_MEM_CUSTOM .*\)0|\1${LVGL_CONFIG_LV_MEM_CUSTOM}|g" \
33 \
34 -e "s|\(#define LV_TICK_CUSTOM \).*|\1 1|g" \
35 -e "s|\(#define LV_TICK_CUSTOM_INCLUDE \).*|\1 <stdint.h>|g" \
36 -e "s|\(#define LV_TICK_CUSTOM_SYS_TIME_EXPR \).*|extern uint32_t custom_tick_get(void);\n\1 (custom_tick_get())|g" \
37 \
38 < "${S}/lv_conf_template.h" > "${S}/lv_conf.h"
39}
40
41FILES:${PN}-dev += "\
42 ${includedir}/${PN}/ \
43 ${includedir}/${PN}/lvgl/ \
44 "