summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/libvncserver/libvncserver_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/libvncserver/libvncserver_git.bb')
-rw-r--r--meta-oe/recipes-graphics/libvncserver/libvncserver_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/libvncserver/libvncserver_git.bb b/meta-oe/recipes-graphics/libvncserver/libvncserver_git.bb
new file mode 100644
index 000000000..25917756f
--- /dev/null
+++ b/meta-oe/recipes-graphics/libvncserver/libvncserver_git.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "library for easy implementation of a RDP/VNC server"
2HOMEPAGE = "https://libvnc.github.io"
3SECTION = "libs"
4PRIORITY = "optional"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=361b6b837cad26c6900a926b62aada5f"
7
8PACKAGECONFIG ??= "gcrypt gnutls jpeg png ${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)} sdl zlib"
9PACKAGECONFIG[gcrypt] = ",,libgcrypt,libgcrypt"
10PACKAGECONFIG[gnutls] = ",,gnutls"
11PACKAGECONFIG[jpeg] = ",-DWITH_JPEG=OFF,jpeg"
12PACKAGECONFIG[openssl] = ",,openssl"
13PACKAGECONFIG[png] = ",-DWITH_PNG=OFF,libpng,libpng"
14PACKAGECONFIG[systemd] = ",,systemd"
15PACKAGECONFIG[sdl] = ",,libsdl2"
16PACKAGECONFIG[zlib] = ",,zlib"
17
18inherit cmake
19
20SRC_URI = "git://github.com/LibVNC/libvncserver"
21SRCREV = "f997b5a75fa171d79c5e568b7157fba83c8d8355"
22
23S = "${WORKDIR}/git"