summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/gphoto2
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/gphoto2')
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0001-scripts-remove-bashisms.patch149
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0002-correct-jpeg-memsrcdest-support.patch54
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/avoid_using_sprintf.patch133
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2/0001-configure.ac-remove-AM_PO_SUBDIRS.patch (renamed from meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0001-configure.ac-remove-AM_PO_SUBDIRS.patch)0
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2/10-camera-libgphoto2-device.fdi (renamed from meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/10-camera-libgphoto2-device.fdi)0
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2/10-camera-libgphoto2.fdi (renamed from meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/10-camera-libgphoto2.fdi)0
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2/40-libgphoto2.rules (renamed from meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/40-libgphoto2.rules)0
-rw-r--r--meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.14.bb (renamed from meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.8.bb)8
8 files changed, 3 insertions, 341 deletions
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0001-scripts-remove-bashisms.patch b/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0001-scripts-remove-bashisms.patch
deleted file mode 100644
index 0e0dc879b..000000000
--- a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0001-scripts-remove-bashisms.patch
+++ /dev/null
@@ -1,149 +0,0 @@
1From c00e63e97d8718836ba011d9172128732eecf001 Mon Sep 17 00:00:00 2001
2From: Ismo Puustinen <ismo.puustinen@intel.com>
3Date: Tue, 24 Jan 2017 22:24:05 +0200
4Subject: [PATCH] scripts: remove bashisms.
5
6Convert bash scripts to more generic shell scripts. This removes the
7strict bash dependency and the scripts should now run with any posix
8shell. Also fix the issues reported by shellcheck while at it.
9
10Upstream-status: Accepted [https://github.com/gphoto/libgphoto2/commit/39b4395532058c0edb9a56d0ff04e48a472e4743]
11
12---
13 packaging/generic/check-ptp-camera | 12 ++++++------
14 packaging/linux-hotplug/gphoto-set-procperm | 14 +++++++-------
15 packaging/linux-hotplug/usbcam.console | 4 ++--
16 packaging/linux-hotplug/usbcam.group | 2 +-
17 packaging/linux-hotplug/usbcam.user | 2 +-
18 packaging/linux-hotplug/usbcam.x11-app | 4 ++--
19 6 files changed, 19 insertions(+), 19 deletions(-)
20
21diff --git a/packaging/generic/check-ptp-camera b/packaging/generic/check-ptp-camera
22index 1793fc8..bc3c6ac 100644
23--- a/packaging/generic/check-ptp-camera
24+++ b/packaging/generic/check-ptp-camera
25@@ -1,4 +1,4 @@
26-#!/bin/bash
27+#!/bin/sh
28 # This program is free software; you can redistribute it and/or
29 # modify it under the terms of the GNU Lesser General Public
30 # License as published by the Free Software Foundation; either
31@@ -20,13 +20,13 @@ INTERFACE="${1:-06/01/01}"
32
33 BASENAME=${DEVPATH##*/}
34 for d in /sys/${DEVPATH}/${BASENAME}:*; do
35- [[ -d ${d} ]] || continue
36- INTERFACEID="$(< ${d}/bInterfaceClass)"
37- INTERFACEID="${INTERFACEID}/$(< ${d}/bInterfaceSubClass)"
38- INTERFACEID="${INTERFACEID}/$(< ${d}/bInterfaceProtocol)"
39+ [ -d "${d}" ] || continue
40+ INTERFACEID="$(cat "${d}"/bInterfaceClass)"
41+ INTERFACEID="${INTERFACEID}/$(cat "${d}"/bInterfaceSubClass)"
42+ INTERFACEID="${INTERFACEID}/$(cat "${d}"/bInterfaceProtocol)"
43
44 #echo ${d}: ${INTERFACEID}
45- if [[ ${INTERFACE} == ${INTERFACEID} ]]; then
46+ if [ "${INTERFACE}" = "${INTERFACEID}" ]; then
47 # Found interface
48 exit 0
49 fi
50diff --git a/packaging/linux-hotplug/gphoto-set-procperm b/packaging/linux-hotplug/gphoto-set-procperm
51index d72ee68..977cbf5 100644
52--- a/packaging/linux-hotplug/gphoto-set-procperm
53+++ b/packaging/linux-hotplug/gphoto-set-procperm
54@@ -1,4 +1,4 @@
55-#!/bin/bash
56+#!/bin/sh
57 # This program is free software; you can redistribute it and/or
58 # modify it under the terms of the GNU Lesser General Public
59 # License as published by the Free Software Foundation; either
60@@ -18,22 +18,22 @@
61 # This is taken from Fedora Core gphoto2 package.
62 # http://cvs.fedora.redhat.com/viewcvs/*checkout*/devel/gphoto2/gphoto-set-procperm
63
64-console_user=`cat /var/run/console/console.lock`
65+console_user=$(cat /var/run/console/console.lock)
66
67 if [ -z "$console_user" ] ; then
68 exit 1
69 fi
70
71-if [ -z "$HAL_PROP_USB_BUS_NUMBER" -o -z "$HAL_PROP_USB_LINUX_DEVICE_NUMBER" ] ; then
72+if [ -z "$HAL_PROP_USB_BUS_NUMBER" ] || [ -z "$HAL_PROP_USB_LINUX_DEVICE_NUMBER" ] ; then
73 exit 1
74 fi
75
76-if [ $HAL_PROP_USB_BUS_NUMBER -lt 0 -o $HAL_PROP_USB_LINUX_DEVICE_NUMBER -lt 0 ] ; then
77+if [ "$HAL_PROP_USB_BUS_NUMBER" -lt 0 ] || [ "$HAL_PROP_USB_LINUX_DEVICE_NUMBER" -lt 0 ] ; then
78 exit 1
79 fi
80
81
82-bus_num=`printf %.3u $HAL_PROP_USB_BUS_NUMBER`
83-dev_num=`printf %.3u $HAL_PROP_USB_LINUX_DEVICE_NUMBER`
84+bus_num=$(printf %.3u "$HAL_PROP_USB_BUS_NUMBER")
85+dev_num=$(printf %.3u "$HAL_PROP_USB_LINUX_DEVICE_NUMBER")
86
87-chown $console_user /proc/bus/usb/$bus_num/$dev_num
88+chown "$console_user" /proc/bus/usb/"$bus_num"/"$dev_num"
89diff --git a/packaging/linux-hotplug/usbcam.console b/packaging/linux-hotplug/usbcam.console
90index d72128f..7ac6dc5 100755
91--- a/packaging/linux-hotplug/usbcam.console
92+++ b/packaging/linux-hotplug/usbcam.console
93@@ -1,4 +1,4 @@
94-#!/bin/bash
95+#!/bin/sh
96 # This program is free software; you can redistribute it and/or
97 # modify it under the terms of the GNU Lesser General Public
98 # License as published by the Free Software Foundation; either
99@@ -50,7 +50,7 @@ then
100 /var/lock/console.lock
101 do
102 if [ -f "$conlock" ]; then
103- CONSOLEOWNER=`cat $conlock`
104+ CONSOLEOWNER=$(cat $conlock)
105 fi
106 done
107 if [ -n "$CONSOLEOWNER" ]
108diff --git a/packaging/linux-hotplug/usbcam.group b/packaging/linux-hotplug/usbcam.group
109index f96c33d..8761fac 100755
110--- a/packaging/linux-hotplug/usbcam.group
111+++ b/packaging/linux-hotplug/usbcam.group
112@@ -1,4 +1,4 @@
113-#!/bin/bash
114+#!/bin/sh
115 # This program is free software; you can redistribute it and/or
116 # modify it under the terms of the GNU Lesser General Public
117 # License as published by the Free Software Foundation; either
118diff --git a/packaging/linux-hotplug/usbcam.user b/packaging/linux-hotplug/usbcam.user
119index c46f155..a3ba71a 100644
120--- a/packaging/linux-hotplug/usbcam.user
121+++ b/packaging/linux-hotplug/usbcam.user
122@@ -1,4 +1,4 @@
123-#!/bin/bash
124+#!/bin/sh
125 # This program is free software; you can redistribute it and/or
126 # modify it under the terms of the GNU Lesser General Public
127 # License as published by the Free Software Foundation; either
128diff --git a/packaging/linux-hotplug/usbcam.x11-app b/packaging/linux-hotplug/usbcam.x11-app
129index 023ae9b..618e7db 100644
130--- a/packaging/linux-hotplug/usbcam.x11-app
131+++ b/packaging/linux-hotplug/usbcam.x11-app
132@@ -1,4 +1,4 @@
133-#!/bin/bash
134+#!/bin/sh
135 # This program is free software; you can redistribute it and/or
136 # modify it under the terms of the GNU Lesser General Public
137 # License as published by the Free Software Foundation; either
138@@ -69,7 +69,7 @@ then
139 if [ "${USER}" != "root" ]
140 then
141 # we don't want to run this as root. definitely not.
142- cd "${DIRECTORY}"
143+ cd "${DIRECTORY}" || exit 1
144 usrhome=~${USER}
145 "${SU}" "${USER}" -c "${ENV} DISPLAY=${DISPLAY} HOME=${usrhome} ${X11_APP}"
146 fi
147--
1482.9.3
149
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0002-correct-jpeg-memsrcdest-support.patch b/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0002-correct-jpeg-memsrcdest-support.patch
deleted file mode 100644
index cf2d86da1..000000000
--- a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0002-correct-jpeg-memsrcdest-support.patch
+++ /dev/null
@@ -1,54 +0,0 @@
1--- libgphoto2-2.5.8/camlibs/ax203/jpeg_memsrcdest.h.orig 2016-06-15 09:03:20.625774684 -0400
2+++ libgphoto2-2.5.8/camlibs/ax203/jpeg_memsrcdest.h 2016-06-15 09:03:47.049774148 -0400
3@@ -1,5 +1,7 @@
4 #include <jpeglib.h>
5
6+#if JPEG_LIB_VERSION < 80 && !defined(MEM_SRCDST_SUPPORTED)
7+
8 void
9 jpeg_mem_src (j_decompress_ptr cinfo, unsigned char * buffer,
10 unsigned long bufsize);
11@@ -7,3 +9,5 @@
12 void
13 jpeg_mem_dest (j_compress_ptr cinfo, unsigned char ** outbuffer,
14 unsigned long * outsize);
15+
16+#endif
17--- libgphoto2-2.5.8/camlibs/ax203/jpeg_memsrcdest.c.orig 2016-06-15 09:03:58.689773913 -0400
18+++ libgphoto2-2.5.8/camlibs/ax203/jpeg_memsrcdest.c 2016-06-15 09:04:17.769773526 -0400
19@@ -26,7 +26,7 @@
20
21 /* libjpeg8 and later come with their own (API compatible) memory source
22 and dest */
23-#if JPEG_LIB_VERSION < 80
24+#if JPEG_LIB_VERSION < 80 && !defined(MEM_SRCDST_SUPPORTED)
25
26 /* Expanded data source object for memory input */
27
28--- libgphoto2-2.5.8/camlibs/jl2005c/jpeg_memsrcdest.h.orig 2016-06-15 09:05:01.893772632 -0400
29+++ libgphoto2-2.5.8/camlibs/jl2005c/jpeg_memsrcdest.h 2016-06-15 09:05:17.433772318 -0400
30@@ -1,5 +1,7 @@
31 #include <jpeglib.h>
32
33+#if JPEG_LIB_VERSION < 80 && !defined(MEM_SRCDST_SUPPORTED)
34+
35 void
36 jpeg_mem_src (j_decompress_ptr cinfo, unsigned char * buffer,
37 unsigned long bufsize);
38@@ -7,3 +9,5 @@
39 void
40 jpeg_mem_dest (j_compress_ptr cinfo, unsigned char ** outbuffer,
41 unsigned long * outsize);
42+
43+#endif
44--- libgphoto2-2.5.8/camlibs/jl2005c/jpeg_memsrcdest.c.orig 2016-06-15 09:04:42.641773022 -0400
45+++ libgphoto2-2.5.8/camlibs/jl2005c/jpeg_memsrcdest.c 2016-06-15 09:04:48.657772901 -0400
46@@ -26,7 +26,7 @@
47
48 /* libjpeg8 and later come with their own (API compatible) memory source
49 and dest */
50-#if JPEG_LIB_VERSION < 80
51+#if JPEG_LIB_VERSION < 80 && !defined(MEM_SRCDST_SUPPORTED)
52
53 /* Expanded data source object for memory input */
54
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/avoid_using_sprintf.patch b/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/avoid_using_sprintf.patch
deleted file mode 100644
index fba4c6964..000000000
--- a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/avoid_using_sprintf.patch
+++ /dev/null
@@ -1,133 +0,0 @@
1From 4adfe5a6c9db07537df302f3c17713515bf23a2e Mon Sep 17 00:00:00 2001
2From: Marcus Meissner <marcus@jet.franken.de>
3Date: Sat, 11 Jul 2015 09:38:13 +0000
4Subject: [PATCH] avoid use of sprintf to convert %% to %, duplicate the macro
5
6git-svn-id: https://svn.code.sf.net/p/gphoto/code/trunk/libgphoto2@15490 67ed7778-7388-44ab-90cf-0a291f65f57c
7---
8 camlibs/ptp2/chdk.c | 8 ++---
9 camlibs/ptp2/chdk_ptp.h | 82 +++++++++++++++++++++++++++++++++++++++++++++++++
10 2 files changed, 84 insertions(+), 6 deletions(-)
11
12diff --git a/camlibs/ptp2/chdk.c b/camlibs/ptp2/chdk.c
13index 5fb84ea..3b8a995 100644
14--- a/camlibs/ptp2/chdk.c
15+++ b/camlibs/ptp2/chdk.c
16@@ -1119,18 +1119,14 @@ chdk_camera_capture (Camera *camera, CameraCaptureType type, CameraFilePath *pat
17 int ret, retint;
18 char *table, *s;
19 PTPParams *params = &camera->pl->params;
20- char *lua;
21- const char *luascript = PTP_CHDK_LUA_SERIALIZE_MSGS \
22+ const char *luascript = PTP_CHDK_LUA_SERIALIZE_MSGS_SIMPLEQUOTE \
23 PTP_CHDK_LUA_RLIB_SHOOT \
24 "return rlib_shoot({info=true});\n";
25
26 ret = camera_prepare_chdk_capture(camera, context);
27 if (ret != GP_OK) return ret;
28
29- lua = malloc(strlen(luascript)+1);
30- sprintf(lua,luascript); /* This expands the %q inside the string too ... do not optimize away. */
31- ret = chdk_generic_script_run (params, lua, &table, &retint, context);
32- free (lua);
33+ ret = chdk_generic_script_run (params, luascript, &table, &retint, context);
34 GP_LOG_D("rlib_shoot returned table %s, retint %d\n", table, retint);
35 s = strstr(table, "exp=");
36 if (s) {
37diff --git a/camlibs/ptp2/chdk_ptp.h b/camlibs/ptp2/chdk_ptp.h
38index d11e0b7..65dcfd7 100644
39--- a/camlibs/ptp2/chdk_ptp.h
40+++ b/camlibs/ptp2/chdk_ptp.h
41@@ -198,10 +198,92 @@ function serialize(v,opts)\n\
42 return table.concat(r)\n\
43 end\n"
44
45+#define PTP_CHDK_LUA_SERIALIZE_SIMPLEQUOTE "\n\
46+serialize_r = function(v,opts,r,seen,depth)\n\
47+ local vt = type(v)\n\
48+ if vt == 'nil' or vt == 'boolean' or vt == 'number' then\n\
49+ table.insert(r,tostring(v))\n\
50+ return\n\
51+ end\n\
52+ if vt == 'string' then\n\
53+ table.insert(r,string.format('%q',v))\n\
54+ return\n\
55+ end\n\
56+ if vt == 'table' then\n\
57+ if not depth then\n\
58+ depth = 1\n\
59+ end\n\
60+ if depth >= opts.maxdepth then\n\
61+ error('serialize: max depth')\n\
62+ end\n\
63+ if not seen then\n\
64+ seen={}\n\
65+ elseif seen[v] then\n\
66+ if opts.err_cycle then\n\
67+ error('serialize: cycle')\n\
68+ else\n\
69+ table.insert(r,'\"cycle:'..tostring(v)..'\"')\n\
70+ return\n\
71+ end\n\
72+ end\n\
73+ seen[v] = true;\n\
74+ table.insert(r,'{')\n\
75+ for k,v1 in pairs(v) do\n\
76+ if opts.pretty then\n\
77+ table.insert(r,'\\n'..string.rep(' ',depth))\n\
78+ end\n\
79+ if type(k) == 'string' and string.match(k,'^[_%a][%a%d_]*$') then\n\
80+ table.insert(r,k)\n\
81+ else\n\
82+ table.insert(r,'[')\n\
83+ serialize_r(k,opts,r,seen,depth+1)\n\
84+ table.insert(r,']')\n\
85+ end\n\
86+ table.insert(r,'=')\n\
87+ serialize_r(v1,opts,r,seen,depth+1)\n\
88+ table.insert(r,',')\n\
89+ end\n\
90+ if opts.pretty then\n\
91+ table.insert(r,'\\n'..string.rep(' ',depth-1))\n\
92+ end\n\
93+ table.insert(r,'}')\n\
94+ return\n\
95+ end\n\
96+ if opts.err_type then\n\
97+ error('serialize: unsupported type ' .. vt, 2)\n\
98+ else\n\
99+ table.insert(r,'\"'..tostring(v)..'\"')\n\
100+ end\n\
101+end\n\
102+serialize_defaults = {\n\
103+ maxdepth=10,\n\
104+ err_type=true,\n\
105+ err_cycle=true,\n\
106+ pretty=false,\n\
107+}\n\
108+function serialize(v,opts)\n\
109+ if opts then\n\
110+ for k,v in pairs(serialize_defaults) do\n\
111+ if not opts[k] then\n\
112+ opts[k]=v\n\
113+ end\n\
114+ end\n\
115+ else\n\
116+ opts=serialize_defaults\n\
117+ end\n\
118+ local r={}\n\
119+ serialize_r(v,opts,r)\n\
120+ return table.concat(r)\n\
121+end\n"
122+
123 #define PTP_CHDK_LUA_SERIALIZE_MSGS \
124 PTP_CHDK_LUA_SERIALIZE\
125 "usb_msg_table_to_string=serialize\n"
126
127+#define PTP_CHDK_LUA_SERIALIZE_MSGS_SIMPLEQUOTE \
128+PTP_CHDK_LUA_SERIALIZE_SIMPLEQUOTE\
129+"usb_msg_table_to_string=serialize\n"
130+
131 #define PTP_CHDK_LUA_EXTEND_TABLE \
132 "function extend_table(target,source,deep)\n\
133 if type(target) ~= 'table' then\n\
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0001-configure.ac-remove-AM_PO_SUBDIRS.patch b/meta-oe/recipes-graphics/gphoto2/libgphoto2/0001-configure.ac-remove-AM_PO_SUBDIRS.patch
index 8093676ad..8093676ad 100644
--- a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/0001-configure.ac-remove-AM_PO_SUBDIRS.patch
+++ b/meta-oe/recipes-graphics/gphoto2/libgphoto2/0001-configure.ac-remove-AM_PO_SUBDIRS.patch
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/10-camera-libgphoto2-device.fdi b/meta-oe/recipes-graphics/gphoto2/libgphoto2/10-camera-libgphoto2-device.fdi
index 3977064fe..3977064fe 100644
--- a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/10-camera-libgphoto2-device.fdi
+++ b/meta-oe/recipes-graphics/gphoto2/libgphoto2/10-camera-libgphoto2-device.fdi
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/10-camera-libgphoto2.fdi b/meta-oe/recipes-graphics/gphoto2/libgphoto2/10-camera-libgphoto2.fdi
index 00427e7d9..00427e7d9 100644
--- a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/10-camera-libgphoto2.fdi
+++ b/meta-oe/recipes-graphics/gphoto2/libgphoto2/10-camera-libgphoto2.fdi
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/40-libgphoto2.rules b/meta-oe/recipes-graphics/gphoto2/libgphoto2/40-libgphoto2.rules
index b9f04398d..b9f04398d 100644
--- a/meta-oe/recipes-graphics/gphoto2/libgphoto2-2.5.8/40-libgphoto2.rules
+++ b/meta-oe/recipes-graphics/gphoto2/libgphoto2/40-libgphoto2.rules
diff --git a/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.8.bb b/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.14.bb
index 4434af930..d7290fa6f 100644
--- a/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.8.bb
+++ b/meta-oe/recipes-graphics/gphoto2/libgphoto2_2.5.14.bb
@@ -14,13 +14,10 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2;name=libgphoto2
14 file://10-camera-libgphoto2.fdi \ 14 file://10-camera-libgphoto2.fdi \
15 file://40-libgphoto2.rules \ 15 file://40-libgphoto2.rules \
16 file://0001-configure.ac-remove-AM_PO_SUBDIRS.patch \ 16 file://0001-configure.ac-remove-AM_PO_SUBDIRS.patch \
17 file://0002-correct-jpeg-memsrcdest-support.patch \
18 file://avoid_using_sprintf.patch \
19 file://0001-scripts-remove-bashisms.patch \
20" 17"
21 18
22SRC_URI[libgphoto2.md5sum] = "873ab01aced49c6b92a98e515db5dcef" 19SRC_URI[libgphoto2.md5sum] = "65acb6cbd2b4f3f46829599f5dabd89c"
23SRC_URI[libgphoto2.sha256sum] = "031a262e342fae43f724afe66787947ce1fb483277dfe5a8cf1fbe92c58e27b6" 20SRC_URI[libgphoto2.sha256sum] = "d3ce70686fb87d6791b9adcbb6e5693bfbe1cfef9661c23c75eb8a699ec4e274"
24 21
25inherit autotools pkgconfig gettext lib_package 22inherit autotools pkgconfig gettext lib_package
26 23
@@ -54,3 +51,4 @@ FILES_libgphotoport = "${libdir}/libgphoto2_port.so.*"
54FILES_${PN} += "${nonarch_base_libdir}/udev/* ${datadir}/hal" 51FILES_${PN} += "${nonarch_base_libdir}/udev/* ${datadir}/hal"
55FILES_${PN}-dbg += "${libdir}/*/*/.debug" 52FILES_${PN}-dbg += "${libdir}/*/*/.debug"
56FILES_${PN}-dev += "${libdir}/*/*/*.la" 53FILES_${PN}-dev += "${libdir}/*/*/*.la"
54FILES_${PN}-doc += "${datadir}/libgphoto2_port/0.12.0/vcamera/README.txt"