summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/gimp/gimp_2.6.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/gimp/gimp_2.6.11.bb')
-rw-r--r--meta-oe/recipes-graphics/gimp/gimp_2.6.11.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/gimp/gimp_2.6.11.bb b/meta-oe/recipes-graphics/gimp/gimp_2.6.11.bb
new file mode 100644
index 000000000..31e892559
--- /dev/null
+++ b/meta-oe/recipes-graphics/gimp/gimp_2.6.11.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "The GIMP is the GNU Image Manipulation Program."
2HOMEPAGE = "http://www.gimp.org"
3SECTION = "x11/graphics"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=878e3965c7b52d85827c75f5a2f3b314"
6
7DEPENDS = "babl gdk-pixbuf-native libart-lgpl gtk+ jpeg libpng libexif tiff webkit-gtk lcms gegl poppler"
8
9inherit gnome
10
11SRC_URI = "ftp://ftp.gimp.org/pub/gimp/v2.6/gimp-${PV}.tar.bz2 \
12 file://gimp-2.6.11-poppler18.patch"
13SRC_URI[md5sum] = "bb2939fe13e54fc7255cef5d097bb5dd"
14SRC_URI[sha256sum] = "9b6d08d0803b3912ea596d1b77b9c21ee13778c23388a225c004b8c1587cb0a1"
15
16EXTRA_OECONF = "--disable-python \
17 --without-libwmf"
18
19do_configure_append() {
20 find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
21 find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
22}
23
24FILES_${PN}-dbg += "${libdir}/gimp/2.0/*/.debug"