summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/fvwm/fvwm_2.6.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/fvwm/fvwm_2.6.7.bb')
-rw-r--r--meta-oe/recipes-graphics/fvwm/fvwm_2.6.7.bb114
1 files changed, 114 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/fvwm/fvwm_2.6.7.bb b/meta-oe/recipes-graphics/fvwm/fvwm_2.6.7.bb
new file mode 100644
index 000000000..cb851bfd9
--- /dev/null
+++ b/meta-oe/recipes-graphics/fvwm/fvwm_2.6.7.bb
@@ -0,0 +1,114 @@
1SUMMARY = "F Virtual Window Manager "
2HOMEPAGE = "http://www.fvwm.org/"
3SECTION = "x11/wm"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=363fbcfb59124689af72c914560eaf6e"
6
7DEPENDS = " \
8 bison-native \
9 flex-native \
10 freetype-native \
11 gettext-native \
12 libxslt-native \
13 fontconfig \
14 libice \
15 libpng \
16 librsvg \
17 libsm \
18 libxau \
19 libxcb \
20 libxcursor \
21 libxdmcp \
22 libxext \
23 libxfixes \
24 libxft \
25 libxinerama \
26 libxml2 \
27 libxrender \
28 libxt \
29 virtual/libx11 \
30 xrandr \
31 zlib \
32"
33
34PV = "2.6.7+git${SRCPV}"
35
36SRC_URI = " \
37 git://github.com/fvwmorg/fvwm.git;protocol=https \
38 file://0001-Fix-compilation-for-disabled-gnome.patch \
39 file://0002-Avoid-absolute-symlinks.patch \
40"
41
42SRCREV = "597a4e296da4f21e71a17facab297e016a3a80a8"
43
44S = "${WORKDIR}/git"
45
46inherit autotools gettext update-alternatives pkgconfig pythonnative perlnative distro_features_check
47# depends on virtual/libx11
48REQUIRED_DISTRO_FEATURES = "x11"
49
50ALTERNATIVE_${PN} = "x-window-manager"
51ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/fvwm"
52ALTERNATIVE_PRIORITY[x-window-manager] = "20"
53
54EXTRA_OECONF = " \
55 --disable-bidi \
56 --disable-fontconfigtest \
57 --disable-freetypetest \
58 --disable-htmldoc \
59 --disable-imlibtest \
60 --disable-mandoc \
61 --disable-nls \
62 --disable-perllib \
63 --disable-rsvg \
64 --disable-shape \
65 --disable-sm \
66 --disable-xfttest \
67 --with-imlib-exec-prefix=/nonexistent \
68 --with-imlib-prefix=/nonexistent \
69 --without-ncurses-library \
70 --without-readline-library \
71 --without-rplay-library \
72 --without-stroke-library \
73 --without-termcap-library \
74 --without-xpm-library \
75 ac_cv_func_mkstemp=no \
76 has_safety_mkstemp=yes \
77"
78
79# show the exact commands in the log file
80EXTRA_OEMAKE = " \
81 V=1 \
82"
83
84do_install_append() {
85 install -d -m 0755 ${D}/${sysconfdir}/xdg/fvwm
86 # You can install the config file here
87
88 install -d -m 0755 ${D}/${datadir}/fvwm
89 touch ${D}/${datadir}/fvwm/ConfigFvwmDefaults
90}
91
92# the only needed packages (note: locale packages are automatically generated
93# as well)
94PACKAGES = " \
95 ${PN} \
96 ${PN}-dbg \
97"
98
99# minimal set of binaries
100FILES_${PN} = " \
101 ${bindir}/fvwm \
102 ${bindir}/fvwm-root \
103 ${datadir}/fvwm/ConfigFvwmDefaults \
104"
105
106RDEPENDS_${PN} = " \
107 xuser-account \
108"
109
110# by default a lot of stuff is installed and it's not easy to control what to
111# install, so install everything, but skip the check
112INSANE_SKIP_${PN} = " \
113 installed-vs-shipped \
114"