summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/fvwm/fvwm/0001-Fix-compilation-for-disabled-gnome.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/fvwm/fvwm/0001-Fix-compilation-for-disabled-gnome.patch')
-rw-r--r--meta-oe/recipes-graphics/fvwm/fvwm/0001-Fix-compilation-for-disabled-gnome.patch69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/fvwm/fvwm/0001-Fix-compilation-for-disabled-gnome.patch b/meta-oe/recipes-graphics/fvwm/fvwm/0001-Fix-compilation-for-disabled-gnome.patch
new file mode 100644
index 000000000..5a7647455
--- /dev/null
+++ b/meta-oe/recipes-graphics/fvwm/fvwm/0001-Fix-compilation-for-disabled-gnome.patch
@@ -0,0 +1,69 @@
1From 60c17eb49121bf2aa485acd30750b2fc6c8eb61f Mon Sep 17 00:00:00 2001
2From: Jarmo Jaakkola <jarmo.jaakkola@vincit.fi>
3Date: Mon, 19 Jun 2017 16:41:36 +0300
4Subject: [PATCH] Fix compilation for Helix.
5
6Gnome support, including GNOME_INIT_HOOK, has been removed, but it was
7still being called.
8
9COMPAT_OLD_KEYSYMDEF is a check for a legacy system, which our system
10most definitely is not. It is accomplished by trying to execute
11a program, which does not work when cross compiling.
12
13The fvwm(1) man page is created from Docbook XML which is set for
14a Windows code page that is not available when compiling. Easiest is
15to just not create the man page as those are not needed on the monitor.
16
17Upstream-Status: inappropriate [OE specific]
18Signed-off-by: Jarmo Jaakkola <jarmo.jaakkola@vincit.fi>
19Signed-off-by: Riku Hämäläinen <riku.hamalainen@ge.com>
20Signed-off-by: Sebastian Reichel <sebastian.reichel@collabora.co.uk>
21---
22 configure.ac | 20 ++++----------------
23 doc/fvwm/Makefile.am | 2 +-
24 3 files changed, 7 insertions(+), 17 deletions(-)
25
26diff --git a/configure.ac b/configure.ac
27index 48ce264..fab7b44 100644
28--- a/configure.ac
29+++ b/configure.ac
30@@ -1413,23 +1413,7 @@ else
31 problem_gdkimlib=": Failed on gdk-imlib, see config.log"
32 fi
33
34-GNOME_INIT_HOOK
35-
36-# Unfortunately we have 2 gnome supports: WM hints and gnome libs.
37-# The $with_gnomehints below refers to the first, not GNOME_INIT_HOOK.
38-if test ! x"$enable_gnome_hints" = xno; then
39- with_gnomehints=yes
40- problem_gnomehints=""
41-else
42- with_gnomehints=no
43- problem_gnomehints=": Explicitly disabled"
44-fi
45-
46 # Define some compatibility macros needed for config.h.
47-mg_DEFINE_IF_NOT([#include <X11/keysym.h>],
48- [defined XK_Page_Up && defined XK_Page_Down],
49- [COMPAT_OLD_KEYSYMDEF], [$X_CFLAGS],
50- [Old AIX systems (3.2.5) don't define some common keysyms.])
51 AH_VERBATIM([_COMPAT_OLD_KEYSYMDEF],
52 [#ifdef COMPAT_OLD_KEYSYMDEF
53 # define XK_Page_Up XK_Prior
54diff --git a/doc/fvwm/Makefile.am b/doc/fvwm/Makefile.am
55index cddb102..ff00149 100755
56--- a/doc/fvwm/Makefile.am
57+++ b/doc/fvwm/Makefile.am
58@@ -10,7 +10,7 @@ XSL_PROFILE = $(srcdir)/../docbook-xsl/profiling/profile.xsl
59 HTML_FILES = fvwm.man.html
60 XML_FILES = @DOC_SECTIONS_XML_PATH@
61 EXTRA_DIST = @DOC_SECTIONS_XML@ $(man_MANS) sections
62-man_MANS = fvwm.1
63+man_MANS =
64
65 if FVWM_BUILD_HTMLDOC
66 doc_DATA = $(HTML_FILES)
67--
681.9.1
69