summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/fbida/fbida_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/fbida/fbida_git.bb')
-rw-r--r--meta-oe/recipes-graphics/fbida/fbida_git.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/fbida/fbida_git.bb b/meta-oe/recipes-graphics/fbida/fbida_git.bb
new file mode 100644
index 000000000..41c14b88a
--- /dev/null
+++ b/meta-oe/recipes-graphics/fbida/fbida_git.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Framebuffer image and doc viewer tools"
2DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \
3 with the main focus being photos."
4HOMEPAGE = "http://linux.bytesex.org/fbida/"
5AUTHOR = "Gerd Hoffmann"
6SECTION = "utils"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
10
11DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif curl"
12
13SRC_URI = "git://git.kraxel.org/fbida"
14SRCREV = "6aa5563cb3c8864ad15cf83eb6fca3b773da1099"
15PV = "2.09+git${SRCPV}"
16S = "${WORKDIR}/git"
17
18EXTRA_OEMAKE = "STRIP="
19
20PACKAGECONFIG ??= "gif png"
21PACKAGECONFIG[gif] = ",,giflib"
22PACKAGECONFIG[png] = ",,libpng"
23PACKAGECONFIG[tiff] = ",,tiff"
24PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif"
25
26do_compile() {
27 sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk
28 sed -i -e 's: cpp: ${TARGET_PREFIX}cpp -I${STAGING_INCDIR}:' ${S}/GNUmakefile
29
30 # Be sure to respect preferences (force to "no")
31 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH}
32 if [ -z "${@base_contains('PACKAGECONFIG', 'gif', 'gif', '', d)}" ]; then
33 sed -i -e '/^HAVE_LIBUNGIF/s/:=.*$/:= no/' ${S}/GNUmakefile
34 fi
35 if [ -z "${@base_contains('PACKAGECONFIG', 'png', 'png', '', d)}" ]; then
36 sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile
37 fi
38 if [ -z "${@base_contains('PACKAGECONFIG', 'tiff', 'tiff', '', d)}" ]; then
39 sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile
40 fi
41 if [ -z "${@base_contains('PACKAGECONFIG', 'motif', 'motif', '', d)}" ]; then
42 sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile
43 fi
44
45 oe_runmake
46}
47
48do_install() {
49 oe_runmake 'DESTDIR=${D}' install
50}
51
52RDEPENDS_${PN} = "ttf-dejavu-sans-mono"