summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/collectd/collectd/0001-Remove-including-sys-sysctl.h-on-glibc-based-systems.patch106
-rw-r--r--meta-oe/recipes-extended/collectd/collectd/0001-conditionally-check-libvirt.patch39
-rw-r--r--meta-oe/recipes-extended/collectd/collectd/0001-configure-Check-for-Wno-error-format-truncation-comp.patch6
-rw-r--r--meta-oe/recipes-extended/collectd/collectd/0001-fix-to-build-with-glibc-2.25.patch4
-rw-r--r--meta-oe/recipes-extended/collectd/collectd_5.10.0.bb (renamed from meta-oe/recipes-extended/collectd/collectd_5.8.1.bb)5
5 files changed, 65 insertions, 95 deletions
diff --git a/meta-oe/recipes-extended/collectd/collectd/0001-Remove-including-sys-sysctl.h-on-glibc-based-systems.patch b/meta-oe/recipes-extended/collectd/collectd/0001-Remove-including-sys-sysctl.h-on-glibc-based-systems.patch
index 3dee34cd0..57044057b 100644
--- a/meta-oe/recipes-extended/collectd/collectd/0001-Remove-including-sys-sysctl.h-on-glibc-based-systems.patch
+++ b/meta-oe/recipes-extended/collectd/collectd/0001-Remove-including-sys-sysctl.h-on-glibc-based-systems.patch
@@ -3,44 +3,69 @@ From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 27 Jul 2019 14:20:14 -0700 3Date: Sat, 27 Jul 2019 14:20:14 -0700
4Subject: [PATCH] Remove including sys/sysctl.h on glibc based systems 4Subject: [PATCH] Remove including sys/sysctl.h on glibc based systems
5 5
6Glibc 2.30 has added deprecation notice and collectd detects it as warning [1] 6Glibc 2.30 has added deprecation notice and collectd detects it as
7warning [1]
7 8
8Fixes 9Fixes
9sys/sysctl.h:21:2: error: "The <sys/sysctl.h> header is deprecated and will be removed." [-Werror,-W#warnings] 10sys/sysctl.h:21:2: error: "The <sys/sysctl.h> header is deprecated and
11will be removed." [-Werror,-W#warnings]
10 12
11[1] https://sourceware.org/git/?p=glibc.git;a=commit;h=744e829637162bb7d5029632aacf341c64b86990 13[1]
14https://sourceware.org/git/?p=glibc.git;a=commit;h=744e829637162bb7d5029632aacf341c64b86990
12 15
13Upstream-Status: Submitted [https://github.com/collectd/collectd/pull/3234] 16Upstream-Status: Submitted
17[https://github.com/collectd/collectd/pull/3234]
14Signed-off-by: Khem Raj <raj.khem@gmail.com> 18Signed-off-by: Khem Raj <raj.khem@gmail.com>
15--- 19---
16 src/contextswitch.c | 2 +- 20 src/cpu.c | 2 +-
17 src/memory.c | 2 +- 21 src/memory.c | 2 +-
18 src/swap.c | 2 +- 22 src/processes.c | 2 +-
19 src/uuid.c | 2 +- 23 src/swap.c | 2 +-
20 4 files changed, 4 insertions(+), 4 deletions(-) 24 src/uptime.c | 2 +-
25 src/uuid.c | 2 +-
26 6 files changed, 6 insertions(+), 6 deletions(-)
21 27
22--- a/src/contextswitch.c 28diff --git a/src/cpu.c b/src/cpu.c
23+++ b/src/contextswitch.c 29index 09d60fe..9d12623 100644
24@@ -26,7 +26,7 @@ 30--- a/src/cpu.c
25 #include "common.h" 31+++ b/src/cpu.c
26 #include "plugin.h" 32@@ -60,7 +60,7 @@
27 33
34 #if (defined(HAVE_SYSCTL) && HAVE_SYSCTL) || \
35 (defined(HAVE_SYSCTLBYNAME) && HAVE_SYSCTLBYNAME)
28-#ifdef HAVE_SYS_SYSCTL_H 36-#ifdef HAVE_SYS_SYSCTL_H
29+#if defined(HAVE_SYS_SYSCTL_H) && !defined(__GLIBC__) 37+#if defined(HAVE_SYS_SYSCTL_H) && !defined(__GLIBC__)
30 #include <sys/sysctl.h> 38 #include <sys/sysctl.h>
31 #endif 39 #endif
32 40
41diff --git a/src/memory.c b/src/memory.c
42index 10bccde..50a8086 100644
33--- a/src/memory.c 43--- a/src/memory.c
34+++ b/src/memory.c 44+++ b/src/memory.c
35@@ -28,7 +28,7 @@ 45@@ -28,7 +28,7 @@
36 #include "common.h"
37 #include "plugin.h" 46 #include "plugin.h"
47 #include "utils/common/common.h"
38 48
39-#ifdef HAVE_SYS_SYSCTL_H 49-#ifdef HAVE_SYS_SYSCTL_H
40+#if defined(HAVE_SYS_SYSCTL_H) && !defined(__GLIBC__) 50+#if defined(HAVE_SYS_SYSCTL_H) && !defined(__GLIBC__)
41 #include <sys/sysctl.h> 51 #include <sys/sysctl.h>
42 #endif 52 #endif
43 #ifdef HAVE_SYS_VMMETER_H 53 #ifdef HAVE_SYS_VMMETER_H
54diff --git a/src/processes.c b/src/processes.c
55index f83913a..9f71511 100644
56--- a/src/processes.c
57+++ b/src/processes.c
58@@ -87,7 +87,7 @@
59 #if HAVE_MACH_VM_PROT_H
60 #include <mach/vm_prot.h>
61 #endif
62-#if HAVE_SYS_SYSCTL_H
63+#if defined(HAVE_SYS_SYSCTL_H) && !defined(__GLIBC__)
64 #include <sys/sysctl.h>
65 #endif
66 /* #endif HAVE_THREAD_INFO */
67diff --git a/src/swap.c b/src/swap.c
68index 61c9e28..5a475e4 100644
44--- a/src/swap.c 69--- a/src/swap.c
45+++ b/src/swap.c 70+++ b/src/swap.c
46@@ -49,7 +49,7 @@ 71@@ -49,7 +49,7 @@
@@ -52,39 +77,8 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
52 #include <sys/sysctl.h> 77 #include <sys/sysctl.h>
53 #endif 78 #endif
54 #if HAVE_SYS_DKSTAT_H 79 #if HAVE_SYS_DKSTAT_H
55--- a/src/uuid.c 80diff --git a/src/uptime.c b/src/uptime.c
56+++ b/src/uuid.c 81index 0892bda..4b15150 100644
57@@ -29,7 +29,7 @@
58 #include "common.h"
59 #include "plugin.h"
60
61-#if HAVE_SYS_SYSCTL_H
62+#if defined(HAVE_SYS_SYSCTL_H) && !defined(__GLIBC__)
63 #include <sys/sysctl.h>
64 #endif
65
66--- a/src/cpu.c
67+++ b/src/cpu.c
68@@ -60,7 +60,7 @@
69
70 #if (defined(HAVE_SYSCTL) && HAVE_SYSCTL) || \
71 (defined(HAVE_SYSCTLBYNAME) && HAVE_SYSCTLBYNAME)
72-#ifdef HAVE_SYS_SYSCTL_H
73+#if defined(HAVE_SYS_SYSCTL_H) && !defined(__GLIBC__)
74 #include <sys/sysctl.h>
75 #endif
76
77--- a/src/processes.c
78+++ b/src/processes.c
79@@ -82,7 +82,7 @@
80 #if HAVE_MACH_VM_PROT_H
81 #include <mach/vm_prot.h>
82 #endif
83-#if HAVE_SYS_SYSCTL_H
84+#if defined(HAVE_SYS_SYSCTL_H) && !defined(__GLIBC__)
85 #include <sys/sysctl.h>
86 #endif
87 /* #endif HAVE_THREAD_INFO */
88--- a/src/uptime.c 82--- a/src/uptime.c
89+++ b/src/uptime.c 83+++ b/src/uptime.c
90@@ -33,7 +33,7 @@ 84@@ -33,7 +33,7 @@
@@ -96,3 +90,19 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
96 #include <sys/sysctl.h> 90 #include <sys/sysctl.h>
97 /* Using sysctl interface to retrieve the boot time on *BSD / Darwin / OS X 91 /* Using sysctl interface to retrieve the boot time on *BSD / Darwin / OS X
98 * systems */ 92 * systems */
93diff --git a/src/uuid.c b/src/uuid.c
94index 60d09b5..17e4dd8 100644
95--- a/src/uuid.c
96+++ b/src/uuid.c
97@@ -29,7 +29,7 @@
98 #include "plugin.h"
99 #include "utils/common/common.h"
100
101-#if HAVE_SYS_SYSCTL_H
102+#if defined(HAVE_SYS_SYSCTL_H) && !defined(__GLIBC__)
103 #include <sys/sysctl.h>
104 #endif
105
106--
1072.17.1
108
diff --git a/meta-oe/recipes-extended/collectd/collectd/0001-conditionally-check-libvirt.patch b/meta-oe/recipes-extended/collectd/collectd/0001-conditionally-check-libvirt.patch
deleted file mode 100644
index 5ee75cb4d..000000000
--- a/meta-oe/recipes-extended/collectd/collectd/0001-conditionally-check-libvirt.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 385bf1c2ec57942e17ee529e57eef0dcd99904e6 Mon Sep 17 00:00:00 2001
2From: Roy Li <rongqing.li@windriver.com>
3Date: Tue, 1 Sep 2015 17:00:33 +0800
4Subject: [PATCH] [PATCH] conditionally check libvirt
5
6Upstream-Statue: Pending
7
8check if libvirt is available only when a user wants to use libvirt
9
10Signed-off-by: Roy Li <rongqing.li@windriver.com>
11
12---
13 configure.ac | 13 ++++++++-----
14 1 file changed, 8 insertions(+), 5 deletions(-)
15
16diff --git a/configure.ac b/configure.ac
17index 101d6f9f..a7eca97d 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -5758,11 +5758,14 @@ else
21 with_libxml2="no (pkg-config doesn't know libxml-2.0)"
22 fi
23
24-$PKG_CONFIG --exists libvirt 2>/dev/null
25-if test $? = 0; then
26- with_libvirt="yes"
27-else
28- with_libvirt="no (pkg-config doesn't know libvirt)"
29+if test "x$enable_libvirt" = "xyes"; then
30+ $PKG_CONFIG --exists libvirt 2>/dev/null
31+ if test "$?" = "0"
32+ then
33+ with_libvirt="yes"
34+ else
35+ with_libvirt="no (pkg-config doesn't know libvirt)"
36+ fi
37 fi
38
39 if test "x$with_libxml2" = "xyes"; then
diff --git a/meta-oe/recipes-extended/collectd/collectd/0001-configure-Check-for-Wno-error-format-truncation-comp.patch b/meta-oe/recipes-extended/collectd/collectd/0001-configure-Check-for-Wno-error-format-truncation-comp.patch
index d2c726800..8d31e12f9 100644
--- a/meta-oe/recipes-extended/collectd/collectd/0001-configure-Check-for-Wno-error-format-truncation-comp.patch
+++ b/meta-oe/recipes-extended/collectd/collectd/0001-configure-Check-for-Wno-error-format-truncation-comp.patch
@@ -23,9 +23,9 @@ diff --git a/configure.ac b/configure.ac
23index a7eca97d..560eb988 100644 23index a7eca97d..560eb988 100644
24--- a/configure.ac 24--- a/configure.ac
25+++ b/configure.ac 25+++ b/configure.ac
26@@ -6794,6 +6794,7 @@ if test "x$enable_werror" != "xno"; then 26@@ -7101,6 +7101,7 @@ if test "x$GCC" = "xyes"; then
27 AM_CFLAGS="$AM_CFLAGS -Werror" 27 AM_CXXFLAGS="$AM_CXXFLAGS -Werror"
28 AM_CXXFLAGS="$AM_CXXFLAGS -Werror" 28 fi
29 fi 29 fi
30+AX_CHECK_COMPILE_FLAG([-Werror -Werror=format-truncation],[AM_CFLAGS="$AM_CFLAGS -Wno-error=format-truncation" AM_CXXFLAGS="$AM_CXXFLAGS -Wno-error=format-truncation"]) 30+AX_CHECK_COMPILE_FLAG([-Werror -Werror=format-truncation],[AM_CFLAGS="$AM_CFLAGS -Wno-error=format-truncation" AM_CXXFLAGS="$AM_CXXFLAGS -Wno-error=format-truncation"])
31 31
diff --git a/meta-oe/recipes-extended/collectd/collectd/0001-fix-to-build-with-glibc-2.25.patch b/meta-oe/recipes-extended/collectd/collectd/0001-fix-to-build-with-glibc-2.25.patch
index be942e5ef..1e140f975 100644
--- a/meta-oe/recipes-extended/collectd/collectd/0001-fix-to-build-with-glibc-2.25.patch
+++ b/meta-oe/recipes-extended/collectd/collectd/0001-fix-to-build-with-glibc-2.25.patch
@@ -11,8 +11,8 @@ diff --git a/src/md.c b/src/md.c
11index 3725f9a..202225b 100644 11index 3725f9a..202225b 100644
12--- a/src/md.c 12--- a/src/md.c
13+++ b/src/md.c 13+++ b/src/md.c
14@@ -25,6 +25,7 @@ 14@@ -26,6 +26,7 @@
15 #include "utils_ignorelist.h" 15 #include "utils/ignorelist/ignorelist.h"
16 16
17 #include <sys/ioctl.h> 17 #include <sys/ioctl.h>
18+#include <sys/sysmacros.h> 18+#include <sys/sysmacros.h>
diff --git a/meta-oe/recipes-extended/collectd/collectd_5.8.1.bb b/meta-oe/recipes-extended/collectd/collectd_5.10.0.bb
index 8b9fd74a8..df3a5b204 100644
--- a/meta-oe/recipes-extended/collectd/collectd_5.8.1.bb
+++ b/meta-oe/recipes-extended/collectd/collectd_5.10.0.bb
@@ -9,15 +9,14 @@ SRC_URI = "http://collectd.org/files/collectd-${PV}.tar.bz2 \
9 file://collectd.init \ 9 file://collectd.init \
10 file://collectd.service \ 10 file://collectd.service \
11 file://no-gcrypt-badpath.patch \ 11 file://no-gcrypt-badpath.patch \
12 file://0001-conditionally-check-libvirt.patch \
13 file://0001-fix-to-build-with-glibc-2.25.patch \ 12 file://0001-fix-to-build-with-glibc-2.25.patch \
14 file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \ 13 file://0001-configure-Check-for-Wno-error-format-truncation-comp.patch \
15 file://0005-Disable-new-gcc8-warnings.patch \ 14 file://0005-Disable-new-gcc8-warnings.patch \
16 file://0006-libcollectdclient-Fix-string-overflow-errors.patch \ 15 file://0006-libcollectdclient-Fix-string-overflow-errors.patch \
17 file://0001-Remove-including-sys-sysctl.h-on-glibc-based-systems.patch \ 16 file://0001-Remove-including-sys-sysctl.h-on-glibc-based-systems.patch \
18 " 17 "
19SRC_URI[md5sum] = "bfce96c42cede5243028510bcc57c1e6" 18SRC_URI[md5sum] = "a8344a199b124711bdbec57f1c0b624f"
20SRC_URI[sha256sum] = "e796fda27ce06377f491ad91aa286962a68c2b54076aa77a29673d53204453da" 19SRC_URI[sha256sum] = "a03359f563023e744c2dc743008a00a848f4cd506e072621d86b6d8313c0375b"
21 20
22inherit autotools python3native update-rc.d pkgconfig systemd 21inherit autotools python3native update-rc.d pkgconfig systemd
23 22