summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/wtmpdb/wtmpdb_0.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/wtmpdb/wtmpdb_0.9.3.bb')
-rw-r--r--meta-oe/recipes-extended/wtmpdb/wtmpdb_0.9.3.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/wtmpdb/wtmpdb_0.9.3.bb b/meta-oe/recipes-extended/wtmpdb/wtmpdb_0.9.3.bb
new file mode 100644
index 000000000..6d23c0070
--- /dev/null
+++ b/meta-oe/recipes-extended/wtmpdb/wtmpdb_0.9.3.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Y2038 safe version of wtmp"
2HOMEPAGE = "https://github.com/thkukuk/wtmpdb"
3DESCRIPTION = "last reports the login and logout times of users and when the machine got rebooted."
4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=020090a00b69dd2af9ab82eb0003ea2c"
6SECTION = "libs"
7
8SRCREV = "8ef2677a13d19aee3a834500f9c8a4dac9d68ef7"
9
10SRC_URI = "git://github.com/thkukuk/wtmpdb.git;branch=main;protocol=https \
11 file://0001-remove-lto-to-fix-link-error-of-clang.patch \
12"
13
14S = "${WORKDIR}/git"
15
16inherit meson pkgconfig systemd features_check
17
18DEPENDS += " ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)} sqlite3 "
19REQUIRED_DISTRO_FEATURES = "pam"
20
21SYSTEMD_SERVICE:${PN} = "wtmpdb-update-boot.service wtmpdb-rotate.service"
22
23EXTRA_OEMESON = " -Dpamlibdir=${libdir}"
24
25do_install:append () {
26 if [ -d ${D}${prefix}/lib/systemd -a ${D}${prefix}/lib != `dirname ${D}${systemd_unitdir}` ]; then
27 # Fix makefile hardcoded path assumptions for systemd (assumes $prefix)
28 # without usrmerge distro feature enabled
29 install -d `dirname ${D}${systemd_unitdir}`
30 mv ${D}${prefix}/lib/systemd `dirname ${D}${systemd_unitdir}`
31 fi
32}
33
34FILES:${PN} += " ${systemd_system_unitdir} "
35FILES:${PN} += " ${libdir} "
36FILES:${PN} += " ${nonarch_libdir}/tmpfiles.d/* "