summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/tmux/tmux_2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/tmux/tmux_2.6.bb')
-rw-r--r--meta-oe/recipes-extended/tmux/tmux_2.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/tmux/tmux_2.6.bb b/meta-oe/recipes-extended/tmux/tmux_2.6.bb
new file mode 100644
index 000000000..fba5156f6
--- /dev/null
+++ b/meta-oe/recipes-extended/tmux/tmux_2.6.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Terminal multiplexer"
2HOMEPAGE = "http://tmux.sourceforge.net"
3SECTION = "console/utils"
4
5LICENSE = "ISC"
6LIC_FILES_CHKSUM = "file://tmux.c;beginline=3;endline=17;md5=f256b76d52e7b4d02bf19144bdaca107"
7
8DEPENDS = "ncurses libevent"
9
10SRC_URI = "https://github.com/tmux/tmux/releases/download/${PV}/tmux-${PV}.tar.gz"
11SRC_URI[md5sum] = "d541ff392249f94c4f3635793556f827"
12SRC_URI[sha256sum] = "b17cd170a94d7b58c0698752e1f4f263ab6dc47425230df7e53a6435cc7cd7e8"
13
14inherit autotools pkgconfig
15
16PACKAGECONFIG ??= ""
17PACKAGECONFIG[utempter] = "ac_cv_header_utempter_h=yes,ac_cv_header_utempter_h=no,libutempter,"
18
19do_configure_prepend() {
20 # The 'compat' directory is needed for output during the build but it's
21 # not automatically created when building outside the source directory.
22 mkdir ${B}/compat
23}