summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch')
-rw-r--r--meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch79
1 files changed, 46 insertions, 33 deletions
diff --git a/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch b/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch
index 8b98707cd..976e0380e 100644
--- a/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch
+++ b/meta-oe/recipes-extended/t1lib/t1lib-5.1.2/configure.patch
@@ -1,11 +1,21 @@
1From 81c1ba940415595584a837ab1078c64855072f0c Mon Sep 17 00:00:00 2001
2From: Koen Kooi <koen@dominion.thruhere.net>
3Date: Mon, 21 Nov 2011 12:00:54 +0100
4Subject: [PATCH] t1lib: add 5.1.2
1 5
2# 6#
3# Patch managed by http://www.holgerschurig.de/patcher.html 7# Patch managed by http://www.holgerschurig.de/patcher.html
4# 8#
5 9
6--- t1lib-5.0.2/configure.in~configure.patch 10---
7+++ t1lib-5.0.2/configure.in 11 configure.in | 95 ++++++++++++++++++++++++------------------------------------
8@@ -75,9 +75,9 @@ 12 1 file changed, 38 insertions(+), 57 deletions(-)
13
14diff --git a/configure.in b/configure.in
15index eade4c0..e649ea9 100644
16--- a/configure.in
17+++ b/configure.in
18@@ -74,9 +74,9 @@ T1LIB_PATCHLEVEL=builtin(eval, MACRO_T1LIB_LT_REVISION)
9 T1LIB_VERSIONSTRING=\"MACRO_T1LIB_IDENTIFIER\" 19 T1LIB_VERSIONSTRING=\"MACRO_T1LIB_IDENTIFIER\"
10 20
11 21
@@ -18,7 +28,7 @@
18 28
19 dnl We want these before the checks, so the checks can modify their values. 29 dnl We want these before the checks, so the checks can modify their values.
20 test -z "$LDLIBS" && LDLIBS=-lm AC_SUBST(LDLIBS) 30 test -z "$LDLIBS" && LDLIBS=-lm AC_SUBST(LDLIBS)
21@@ -161,6 +161,7 @@ 31@@ -162,6 +162,7 @@ fi
22 32
23 dnl **** Check for underscore on external symbols **** 33 dnl **** Check for underscore on external symbols ****
24 34
@@ -26,21 +36,12 @@
26 AC_CACHE_CHECK("whether external symbols need an underscore prefix", 36 AC_CACHE_CHECK("whether external symbols need an underscore prefix",
27 ac_cv_c_extern_prefix, 37 ac_cv_c_extern_prefix,
28 [saved_libs=$LIBS 38 [saved_libs=$LIBS
29@@ -178,68 +179,48 @@ 39@@ -179,68 +180,48 @@ then
30 AC_DEFINE(NEED_UNDERSCORE_PREFIX) 40 AC_DEFINE(NEED_UNDERSCORE_PREFIX)
31 fi 41 fi
32 42
33-dnl **** Check which ANSI integer type is 16 bit 43-dnl **** Check which ANSI integer type is 16 bit
34+dnl **** Check which ANSI integer type is 16 bit 44-
35+T1_AA_TYPE16=""
36+for type in short int; do
37+ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x2"; then
38+ T1_AA_TYPE16="-DT1_AA_TYPE16=$type"
39+ T1_INT16="$type"
40+ break
41+ fi
42+done
43
44-AC_CACHE_CHECK( "which ANSI integer type is 16 bit", ac_16bit_type, 45-AC_CACHE_CHECK( "which ANSI integer type is 16 bit", ac_16bit_type,
45- AC_TRY_RUN([ 46- AC_TRY_RUN([
46-int main(void) { 47-int main(void) {
@@ -58,21 +59,23 @@
58-else 59-else
59- T1_AA_TYPE16="-DT1_AA_TYPE16=int" 60- T1_AA_TYPE16="-DT1_AA_TYPE16=int"
60- T1_INT16="int" 61- T1_INT16="int"
62+dnl **** Check which ANSI integer type is 16 bit
63+T1_AA_TYPE16=""
64+for type in short int; do
65+ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x2"; then
66+ T1_AA_TYPE16="-DT1_AA_TYPE16=$type"
67+ T1_INT16="$type"
68+ break
69+ fi
70+done
71+
61+if test x"$T1_AA_TYPE16" = "x"; then 72+if test x"$T1_AA_TYPE16" = "x"; then
62+ AC_MSG_ERROR("Unable to determine which integer type is 16 bit.") 73+ AC_MSG_ERROR("Unable to determine which integer type is 16 bit.")
63 fi 74 fi
64 75
65- 76-
66 dnl **** Check which ANSI integer type is 32 bit 77 dnl **** Check which ANSI integer type is 32 bit
67+T1_AA_TYPE32="" 78-
68+for type in int long; do
69+ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x4"; then
70+ T1_AA_TYPE32="-DT1_AA_TYPE32=$type"
71+ T1_INT32="$type"
72+ break
73+ fi
74+done
75
76-AC_CACHE_CHECK( "which ANSI integer type is 32 bit", ac_32bit_type, 79-AC_CACHE_CHECK( "which ANSI integer type is 32 bit", ac_32bit_type,
77- AC_TRY_RUN([ 80- AC_TRY_RUN([
78-int main(void) { 81-int main(void) {
@@ -90,21 +93,22 @@
90-else 93-else
91- T1_AA_TYPE32="-DT1_AA_TYPE32=long" 94- T1_AA_TYPE32="-DT1_AA_TYPE32=long"
92- T1_INT32="long" 95- T1_INT32="long"
96+T1_AA_TYPE32=""
97+for type in int long; do
98+ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x4"; then
99+ T1_AA_TYPE32="-DT1_AA_TYPE32=$type"
100+ T1_INT32="$type"
101+ break
102+ fi
103+done
104+
93+if test x"$T1_AA_TYPE32" = "x"; then 105+if test x"$T1_AA_TYPE32" = "x"; then
94+ AC_MSG_ERROR("Unable to determine which integer type is 32 bit.") 106+ AC_MSG_ERROR("Unable to determine which integer type is 32 bit.")
95 fi 107 fi
96 108
97- 109-
98 dnl **** Check which ANSI integer type is 64 bit 110 dnl **** Check which ANSI integer type is 64 bit
99+T1_AA_TYPE64="" 111-
100+for type in long long_long; do
101+ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x8"; then
102+ AC_MSG_WARN("$type is 64 bit")
103+ T1_AA_TYPE64="-DT1_AA_TYPE64=\"`echo $type|tr '_' ' '`\""
104+ break
105+ fi
106+done
107
108-AC_CACHE_CHECK( "which ANSI integer type is 64 bit", ac_64bit_type, 112-AC_CACHE_CHECK( "which ANSI integer type is 64 bit", ac_64bit_type,
109- AC_TRY_RUN([ 113- AC_TRY_RUN([
110-int main(void) { 114-int main(void) {
@@ -118,6 +122,15 @@
118- T1_AA_TYPE64="-DT1_AA_TYPE64=long" 122- T1_AA_TYPE64="-DT1_AA_TYPE64=long"
119-else 123-else
120- T1_AA_TYPE64= 124- T1_AA_TYPE64=
125+T1_AA_TYPE64=""
126+for type in long long_long; do
127+ if test x"`eval echo \\$ac_cv_sizeof_$type`" = "x8"; then
128+ AC_MSG_WARN("$type is 64 bit")
129+ T1_AA_TYPE64="-DT1_AA_TYPE64=\"`echo $type|tr '_' ' '`\""
130+ break
131+ fi
132+done
133+
121+if test x"$T1_AA_TYPE64" = "x"; then 134+if test x"$T1_AA_TYPE64" = "x"; then
122+ AC_MSG_ERROR("Unable to determine which integer type is 64 bit.") 135+ AC_MSG_ERROR("Unable to determine which integer type is 64 bit.")
123 fi 136 fi