summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/redis/redis/lua-update-Makefile-to-use-environment-build-setting.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/redis/redis/lua-update-Makefile-to-use-environment-build-setting.patch')
-rw-r--r--meta-oe/recipes-extended/redis/redis/lua-update-Makefile-to-use-environment-build-setting.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/redis/redis/lua-update-Makefile-to-use-environment-build-setting.patch b/meta-oe/recipes-extended/redis/redis/lua-update-Makefile-to-use-environment-build-setting.patch
new file mode 100644
index 000000000..c4d1bc493
--- /dev/null
+++ b/meta-oe/recipes-extended/redis/redis/lua-update-Makefile-to-use-environment-build-setting.patch
@@ -0,0 +1,54 @@
1From 394108035d350ae662a431c80131f812b5f72dff Mon Sep 17 00:00:00 2001
2From: Venture Research <tech@ventureresearch.com>
3Date: Fri, 8 Feb 2013 20:22:19 -0600
4Subject: [PATCH] lua: update Makefile to use environment build settings
5
6OE-specific parameters, instead of overriding all of these simply use
7the ones that are already passed in. Also configure for only Linux...
8
9Signed-off-by: Venture Research <tech@ventureresearch.com>
10---
11 deps/lua/src/Makefile | 18 +++++++-----------
12 1 file changed, 7 insertions(+), 11 deletions(-)
13
14diff --git a/deps/lua/src/Makefile b/deps/lua/src/Makefile
15index 77d6a48..888d0da 100644
16--- a/deps/lua/src/Makefile
17+++ b/deps/lua/src/Makefile
18@@ -5,18 +5,14 @@
19 # == CHANGE THE SETTINGS BELOW TO SUIT YOUR ENVIRONMENT =======================
20
21 # Your platform. See PLATS for possible values.
22-PLAT= none
23+PLAT= linux
24
25-CC= gcc
26-CFLAGS= -O2 -Wall $(MYCFLAGS)
27-AR= ar rcu
28-RANLIB= ranlib
29-RM= rm -f
30-LIBS= -lm $(MYLIBS)
31-
32-MYCFLAGS=
33+MYCFLAGS=-DLUA_USE_LINUX
34 MYLDFLAGS=
35-MYLIBS=
36+MYLIBS=-Wl,-E -ldl -lreadline -lhistory -lncurses
37+
38+CFLAGS += $(MYCFLAGS)
39+LIBS += -lm $(MYLIBS)
40
41 # == END OF USER SETTINGS. NO NEED TO CHANGE ANYTHING BELOW THIS LINE =========
42
43@@ -48,7 +44,7 @@ o: $(ALL_O)
44 a: $(ALL_A)
45
46 $(LUA_A): $(CORE_O) $(LIB_O)
47- $(AR) $@ $?
48+ $(AR) rcu $@ $?
49 $(RANLIB) $@
50
51 $(LUA_T): $(LUA_O) $(LUA_A)
52--
531.8.1.2
54