diff options
Diffstat (limited to 'meta-oe/recipes-extended/redis/redis-7.2.6/0002-lua-update-Makefile-to-use-environment-build-setting.patch')
-rw-r--r-- | meta-oe/recipes-extended/redis/redis-7.2.6/0002-lua-update-Makefile-to-use-environment-build-setting.patch | 77 |
1 files changed, 77 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/redis/redis-7.2.6/0002-lua-update-Makefile-to-use-environment-build-setting.patch b/meta-oe/recipes-extended/redis/redis-7.2.6/0002-lua-update-Makefile-to-use-environment-build-setting.patch new file mode 100644 index 000000000..46330f506 --- /dev/null +++ b/meta-oe/recipes-extended/redis/redis-7.2.6/0002-lua-update-Makefile-to-use-environment-build-setting.patch | |||
@@ -0,0 +1,77 @@ | |||
1 | From 45ae5eb5c3482054073e06ab1a78e0aa9b96447f Mon Sep 17 00:00:00 2001 | ||
2 | From: Venture Research <tech@ventureresearch.com> | ||
3 | Date: Fri, 8 Feb 2013 20:22:19 -0600 | ||
4 | Subject: [PATCH] lua: update Makefile to use environment build settings | ||
5 | |||
6 | OE-specific parameters, instead of overriding all of these simply use | ||
7 | the ones that are already passed in. Also configure for only Linux... | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | |||
11 | Signed-off-by: Venture Research <tech@ventureresearch.com> | ||
12 | |||
13 | Updated to work with 3.0.x | ||
14 | |||
15 | Signed-off-by: Armin Kuster <akust808@gmail.com> | ||
16 | |||
17 | updated to work wtih 6.2.1 | ||
18 | Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com> | ||
19 | --- | ||
20 | deps/Makefile | 1 - | ||
21 | deps/lua/Makefile | 1 - | ||
22 | deps/lua/src/Makefile | 16 ++++++---------- | ||
23 | 3 files changed, 6 insertions(+), 12 deletions(-) | ||
24 | |||
25 | diff --git a/deps/Makefile b/deps/Makefile | ||
26 | index 3bf0363..fd8765a 100644 | ||
27 | --- a/deps/Makefile | ||
28 | +++ b/deps/Makefile | ||
29 | @@ -94,7 +94,6 @@ endif | ||
30 | # lua's Makefile defines AR="ar rcu", which is unusual, and makes it more | ||
31 | # challenging to cross-compile lua (and redis). These defines make it easier | ||
32 | # to fit redis into cross-compilation environments, which typically set AR. | ||
33 | -AR=ar | ||
34 | ARFLAGS=rc | ||
35 | |||
36 | lua: .make-prerequisites | ||
37 | diff --git a/deps/lua/Makefile b/deps/lua/Makefile | ||
38 | index 209a132..72f4b2b 100644 | ||
39 | --- a/deps/lua/Makefile | ||
40 | +++ b/deps/lua/Makefile | ||
41 | @@ -33,7 +33,6 @@ INSTALL_DATA= $(INSTALL) -m 0644 | ||
42 | |||
43 | # Utilities. | ||
44 | MKDIR= mkdir -p | ||
45 | -RANLIB= ranlib | ||
46 | |||
47 | # == END OF USER SETTINGS. NO NEED TO CHANGE ANYTHING BELOW THIS LINE ========= | ||
48 | |||
49 | diff --git a/deps/lua/src/Makefile b/deps/lua/src/Makefile | ||
50 | index f3bba2f..1555ec0 100644 | ||
51 | --- a/deps/lua/src/Makefile | ||
52 | +++ b/deps/lua/src/Makefile | ||
53 | @@ -5,18 +5,14 @@ | ||
54 | # == CHANGE THE SETTINGS BELOW TO SUIT YOUR ENVIRONMENT ======================= | ||
55 | |||
56 | # Your platform. See PLATS for possible values. | ||
57 | -PLAT= none | ||
58 | +PLAT= linux | ||
59 | |||
60 | -CC?= gcc | ||
61 | -CFLAGS= -O2 -Wall $(MYCFLAGS) | ||
62 | -AR= ar rcu | ||
63 | -RANLIB= ranlib | ||
64 | -RM= rm -f | ||
65 | -LIBS= -lm $(MYLIBS) | ||
66 | - | ||
67 | -MYCFLAGS= | ||
68 | +MYCFLAGS=-DLUA_USE_LINUX | ||
69 | MYLDFLAGS= | ||
70 | -MYLIBS= | ||
71 | +MYLIBS=-Wl,-E -ldl -lreadline -lhistory -lncurses | ||
72 | + | ||
73 | +CFLAGS += $(MYCFLAGS) | ||
74 | +LIBS += -lm $(MYLIBS) | ||
75 | |||
76 | # == END OF USER SETTINGS. NO NEED TO CHANGE ANYTHING BELOW THIS LINE ========= | ||
77 | |||