summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb')
-rw-r--r--meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb b/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb
new file mode 100644
index 000000000..d69499db7
--- /dev/null
+++ b/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb
@@ -0,0 +1,49 @@
1SUMMARY = "The RARP daemon."
2DESCRIPTION = "RARP (Reverse Address Resolution Protocol) is a protocol which \
3allows individual devices on an IP network to get their own IP addresses from \
4the RARP server. Some machines (e.g. SPARC boxes) use this protocol instead \
5of e.g. DHCP to query their IP addresses during network bootup. \
6Linux kernels up to 2.2 used to provide a kernel daemon for this service, \
7but since 2.3 kernels it is served by this userland daemon. \
8You should install rarpd if you want to set up a RARP server on your \
9network."
10SECTION = "System Environment/Daemons"
11
12SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/${PN}/${PN}-${PV}.tar.gz/be2a88f8ccddf2a40ac484cb3294fedc/${PN}-${PV}.tar.gz"
13SRC_URI[md5sum] = "be2a88f8ccddf2a40ac484cb3294fedc"
14SRC_URI[sha256sum] = "4d6145d435a5d8b567b9798620f57f9b0a464078a1deba267958f168fbe776e6"
15
16SRC_URI += "file://0001-rarpd.8-add-man-file.patch \
17 file://0002-Makefile-modify-compile-parameters.patch \
18 file://0003-rarpd.c-bug-fix.patch \
19 file://0004-rarpd.init-add-new-init-file.patch \
20 file://0005-ethernet.c-remove-it.patch \
21 file://ethers.sample \
22 file://rarpd.service \
23"
24
25LICENSE = "GPLv2+"
26LIC_FILES_CHKSUM = "file://rarpd.c;md5=199b20b172ea93121bc613a9c77b6931"
27
28S = "${WORKDIR}/${PN}"
29
30do_install() {
31 install -d ${D}${sysconfdir}/init.d
32 install -d ${D}${sbindir}
33 install -d ${D}${mandir}/man8
34 install -m 755 rarpd.init ${D}${sysconfdir}/init.d/rarpd
35 install -m 755 rarpd ${D}${sbindir}/rarpd
36 install -m 644 rarpd.8 ${D}${mandir}/man8/rarpd.8
37 install -m 644 ${WORKDIR}/ethers.sample ${D}${sysconfdir}/ethers
38
39 if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then
40 install -d ${D}${systemd_unitdir}/system
41 install -m 0644 ${WORKDIR}/rarpd.service ${D}${systemd_unitdir}/system/
42 fi
43}
44
45inherit ${@base_contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','',d)}
46
47SYSTEMD_PACKAGES = "${PN}"
48SYSTEMD_SERVICE_${PN} = "rarpd.service"
49SYSTEMD_AUTO_ENABLE = "disable"