summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/polkit/polkit_0.112.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/polkit/polkit_0.112.bb')
-rw-r--r--meta-oe/recipes-extended/polkit/polkit_0.112.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/polkit/polkit_0.112.bb b/meta-oe/recipes-extended/polkit/polkit_0.112.bb
new file mode 100644
index 000000000..72b182b95
--- /dev/null
+++ b/meta-oe/recipes-extended/polkit/polkit_0.112.bb
@@ -0,0 +1,46 @@
1SUMMARY = "PolicyKit Authorization Framework"
2DESCRIPTION = "The polkit package is an application-level toolkit for defining and handling the policy that allows unprivileged processes to speak to privileged processes."
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/polkit"
4LICENSE = "LGPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
6 file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4"
7
8DEPENDS = "expat glib-2.0 intltool-native gobject-introspection-stub mozjs"
9
10inherit autotools gtk-doc pkgconfig useradd systemd
11
12PACKAGECONFIG = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
13 ${@base_contains('DISTRO_FEATURES','systemd','systemd','consolekit',d)}"
14
15PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam"
16PACKAGECONFIG[systemd] = "--enable-libsystemd-login=yes --with-systemdsystemunitdir=${systemd_unitdir}/system/,--enable-libsystemd-login=no --with-systemdsystemunitdir=,systemd"
17# there is no --enable/--disable option for consolekit and it's not picked by shlibs, so add it to RDEPENDS
18PACKAGECONFIG[consolekit] = ",,,consolekit"
19
20PAM_SRC_URI = "file://polkit-1_pam.patch"
21SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \
22 ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
23 file://0001-configure.ac-Check-only-for-libsystemd-not-libsystem.patch \
24"
25
26SRC_URI[md5sum] = "b0f2fa00a55f47c6a5d88e9b73f80127"
27SRC_URI[sha256sum] = "d695f43cba4748a822fbe864dd32c4887c5da1c71694a47693ace5e88fcf6af6"
28
29EXTRA_OECONF = "--with-os-type=moblin --disable-man-pages --disable-introspection"
30
31PACKAGES =+ "${PN}-examples"
32
33FILES_${PN} += " \
34 ${libdir}/${BPN}-1 \
35 ${datadir}/dbus-1 \
36 ${datadir}/${BPN}-1 \
37"
38FILES_${PN}-dbg += "${libdir}/${BPN}-1/.debug"
39
40FILES_${PN}-examples = "${bindir}/*example*"
41
42USERADD_PACKAGES = "${PN}"
43USERADD_PARAM_${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd"
44
45SYSTEMD_SERVICE_${PN} = "${BPN}.service"
46SYSTEMD_AUTO_ENABLE = "disable"