summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/pmdk/files/0006-Makefile.inc-Allow-extra-libs-to-be-specified.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/pmdk/files/0006-Makefile.inc-Allow-extra-libs-to-be-specified.patch')
-rw-r--r--meta-oe/recipes-extended/pmdk/files/0006-Makefile.inc-Allow-extra-libs-to-be-specified.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/pmdk/files/0006-Makefile.inc-Allow-extra-libs-to-be-specified.patch b/meta-oe/recipes-extended/pmdk/files/0006-Makefile.inc-Allow-extra-libs-to-be-specified.patch
new file mode 100644
index 000000000..2042fdb25
--- /dev/null
+++ b/meta-oe/recipes-extended/pmdk/files/0006-Makefile.inc-Allow-extra-libs-to-be-specified.patch
@@ -0,0 +1,29 @@
1From a88e806f9ce8cc071e81abad688643d53f393176 Mon Sep 17 00:00:00 2001
2From: Alistair Francis <alistair.francis@wdc.com>
3Date: Mon, 10 Sep 2018 14:18:38 -0700
4Subject: [PATCH 3/3] Makefile.inc: Allow extra libs to be specified
5
6Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
7Upstream-Status: Pending
8---
9 src/Makefile.inc | 2 ++
10 src/common.inc | 2 ++
11 src/tools/Makefile.inc | 1 +
12 3 files changed, 5 insertions(+)
13
14diff --git a/src/common.inc b/src/common.inc
15index 032cb83ea..2d5c4bedf 100644
16--- a/src/common.inc
17+++ b/src/common.inc
18@@ -74,6 +74,8 @@ GCOV_CFLAGS=-fprofile-arcs -ftest-coverage --coverage
19 GCOV_LDFLAGS=-fprofile-arcs -ftest-coverage
20 GCOV_LIBS=-lgcov
21
22+LIBS += $(EXTRA_LIBS)
23+
24 osdep = $(1)_$(shell uname -s | tr "[:upper:]" "[:lower:]")$(2)
25 get_arch = $(shell $(CC) -dumpmachine | awk -F'[/-]' '{print $$1}')
26
27--
282.17.1
29