summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/pam/pam-plugin-ccreds/0003-Set-EXTENSION_SO-for-all-linux-targets.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/pam/pam-plugin-ccreds/0003-Set-EXTENSION_SO-for-all-linux-targets.patch')
-rw-r--r--meta-oe/recipes-extended/pam/pam-plugin-ccreds/0003-Set-EXTENSION_SO-for-all-linux-targets.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/pam/pam-plugin-ccreds/0003-Set-EXTENSION_SO-for-all-linux-targets.patch b/meta-oe/recipes-extended/pam/pam-plugin-ccreds/0003-Set-EXTENSION_SO-for-all-linux-targets.patch
new file mode 100644
index 000000000..988c37442
--- /dev/null
+++ b/meta-oe/recipes-extended/pam/pam-plugin-ccreds/0003-Set-EXTENSION_SO-for-all-linux-targets.patch
@@ -0,0 +1,40 @@
1From 2b137b0364c57505a95cb498660e3b97b557540d Mon Sep 17 00:00:00 2001
2From: Richard Leitner <richard.leitner@skidata.com>
3Date: Fri, 1 Jun 2018 13:24:15 +0200
4Subject: [PATCH 3/3] Set EXTENSION_SO for all linux* targets
5
6As EXTENSION_SO gets already set for linux and linux-gnu targets we
7should set it for all linux* targets. This is done by introducing a new
8"LINUX" value for the "TARGET_OS" helper variable.
9
10Signed-off-by: Richard Leitner <richard.leitner@skidata.com>
11---
12 configure.in | 5 +++--
13 1 file changed, 3 insertions(+), 2 deletions(-)
14
15diff --git a/configure.in b/configure.in
16index 0dbdf79..3829d9f 100644
17--- a/configure.in
18+++ b/configure.in
19@@ -35,7 +35,8 @@ hpux*) pam_ccreds_so_LD="/bin/ld"
20 TARGET_OS="HPUX" ;;
21 solaris*) pam_ccreds_so_LD="/usr/ccs/bin/ld"
22 pam_ccreds_so_LDFLAGS="-B dynamic -M \$(srcdir)/exports.solaris -G -B group -lc" ;;
23-linux*) pam_ccreds_so_LDFLAGS="-shared -Wl,-Bdynamic -Wl,--version-script,\$(srcdir)/exports.linux" ;;
24+linux*) pam_ccreds_so_LDFLAGS="-shared -Wl,-Bdynamic -Wl,--version-script,\$(srcdir)/exports.linux"
25+ TARGET_OS="LINUX" ;;
26 *) pam_ccreds_so_LDFLAGS="-shared" ;;
27 esac
28
29@@ -43,7 +44,7 @@ AC_SUBST(pam_ccreds_so_LD)
30 AC_SUBST(pam_ccreds_so_LDFLAGS)
31
32 AM_CONDITIONAL(USE_NATIVE_LINKER, test -n "$pam_ccreds_so_LD")
33-AM_CONDITIONAL(EXTENSION_SO, test "$target_os" = "linux" -o "$target_os" = "linux-gnu")
34+AM_CONDITIONAL(EXTENSION_SO, test "$TARGET_OS" = "LINUX")
35 AM_CONDITIONAL(EXTENSION_1, test "$TARGET_OS" = "HPUX")
36
37 if test -z "$use_gcrypt"; then
38--
392.11.0
40