summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libuio
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/libuio')
-rw-r--r--meta-oe/recipes-extended/libuio/libuio/0001-include-fcntl.h-for-O_RDWR-define.patch38
-rw-r--r--meta-oe/recipes-extended/libuio/libuio_0.2.1.bb6
2 files changed, 43 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/libuio/libuio/0001-include-fcntl.h-for-O_RDWR-define.patch b/meta-oe/recipes-extended/libuio/libuio/0001-include-fcntl.h-for-O_RDWR-define.patch
new file mode 100644
index 000000000..3cae5c992
--- /dev/null
+++ b/meta-oe/recipes-extended/libuio/libuio/0001-include-fcntl.h-for-O_RDWR-define.patch
@@ -0,0 +1,38 @@
1From d39c78d322585a32f9a55c67c25a99602ce08b12 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 1 Apr 2017 09:01:33 -0700
4Subject: [PATCH] include fcntl.h for O_RDWR define
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 tools/lsuio.c | 1 +
9 tools/rwuio.c | 1 +
10 2 files changed, 2 insertions(+)
11
12diff --git a/tools/lsuio.c b/tools/lsuio.c
13index 58eb922..4769446 100644
14--- a/tools/lsuio.c
15+++ b/tools/lsuio.c
16@@ -19,6 +19,7 @@
17 #include <stdio.h>
18 #include <sys/types.h>
19 #include <getopt.h>
20+#include <fcntl.h>
21
22 #include "system.h"
23 #include "uio_helper.h"
24diff --git a/tools/rwuio.c b/tools/rwuio.c
25index aef9e90..ebc71e1 100644
26--- a/tools/rwuio.c
27+++ b/tools/rwuio.c
28@@ -20,6 +20,7 @@
29 */
30 #include <stdio.h>
31 #include <stdlib.h>
32+#include <fcntl.h>
33 #include <sys/types.h>
34 #include <getopt.h>
35
36--
372.12.1
38
diff --git a/meta-oe/recipes-extended/libuio/libuio_0.2.1.bb b/meta-oe/recipes-extended/libuio/libuio_0.2.1.bb
index f4051977f..dd34c180a 100644
--- a/meta-oe/recipes-extended/libuio/libuio_0.2.1.bb
+++ b/meta-oe/recipes-extended/libuio/libuio_0.2.1.bb
@@ -4,12 +4,16 @@ LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" 4LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
5 5
6SRC_URI = "git://git.code.sf.net/p/libuio/code \ 6SRC_URI = "git://git.code.sf.net/p/libuio/code \
7 file://replace_inline_with_static-inline.patch" 7 file://replace_inline_with_static-inline.patch \
8 file://0001-include-fcntl.h-for-O_RDWR-define.patch \
9 "
8 10
9inherit autotools 11inherit autotools
10 12
11SRCREV = "ed4f07ea147ac403c28105ab44d01bbf524d36f9" 13SRCREV = "ed4f07ea147ac403c28105ab44d01bbf524d36f9"
12 14
15PV .= "+git${SRCPV}"
16
13S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
14 18
15PACKAGES += "${PN}-tools" 19PACKAGES += "${PN}-tools"