summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libreport/libreport_2.17.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/libreport/libreport_2.17.15.bb')
-rw-r--r--meta-oe/recipes-extended/libreport/libreport_2.17.15.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libreport/libreport_2.17.15.bb b/meta-oe/recipes-extended/libreport/libreport_2.17.15.bb
new file mode 100644
index 000000000..28c64a161
--- /dev/null
+++ b/meta-oe/recipes-extended/libreport/libreport_2.17.15.bb
@@ -0,0 +1,49 @@
1DESCRIPTION = "Libraries providing API for reporting different problems in applications \
2to different bug targets like Bugzilla, ftp, trac, etc..."
3SUMMARY = "Generic library for reporting various problems"
4HOMEPAGE = "https://abrt.readthedocs.org/"
5LICENSE = "GPL-2.0-or-later"
6DEPENDS = "xmlrpc-c xmlrpc-c-native intltool-native \
7 json-c libarchive libtar libnewt libproxy rpm \
8 augeas satyr systemd \
9"
10
11LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
12
13SRC_URI = "git://github.com/abrt/libreport.git;protocol=https;branch=master"
14SRC_URI += "file://0001-Makefile.am-remove-doc-and-apidoc.patch \
15 file://0002-configure.ac-remove-prog-test-of-xmlto-and-asciidoc.patch \
16 file://0003-without-build-plugins.patch \
17 file://0004-configure.ac-remove-prog-test-of-augparse.patch \
18"
19
20SRCREV = "f6bb06a699617d078fcd4f8b71b4d063bf47b52b"
21
22UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
23
24S = "${WORKDIR}/git"
25
26inherit features_check
27REQUIRED_DISTRO_FEATURES = "systemd"
28
29inherit gettext autotools python3native python3targetconfig pkgconfig
30
31PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','x11','gtk','',d)}"
32PACKAGECONFIG[gtk] = "--with-gtk, --without-gtk, gtk+3,"
33
34EXTRA_OECONF += "--with-python3"
35
36RDEPENDS:python3-libreport += "${PN}"
37
38do_patch[prefuncs] += "do_gen_version"
39do_gen_version() {
40 cd ${S}
41 ./gen-version
42}
43
44PACKAGES += "python3-libreport"
45
46FILES:${PN} += "${datadir}/*"
47FILES:${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*/.debug"
48FILES:python3-libreport = "${PYTHON_SITEPACKAGES_DIR}/*"
49