diff options
Diffstat (limited to 'meta-oe/recipes-extended/icewm/icewm_2.6.0.bb')
-rw-r--r-- | meta-oe/recipes-extended/icewm/icewm_2.6.0.bb | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/icewm/icewm_2.6.0.bb b/meta-oe/recipes-extended/icewm/icewm_2.6.0.bb new file mode 100644 index 0000000000..90c0d244f2 --- /dev/null +++ b/meta-oe/recipes-extended/icewm/icewm_2.6.0.bb | |||
@@ -0,0 +1,46 @@ | |||
1 | DESCRIPTION = "Ice Window Manager (IceWM)" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=4a26952467ef79a7efca4a9cf52d417b" | ||
4 | |||
5 | SRC_URI = "https://github.com/ice-wm/${BPN}/releases/download/${PV}/${BPN}-${PV}.tar.lz \ | ||
6 | file://0001-configure.ac-skip-running-test-program-when-cross-co.patch \ | ||
7 | " | ||
8 | SRC_URI[sha256sum] = "33cc69ba1fb762d85cc2755a930d6cf1a7c23e33f736ef2ec01c59d612f9b2eb" | ||
9 | |||
10 | UPSTREAM_CHECK_URI = "https://github.com/ice-wm/${BPN}/releases" | ||
11 | |||
12 | inherit autotools pkgconfig gettext perlnative features_check qemu update-alternatives | ||
13 | REQUIRED_DISTRO_FEATURES = "x11" | ||
14 | |||
15 | EXTRA_OECONF += "--with-libdir=${datadir}/icewm \ | ||
16 | --with-cfgdir=${sysconfdir}/icewm \ | ||
17 | --with-docdir=${docdir}/icewm \ | ||
18 | --enable-fribidi \ | ||
19 | --enable-xinerama \ | ||
20 | --enable-shape" | ||
21 | |||
22 | DEPENDS = "asciidoc-native fontconfig fribidi gdk-pixbuf imlib2 libxft libxpm libxrandr \ | ||
23 | libxinerama libice libsm libx11 libxext libxrender libxcomposite libxdamage \ | ||
24 | libxfixes" | ||
25 | DEPENDS_append = " qemu-native" | ||
26 | RDEPENDS_${PN} = "perl fribidi" | ||
27 | |||
28 | do_compile_prepend_class-target() { | ||
29 | |||
30 | cd ${B} | ||
31 | oe_runmake -C src genpref | ||
32 | |||
33 | qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}',['${B}/src/.libs','${STAGING_DIR_TARGET}/${libdir}','${STAGING_DIR_TARGET}/${base_libdir}'])}" | ||
34 | cat >qemuwrapper <<EOF | ||
35 | #!/bin/sh | ||
36 | ${qemu_binary} src/genpref "\$@" | ||
37 | EOF | ||
38 | chmod +x qemuwrapper | ||
39 | ./qemuwrapper > src/preferences | ||
40 | } | ||
41 | |||
42 | ALTERNATIVE_${PN} = "x-session-manager" | ||
43 | ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/icewm-session" | ||
44 | ALTERNATIVE_PRIORITY_${PN} = "100" | ||
45 | |||
46 | FILES_${PN} += "${datadir}/xsessions" | ||