summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/fluentbit/fluentbit/jemalloc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/fluentbit/fluentbit/jemalloc.patch')
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit/jemalloc.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/jemalloc.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/jemalloc.patch
new file mode 100644
index 000000000..abaf92c05
--- /dev/null
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit/jemalloc.patch
@@ -0,0 +1,18 @@
1Add --with-jemalloc-prefix=je_ so it compiles on musl
2
3Signed-off-by: Khem Raj <raj.khem@gmail.com>
4Upstream-Status: Pending
5
6Index: fluent-bit-0.12.1/CMakeLists.txt
7===================================================================
8--- fluent-bit-0.12.1.orig/CMakeLists.txt
9+++ fluent-bit-0.12.1/CMakeLists.txt
10@@ -325,7 +325,7 @@ if(FLB_JEMALLOC AND ${CMAKE_SYSTEM_NAME}
11 # Link to Jemalloc as an external dependency
12 ExternalProject_Add(jemalloc
13 SOURCE_DIR ${CMAKE_CURRENT_SOURCE_DIR}/lib/jemalloc
14- CONFIGURE_COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/lib/jemalloc/configure ${AUTOCONF_HOST_OPT} --with-lg-quantum=3 --enable-cc-silence --prefix=<INSTALL_DIR>
15+ CONFIGURE_COMMAND ${CMAKE_CURRENT_SOURCE_DIR}/lib/jemalloc/configure --with-jemalloc-prefix=je_ ${AUTOCONF_HOST_OPT} --with-lg-quantum=3 --enable-cc-silence --prefix=<INSTALL_DIR>
16 CFLAGS=-std=gnu99\ -Wall\ -pipe\ -g3\ -O3\ -funroll-loops
17 BUILD_COMMAND ${MAKE}
18 INSTALL_DIR ${CMAKE_CURRENT_BINARY_DIR}/