summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/dash/dash_0.5.9.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/dash/dash_0.5.9.1.bb')
-rw-r--r--meta-oe/recipes-extended/dash/dash_0.5.9.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/dash/dash_0.5.9.1.bb b/meta-oe/recipes-extended/dash/dash_0.5.9.1.bb
new file mode 100644
index 000000000..6dee66f69
--- /dev/null
+++ b/meta-oe/recipes-extended/dash/dash_0.5.9.1.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Small and fast POSIX-compliant shell"
2HOMEPAGE = "http://gondor.apana.org.au/~herbert/dash/"
3SECTION = "System Environment/Shells"
4
5LICENSE = "BSD & GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b5262b4a1a1bff72b48e935531976d2e"
7
8inherit autotools update-alternatives
9
10SRC_URI = "http://gondor.apana.org.au/~herbert/${BPN}/files/${BP}.tar.gz \
11 file://0001-Fix-printf-format-errors-with-clang.patch \
12 "
13SRC_URI[md5sum] = "6472702a8d9760d166ef8333dcb527a6"
14SRC_URI[sha256sum] = "5ecd5bea72a93ed10eb15a1be9951dd51b52e5da1d4a7ae020efd9826b49e659"
15
16EXTRA_OECONF += "--bindir=${base_bindir}"
17
18ALTERNATIVE_${PN} = "sh"
19ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
20ALTERNATIVE_TARGET[sh] = "${base_bindir}/dash"
21ALTERNATIVE_PRIORITY = "10"
22
23pkg_postinst_${PN} () {
24 grep -q "^${base_bindir}/dash$" $D${sysconfdir}/shells || echo ${base_bindir}/dash >> $D${sysconfdir}/shells
25}
26
27pkg_postrm_${PN} () {
28 printf "$(grep -v "^${base_bindir}/dash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells
29}