summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/collectd/collectd/glibc-2.20-compatiblity.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/collectd/collectd/glibc-2.20-compatiblity.patch')
-rw-r--r--meta-oe/recipes-extended/collectd/collectd/glibc-2.20-compatiblity.patch102
1 files changed, 102 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/collectd/collectd/glibc-2.20-compatiblity.patch b/meta-oe/recipes-extended/collectd/collectd/glibc-2.20-compatiblity.patch
new file mode 100644
index 000000000..2596bedf9
--- /dev/null
+++ b/meta-oe/recipes-extended/collectd/collectd/glibc-2.20-compatiblity.patch
@@ -0,0 +1,102 @@
1This makes it forward compatible with glibc 2.20+ where _BSD_SOURCE
2macro has been deprecated.
3
4Fixes warnings like
5
6usr/include/features.h:148:3: error: #warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE" [-Werror=cpp]
7| # warning "_BSD_SOURCE and _SVID_SOURCE are deprecated, use _DEFAULT_SOURCE"
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10Upstream-Status: Pending
11Index: collectd-5.4.1/configure.ac
12===================================================================
13--- collectd-5.4.1.orig/configure.ac 2014-09-03 01:21:10.666084244 -0700
14+++ collectd-5.4.1/configure.ac 2014-09-03 01:31:27.794084244 -0700
15@@ -1288,6 +1288,7 @@
16
17 AC_CHECK_MEMBERS([struct udphdr.uh_dport, struct udphdr.uh_sport], [], [],
18 [#define _BSD_SOURCE
19+#define _DEFAULT_SOURCE 1
20 #if HAVE_STDINT_H
21 # include <stdint.h>
22 #endif
23@@ -1309,6 +1310,7 @@
24 ])
25 AC_CHECK_MEMBERS([struct udphdr.dest, struct udphdr.source], [], [],
26 [#define _BSD_SOURCE
27+#define _DEFAULT_SOURCE 1
28 #if HAVE_STDINT_H
29 # include <stdint.h>
30 #endif
31Index: collectd-5.4.1/src/dns.c
32===================================================================
33--- collectd-5.4.1.orig/src/dns.c 2014-01-26 00:09:14.856391886 -0800
34+++ collectd-5.4.1/src/dns.c 2014-09-03 01:32:37.666084244 -0700
35@@ -22,6 +22,7 @@
36 **/
37
38 #define _BSD_SOURCE
39+#define _DEFAULT_SOURCE 1
40
41 #include "collectd.h"
42 #include "common.h"
43Index: collectd-5.4.1/src/exec.c
44===================================================================
45--- collectd-5.4.1.orig/src/exec.c 2014-01-26 00:09:14.860391963 -0800
46+++ collectd-5.4.1/src/exec.c 2014-09-03 01:32:28.874084244 -0700
47@@ -24,6 +24,7 @@
48 **/
49
50 #define _BSD_SOURCE /* For setgroups */
51+#define _DEFAULT_SOURCE 1
52
53 #include "collectd.h"
54 #include "common.h"
55Index: collectd-5.4.1/src/load.c
56===================================================================
57--- collectd-5.4.1.orig/src/load.c 2014-01-26 00:09:23.532559941 -0800
58+++ collectd-5.4.1/src/load.c 2014-09-03 01:32:51.462084244 -0700
59@@ -22,6 +22,7 @@
60 **/
61
62 #define _BSD_SOURCE
63+#define _DEFAULT_SOURCE 1
64
65 #include "collectd.h"
66 #include "common.h"
67Index: collectd-5.4.1/src/network.c
68===================================================================
69--- collectd-5.4.1.orig/src/network.c 2014-01-26 00:09:23.532559941 -0800
70+++ collectd-5.4.1/src/network.c 2014-09-03 01:32:44.522084244 -0700
71@@ -23,6 +23,7 @@
72 **/
73
74 #define _BSD_SOURCE /* For struct ip_mreq */
75+#define _DEFAULT_SOURCE 1
76
77 #include "collectd.h"
78 #include "plugin.h"
79Index: collectd-5.4.1/src/ntpd.c
80===================================================================
81--- collectd-5.4.1.orig/src/ntpd.c 2014-01-26 00:09:14.880392351 -0800
82+++ collectd-5.4.1/src/ntpd.c 2014-09-03 01:32:20.350084244 -0700
83@@ -20,6 +20,7 @@
84 **/
85
86 #define _BSD_SOURCE /* For NI_MAXHOST */
87+#define _DEFAULT_SOURCE 1
88
89 #include "collectd.h"
90 #include "common.h"
91Index: collectd-5.4.1/src/utils_dns.c
92===================================================================
93--- collectd-5.4.1.orig/src/utils_dns.c 2014-01-26 00:09:14.908392893 -0800
94+++ collectd-5.4.1/src/utils_dns.c 2014-09-03 01:31:47.062084244 -0700
95@@ -34,6 +34,7 @@
96 */
97
98 #define _BSD_SOURCE
99+#define _DEFAULT_SOURCE 1
100
101 #include "collectd.h"
102 #include "plugin.h"