summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb
index b340a4821..4431edd6c 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb
@@ -93,17 +93,17 @@ python do_unpack() {
93 import shutil 93 import shutil
94 94
95 bb.build.exec_func('base_do_unpack', d) 95 bb.build.exec_func('base_do_unpack', d)
96 shutil.rmtree(d.getVar('S') + '/deps/openssl', True) 96 shutil.rmtree(d.getVar('S') + '/deps/openssl')
97 if 'ares' in d.getVar('PACKAGECONFIG'): 97 if 'ares' in d.getVar('PACKAGECONFIG'):
98 shutil.rmtree(d.getVar('S') + '/deps/cares', True) 98 shutil.rmtree(d.getVar('S') + '/deps/cares')
99 if 'brotli' in d.getVar('PACKAGECONFIG'): 99 if 'brotli' in d.getVar('PACKAGECONFIG'):
100 shutil.rmtree(d.getVar('S') + '/deps/brotli', True) 100 shutil.rmtree(d.getVar('S') + '/deps/brotli')
101 if 'libuv' in d.getVar('PACKAGECONFIG'): 101 if 'libuv' in d.getVar('PACKAGECONFIG'):
102 shutil.rmtree(d.getVar('S') + '/deps/uv', True) 102 shutil.rmtree(d.getVar('S') + '/deps/uv')
103 if 'nghttp2' in d.getVar('PACKAGECONFIG'): 103 if 'nghttp2' in d.getVar('PACKAGECONFIG'):
104 shutil.rmtree(d.getVar('S') + '/deps/nghttp2', True) 104 shutil.rmtree(d.getVar('S') + '/deps/nghttp2')
105 if 'zlib' in d.getVar('PACKAGECONFIG'): 105 if 'zlib' in d.getVar('PACKAGECONFIG'):
106 shutil.rmtree(d.getVar('S') + '/deps/zlib', True) 106 shutil.rmtree(d.getVar('S') + '/deps/zlib')
107} 107}
108 108
109# V8's JIT infrastructure requires binaries such as mksnapshot and 109# V8's JIT infrastructure requires binaries such as mksnapshot and