summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-02-20 15:46:09 +0000
committerKhem Raj <raj.khem@gmail.com>2023-02-22 01:07:43 -0800
commitb4c3c0b279d8e2c510c9881fdd24f27984695e18 (patch)
treec7e5858b71f8124c02933a92d21af7f91e6cc26e /meta-oe/recipes-devtools
parent22a608d4601b412bb215be32eb067d20d16fbb1d (diff)
downloadmeta-openembedded-b4c3c0b279d8e2c510c9881fdd24f27984695e18.tar.gz
nodejs: remove redundant expand=True to getVar()
The expand argument defaults to True, so there's no need to specify it. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb
index b340a4821..4431edd6c 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_18.12.1.bb
@@ -93,17 +93,17 @@ python do_unpack() {
93 import shutil 93 import shutil
94 94
95 bb.build.exec_func('base_do_unpack', d) 95 bb.build.exec_func('base_do_unpack', d)
96 shutil.rmtree(d.getVar('S') + '/deps/openssl', True) 96 shutil.rmtree(d.getVar('S') + '/deps/openssl')
97 if 'ares' in d.getVar('PACKAGECONFIG'): 97 if 'ares' in d.getVar('PACKAGECONFIG'):
98 shutil.rmtree(d.getVar('S') + '/deps/cares', True) 98 shutil.rmtree(d.getVar('S') + '/deps/cares')
99 if 'brotli' in d.getVar('PACKAGECONFIG'): 99 if 'brotli' in d.getVar('PACKAGECONFIG'):
100 shutil.rmtree(d.getVar('S') + '/deps/brotli', True) 100 shutil.rmtree(d.getVar('S') + '/deps/brotli')
101 if 'libuv' in d.getVar('PACKAGECONFIG'): 101 if 'libuv' in d.getVar('PACKAGECONFIG'):
102 shutil.rmtree(d.getVar('S') + '/deps/uv', True) 102 shutil.rmtree(d.getVar('S') + '/deps/uv')
103 if 'nghttp2' in d.getVar('PACKAGECONFIG'): 103 if 'nghttp2' in d.getVar('PACKAGECONFIG'):
104 shutil.rmtree(d.getVar('S') + '/deps/nghttp2', True) 104 shutil.rmtree(d.getVar('S') + '/deps/nghttp2')
105 if 'zlib' in d.getVar('PACKAGECONFIG'): 105 if 'zlib' in d.getVar('PACKAGECONFIG'):
106 shutil.rmtree(d.getVar('S') + '/deps/zlib', True) 106 shutil.rmtree(d.getVar('S') + '/deps/zlib')
107} 107}
108 108
109# V8's JIT infrastructure requires binaries such as mksnapshot and 109# V8's JIT infrastructure requires binaries such as mksnapshot and