diff options
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r-- | meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb | 8 |
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb index e874e4a5e..8efa31e95 100644 --- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb +++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb | |||
@@ -37,22 +37,22 @@ python () { | |||
37 | if arch == "aarch64": | 37 | if arch == "aarch64": |
38 | tunes = d.getVar("TUNE_FEATURES") | 38 | tunes = d.getVar("TUNE_FEATURES") |
39 | if not tunes: | 39 | if not tunes: |
40 | raise bb.parse.SkipPackage("%s-%s Needs support for crypto on armv8" % (pkgn, pkgv)) | 40 | raise bb.parse.SkipRecipe("%s-%s Needs support for crypto on armv8" % (pkgn, pkgv)) |
41 | return | 41 | return |
42 | pkgn = d.getVar("PN") | 42 | pkgn = d.getVar("PN") |
43 | pkgv = d.getVar("PV") | 43 | pkgv = d.getVar("PV") |
44 | if "crypto" not in tunes: | 44 | if "crypto" not in tunes: |
45 | raise bb.parse.SkipPackage("%s-%s Needs support for crypto on armv8" % (pkgn, pkgv)) | 45 | raise bb.parse.SkipRecipe("%s-%s Needs support for crypto on armv8" % (pkgn, pkgv)) |
46 | 46 | ||
47 | if arch == "x86_64": | 47 | if arch == "x86_64": |
48 | tunes = d.getVar("TUNE_FEATURES") | 48 | tunes = d.getVar("TUNE_FEATURES") |
49 | if not tunes: | 49 | if not tunes: |
50 | raise bb.parse.SkipPackage("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv)) | 50 | raise bb.parse.SkipRecipe("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv)) |
51 | return | 51 | return |
52 | pkgn = d.getVar("PN") | 52 | pkgn = d.getVar("PN") |
53 | pkgv = d.getVar("PV") | 53 | pkgv = d.getVar("PV") |
54 | if "corei7" not in tunes: | 54 | if "corei7" not in tunes: |
55 | raise bb.parse.SkipPackage("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv)) | 55 | raise bb.parse.SkipRecipe("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv)) |
56 | 56 | ||
57 | } | 57 | } |
58 | 58 | ||