summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb')
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb24
1 files changed, 12 insertions, 12 deletions
diff --git a/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
index 23bec15bb..a3698d30f 100644
--- a/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
+++ b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
@@ -9,18 +9,18 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
9CONFIGFILESURI ?= "" 9CONFIGFILESURI ?= ""
10 10
11CONFIGFILESURI_aarch64 = "file://config.h \ 11CONFIGFILESURI_aarch64 = "file://config.h \
12 file://_numpyconfig.h \ 12 file://_numpyconfig.h \
13 " 13"
14CONFIGFILESURI_arm = "file://config.h \ 14CONFIGFILESURI_arm = "file://config.h \
15 file://numpyconfig.h \ 15 file://numpyconfig.h \
16 " 16"
17CONFIGFILESURI_mipsel = "file://config.h \ 17CONFIGFILESURI_mipsel = "file://config.h \
18 file://numpyconfig.h \ 18 file://numpyconfig.h \
19 " 19"
20 20
21CONFIGFILESURI_i586 = "file://config.h \ 21CONFIGFILESURI_i586 = "file://config.h \
22 file://numpyconfig.h \ 22 file://numpyconfig.h \
23 " 23"
24 24
25S = "${WORKDIR}/numpy-${PV}" 25S = "${WORKDIR}/numpy-${PV}"
26 26
@@ -29,10 +29,10 @@ inherit distutils
29# Make the build fail and replace *config.h with proper one 29# Make the build fail and replace *config.h with proper one
30# This is a ugly, ugly hack - Koen 30# This is a ugly, ugly hack - Koen
31do_compile_prepend() { 31do_compile_prepend() {
32 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ 32 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
33 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ 33 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
34 true 34 true
35 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/ 35 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
36} 36}
37 37
38FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a" 38FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
@@ -59,4 +59,4 @@ RDEPENDS_${PN} = "python-unittest \
59 python-email \ 59 python-email \
60 python-subprocess \ 60 python-subprocess \
61 python-compression \ 61 python-compression \
62 " 62"