summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/pistache/pistache_0.4.26.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/pistache/pistache_0.4.26.bb')
-rw-r--r--meta-oe/recipes-devtools/pistache/pistache_0.4.26.bb20
1 files changed, 11 insertions, 9 deletions
diff --git a/meta-oe/recipes-devtools/pistache/pistache_0.4.26.bb b/meta-oe/recipes-devtools/pistache/pistache_0.4.26.bb
index 953c249664..feffff623d 100644
--- a/meta-oe/recipes-devtools/pistache/pistache_0.4.26.bb
+++ b/meta-oe/recipes-devtools/pistache/pistache_0.4.26.bb
@@ -9,22 +9,24 @@ SRCREV = "ddffda861aa49012dcda28f1362d0339e718cd52"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12DEPENDS = "openssl brotli zlib zstd rapidjson" 12DEPENDS = "rapidjson"
13 13
14inherit pkgconfig meson 14inherit pkgconfig meson
15 15
16PACKAGECONFIG ?= "openssl brotli deflate zstd examples" 16PACKAGECONFIG ?= "openssl brotli deflate zstd examples"
17PACKAGECONFIG[openssl] = "-DPISTACHE_USE_SSL=true, -DPISTACHE_USE_SSL=false" 17PACKAGECONFIG[openssl] = "-DPISTACHE_USE_SSL=true, -DPISTACHE_USE_SSL=false, openssl"
18PACKAGECONFIG[brotli] = "-DPISTACHE_USE_CONTENT_ENCODING_BROTLI=true, -DPISTACHE_USE_CONTENT_ENCODING_BROTLI=false" 18PACKAGECONFIG[brotli] = "-DPISTACHE_USE_CONTENT_ENCODING_BROTLI=true, -DPISTACHE_USE_CONTENT_ENCODING_BROTLI=false, brotli"
19PACKAGECONFIG[deflate] = "-DPISTACHE_USE_CONTENT_ENCODING_DEFLATE=true, -DPISTACHE_USE_CONTENT_ENCODING_DEFLATE=false" 19PACKAGECONFIG[deflate] = "-DPISTACHE_USE_CONTENT_ENCODING_DEFLATE=true, -DPISTACHE_USE_CONTENT_ENCODING_DEFLATE=false, zlib"
20PACKAGECONFIG[zstd] = "-DPISTACHE_USE_CONTENT_ENCODING_ZSTD=true, -DPISTACHE_USE_CONTENT_ENCODING_ZSTD=false" 20PACKAGECONFIG[zstd] = "-DPISTACHE_USE_CONTENT_ENCODING_ZSTD=true, -DPISTACHE_USE_CONTENT_ENCODING_ZSTD=false, zstd"
21PACKAGECONFIG[examples] = "-DPISTACHE_BUILD_EXAMPLES=true, -DPISTACHE_BUILD_EXAMPLES=false" 21PACKAGECONFIG[examples] = "-DPISTACHE_BUILD_EXAMPLES=true, -DPISTACHE_BUILD_EXAMPLES=false"
22PACKAGECONFIG[test] = "-DPISTACHE_BUILD_TESTS=true, -DPISTACHE_BUILD_TESTS=false" 22PACKAGECONFIG[test] = "-DPISTACHE_BUILD_TESTS=true, -DPISTACHE_BUILD_TESTS=false, gtest curl"
23 23
24do_install:append () { 24do_install:append () {
25 install -d ${D}${bindir} 25 if ${@bb.utils.contains("PACKAGECONFIG", "examples", "true", "false", d)}; then
26 rm -rf ${B}/examples/*.p/ 26 install -d ${D}${bindir}
27 install -m 0755 ${B}/examples/run* ${D}${bindir}/ 27 rm -rf ${B}/examples/*.p/
28 install -m 0755 ${B}/examples/run* ${D}${bindir}/
29 fi
28} 30}
29 31
30PACKAGES += "${PN}-examples" 32PACKAGES += "${PN}-examples"