summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/php/php/phar-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/php/php/phar-makefile.patch')
-rw-r--r--meta-oe/recipes-devtools/php/php/phar-makefile.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/php/php/phar-makefile.patch b/meta-oe/recipes-devtools/php/php/phar-makefile.patch
index 6fde25127..9d1dc7b9a 100644
--- a/meta-oe/recipes-devtools/php/php/phar-makefile.patch
+++ b/meta-oe/recipes-devtools/php/php/phar-makefile.patch
@@ -4,8 +4,8 @@ index fc93d1d..9a8cd65 100755
4+++ b/ext/phar/Makefile.frag 4+++ b/ext/phar/Makefile.frag
5@@ -6,19 +6,8 @@ pharcmd: $(builddir)/phar.php $(builddir)/phar.phar 5@@ -6,19 +6,8 @@ pharcmd: $(builddir)/phar.php $(builddir)/phar.phar
6 6
7 PHP_PHARCMD_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' -d phar.readonly=0 -d 'safe_mode=0' 7 PHP_PHARCMD_SETTINGS = -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' -d phar.readonly=0 -d 'safe_mode=0'
8 PHP_PHARCMD_EXECUTABLE = ` \ 8 PHP_PHARCMD_EXECUTABLE = ` \
9- if test -x "$(top_builddir)/$(SAPI_CLI_PATH)"; then \ 9- if test -x "$(top_builddir)/$(SAPI_CLI_PATH)"; then \
10- $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \ 10- $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \
11- if test "x$(PHP_MODULES)" != "x"; then \ 11- if test "x$(PHP_MODULES)" != "x"; then \
@@ -21,6 +21,6 @@ index fc93d1d..9a8cd65 100755
21- fi;` 21- fi;`
22+ $(top_srcdir)/build/shtool echo -n -- "$(PHP_EXECUTABLE)"; ` 22+ $(top_srcdir)/build/shtool echo -n -- "$(PHP_EXECUTABLE)"; `
23+ 23+
24 PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(INSTALL_ROOT)$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";` 24 PHP_PHARCMD_BANG = `$(top_srcdir)/build/shtool echo -n -- "$(INSTALL_ROOT)$(bindir)/$(program_prefix)php$(program_suffix)$(EXEEXT)";`
25 25
26 $(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc 26 $(builddir)/phar/phar.inc: $(srcdir)/phar/phar.inc