summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/microsoft-gsl/microsoft-gsl_4.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/microsoft-gsl/microsoft-gsl_4.0.0.bb')
-rw-r--r--meta-oe/recipes-devtools/microsoft-gsl/microsoft-gsl_4.0.0.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/microsoft-gsl/microsoft-gsl_4.0.0.bb b/meta-oe/recipes-devtools/microsoft-gsl/microsoft-gsl_4.0.0.bb
new file mode 100644
index 000000000..7fc31486f
--- /dev/null
+++ b/meta-oe/recipes-devtools/microsoft-gsl/microsoft-gsl_4.0.0.bb
@@ -0,0 +1,43 @@
1SUMMARY = "GSL: Guidelines Support Library"
2DESCRIPTION = "The Guidelines Support Library (GSL) contains functions \
3 and types that are suggested for use by the C++ Core Guidelines \
4 maintained by the Standard C++ Foundation. \
5 This repo contains Microsoft's implementation of GSL."
6HOMEPAGE = "https://github.com/microsoft/GSL"
7
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=363055e71e77071107ba2bb9a54bd9a7"
10
11SRC_URI = "git://github.com/microsoft/GSL.git;protocol=https;branch=main \
12 file://run-ptest \
13 file://0001-Fix-initialization-in-test-1140.patch \
14 file://0002-Fix-gcc-build-problem.patch \
15 file://0003-Adapt-check_cxx_compiler_flag-to-cmake-3.0.2.patch \
16"
17SRCREV = "a3534567187d2edc428efd3f13466ff75fe5805c"
18
19S = "${WORKDIR}/git"
20
21inherit cmake pkgconfig ptest
22
23# this is header-only library
24ALLOW_EMPTY:${PN} = "1"
25
26PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'ptest','', d)}"
27PACKAGECONFIG[ptest] = "-DGSL_TEST=ON,-DGSL_TEST=OFF,googletest"
28
29# clang disagrees with https://github.com/google/googletest/pull/3457
30CXXFLAGS:append:toolchain-clang = " -Wno-error=switch-default"
31
32do_install_ptest() {
33 install -d ${D}${bindir}
34 install -m 0755 ${B}/tests/gsl_tests ${D}${bindir}
35 install -m 0755 ${B}/tests/gsl_noexcept_tests ${D}${bindir}
36}
37
38FILES:${PN}-ptest = "${bindir}/gsl*_tests"
39
40# there is already other gsl recipe, so recipe name does not match the real component name
41CVE_PRODUCT = "microsoft:gsl"
42
43BBCLASSEXTEND = "native nativesdk"