summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/ltrace/ltrace_git.bb')
-rw-r--r--meta-oe/recipes-devtools/ltrace/ltrace_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/ltrace/ltrace_git.bb b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
new file mode 100644
index 000000000..507747ae1
--- /dev/null
+++ b/meta-oe/recipes-devtools/ltrace/ltrace_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "ltrace intercepts and records dynamic library calls"
2
3DESCRIPTION = "ltrace intercepts and records dynamic library calls \
4which are called by an executed process and the signals received by that process. \
5It can also intercept and print the system calls executed by the program.\
6"
7HOMEPAGE = "http://ltrace.org/"
8
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
11
12PE = "1"
13PV = "7.2+git${SRCPV}"
14SRCREV = "f44b28421979cec88d6d6a778fc27a8cd514f508"
15
16DEPENDS = "elfutils"
17RDEPENDS_${PN} = "elfutils"
18SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git \
19 file://ltrace-0.7.2-unused-typedef.patch \
20 "
21S = "${WORKDIR}/git"
22
23inherit autotools
24
25PACKAGECONFIG[unwind] = "--with-libunwind,--without-libunwind,libunwind"
26
27do_configure_prepend () {
28 ( cd ${S}; ./autogen.sh )
29}