summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/dt/dt_18.32.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/dt/dt_18.32.bb')
-rw-r--r--meta-oe/recipes-devtools/dt/dt_18.32.bb49
1 files changed, 0 insertions, 49 deletions
diff --git a/meta-oe/recipes-devtools/dt/dt_18.32.bb b/meta-oe/recipes-devtools/dt/dt_18.32.bb
deleted file mode 100644
index 0234f765a..000000000
--- a/meta-oe/recipes-devtools/dt/dt_18.32.bb
+++ /dev/null
@@ -1,49 +0,0 @@
1SUMMARY = "Generic data test program"
2DESCRIPTION = "The Data Test Program (dt) is a generic data test program used to verify proper \
3operation of peripherals, file systems, device drivers, or any data stream supported by the \
4operating system."
5HOMEPAGE = "http://www.scsifaq.org/RMiller_Tools/dt.html"
6
7SECTION = "console/tests"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=be8bb25bbcfaa0725710d188e5152668"
11
12# Source URI taken from Fedora RPM spec file at:
13# http://pkgs.fedoraproject.org/git/rpms/dt.git
14SRC_URI = "http://dl.dropboxusercontent.com/u/32363629/Datatest/dt-source-v${PV}.tar.gz \
15 file://dt-default-source-define.patch \
16 file://dt-wformat-security.patch \
17 file://Stop-using-relative-path-for-scsilib.c-link.patch \
18 file://Use-tcsh-shell.patch \
19"
20
21SRC_URI[md5sum] = "3054aeaaba047a1dbe90c2132a382ee2"
22SRC_URI[sha256sum] = "10d164676e918a4d07f233bcd11e4cb6bfd1052c996182cd1827ccd0c063fcc6"
23
24S = "${WORKDIR}/dt.v${PV}"
25
26TARGET_CC_ARCH += "${LDFLAGS}"
27
28EXTRA_OEMAKE += "-f Makefile.linux \
29 OS=linux \
30 CFLAGS="-I.. -DAIO -DFIFO -DMMAP -D__linux__ -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -DTHREADS -DSCSI""
31
32do_compile() {
33 oe_runmake
34}
35
36do_install() {
37 install -Dm755 dt ${D}${sbindir}/dt
38 install -Dm644 Documentation/dt.man ${D}${mandir}/man8/dt.8
39
40 install -d ${D}${datadir}/dt/
41 install -d ${D}${docdir}/dt/html/
42 install -m755 Scripts/dt? ${D}${datadir}/dt/
43 install -m644 data/pattern_* ${D}${datadir}/dt/
44 install -m644 html/* ${D}${docdir}/dt/html/
45}
46
47RDEPENDS_${PN} += "tcsh"
48
49PNBLACKLIST[dt] ?= "Rdepends on blacklisted tcsh - the recipe will be removed on 2017-09-01 unless the issue is fixed"