summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cloc/cloc_1.90.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/cloc/cloc_1.90.bb')
-rw-r--r--meta-oe/recipes-devtools/cloc/cloc_1.90.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/cloc/cloc_1.90.bb b/meta-oe/recipes-devtools/cloc/cloc_1.90.bb
new file mode 100644
index 000000000..d34f8c98d
--- /dev/null
+++ b/meta-oe/recipes-devtools/cloc/cloc_1.90.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Count blank lines, comment lines, and physical lines of source code \
2in many programming languages."
3AUTHOR = "Al Danial"
4
5LICENSE="GPL-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=2c1c00f9d3ed9e24fa69b932b7e7aff2"
7
8SRC_URI = "https://github.com/AlDanial/cloc/releases/download/v${PV}/${BP}.tar.gz"
9SRC_URI[md5sum] = "e2364c2c9c9eda1d20890c19911c51fb"
10SRC_URI[sha256sum] = "152502a61d4bae4a406a05a01bf52489b310ec03dbd8c645d0bb051fa4717ddb"
11
12UPSTREAM_CHECK_URI = "https://github.com/AlDanial/${BPN}/releases"
13
14do_configure[noexec] = "1"
15do_compile[noexec] = "1"
16
17do_install() {
18 install -D -m 0755 ${S}/cloc ${D}${bindir}/cloc
19}
20
21RDEPENDS_${PN} = "perl perl-modules"