diff options
Diffstat (limited to 'meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240722.0.bb')
-rw-r--r-- | meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240722.0.bb | 54 |
1 files changed, 54 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240722.0.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240722.0.bb new file mode 100644 index 000000000..d9634b2b0 --- /dev/null +++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_20240722.0.bb | |||
@@ -0,0 +1,54 @@ | |||
1 | SUMMARY = "Abseil is a cpp library like STL" | ||
2 | DESCRIPTION = "Abseil provides pieces missing from the C++ standard. Contains \ | ||
3 | additional useful libraries like algorithm, container, debugging, hash, memory, \ | ||
4 | meta, numeric, strings, synchronization, time, types and utility." | ||
5 | HOMEPAGE = "https://abseil.io/" | ||
6 | SECTION = "libs" | ||
7 | LICENSE = "Apache-2.0" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=df52c6edb7adc22e533b2bacc3bd3915" | ||
9 | |||
10 | SRCREV = "4447c7562e3bc702ade25105912dce503f0c4010" | ||
11 | BRANCH = "lts_2024_07_22" | ||
12 | SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \ | ||
13 | file://0001-absl-always-use-asm-sgidefs.h.patch \ | ||
14 | file://0002-Remove-maes-option-from-cross-compilation.patch \ | ||
15 | file://0003-Remove-neon-option-from-cross-compilation.patch \ | ||
16 | file://0004-abseil-ppc-fixes.patch \ | ||
17 | file://0005-Don-t-match-Wnon-virtual-dtor-in-the-flags-are-neede.patch \ | ||
18 | " | ||
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | |||
22 | inherit cmake | ||
23 | |||
24 | EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \ | ||
25 | -DBUILD_TESTING=OFF \ | ||
26 | -DABSL_ENABLE_INSTALL=ON \ | ||
27 | " | ||
28 | |||
29 | SYSROOT_DIRS:append:class-nativesdk:mingw32 = " ${bindir}" | ||
30 | |||
31 | PACKAGES_DYNAMIC = "^libabsl-*" | ||
32 | PACKAGES_DYNAMIC:class-native = "" | ||
33 | |||
34 | PACKAGESPLITFUNCS =+ "split_dynamic_packages" | ||
35 | |||
36 | python split_dynamic_packages() { | ||
37 | libdir = d.getVar('libdir') | ||
38 | |||
39 | libpackages = do_split_packages( | ||
40 | d, | ||
41 | root=libdir, | ||
42 | file_regex=r'^libabsl_(.*)\.so\..*$', | ||
43 | output_pattern='libabsl-%s', | ||
44 | description="abseil shared library %s", | ||
45 | prepend=True, | ||
46 | extra_depends='', | ||
47 | ) | ||
48 | if libpackages: | ||
49 | d.appendVar('RDEPENDS:' + d.getVar('PN'), ' ' + ' '.join(libpackages)) | ||
50 | } | ||
51 | |||
52 | ALLOW_EMPTY:${PN} = "1" | ||
53 | |||
54 | BBCLASSEXTEND = "native nativesdk" | ||