summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-dbs')
-rw-r--r--meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb4
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb-native_10.11.9.bb (renamed from meta-oe/recipes-dbs/mysql/mariadb-native_10.11.7.bb)0
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb.inc14
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/0001-MDEV-33439-Fix-build-with-libxml2-2.12.patch170
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/0001-Remove-the-compile_time_assert-lines.patch43
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb/0001-Use-a-lambda-function-as-deleter-prototype-in-unique.patch26
-rw-r--r--meta-oe/recipes-dbs/mysql/mariadb_10.11.9.bb (renamed from meta-oe/recipes-dbs/mysql/mariadb_10.11.7.bb)0
-rw-r--r--meta-oe/recipes-dbs/postgresql/files/0003-configure.ac-bypass-autoconf-2.69-version-check.patch6
-rw-r--r--meta-oe/recipes-dbs/postgresql/postgresql.inc13
-rw-r--r--meta-oe/recipes-dbs/postgresql/postgresql_16.4.bb (renamed from meta-oe/recipes-dbs/postgresql/postgresql_16.3.bb)2
-rw-r--r--meta-oe/recipes-dbs/rocksdb/files/0001-CMakeLists.txt-Make-the-test-discovery-occur-on-targ.patch42
-rw-r--r--meta-oe/recipes-dbs/rocksdb/files/run-ptest12
-rw-r--r--meta-oe/recipes-dbs/rocksdb/files/static_library_as_option.patch71
-rw-r--r--meta-oe/recipes-dbs/rocksdb/rocksdb_9.0.0.bb23
14 files changed, 197 insertions, 229 deletions
diff --git a/meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb b/meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb
index 9506d0e55..cc8161cc3 100644
--- a/meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb
+++ b/meta-oe/recipes-dbs/influxdb/influxdb_1.8.10.bb
@@ -38,7 +38,7 @@ USERADD_PACKAGES = "${PN}"
38USERADD_PARAM:${PN} = "--system -d /var/lib/influxdb -m -s /bin/nologin influxdb" 38USERADD_PARAM:${PN} = "--system -d /var/lib/influxdb -m -s /bin/nologin influxdb"
39 39
40do_install:prepend() { 40do_install:prepend() {
41 test -e ${B}/src/${GO_IMPORT}/build.py && rm ${B}/src/${GO_IMPORT}/build.py 41 test -e ${B}/src/${GO_IMPORT}/build.py && rm ${B}/src/${GO_IMPORT}/build.py
42 test -e ${B}/src/${GO_IMPORT}/build.sh && rm ${B}/src/${GO_IMPORT}/build.sh 42 test -e ${B}/src/${GO_IMPORT}/build.sh && rm ${B}/src/${GO_IMPORT}/build.sh
43 rm -rf ${B}/src/${GO_IMPORT}/Dockerfile* 43 rm -rf ${B}/src/${GO_IMPORT}/Dockerfile*
44 44
@@ -75,3 +75,5 @@ INITSCRIPT_NAME = "influxdb"
75INITSCRIPT_PARAMS = "defaults" 75INITSCRIPT_PARAMS = "defaults"
76 76
77SYSTEMD_SERVICE:${PN} = "influxdb.service" 77SYSTEMD_SERVICE:${PN} = "influxdb.service"
78
79CVE_STATUS[CVE-2019-10329] = "cpe-incorrect: Version does not match and only the Jenkins plugin is affected."
diff --git a/meta-oe/recipes-dbs/mysql/mariadb-native_10.11.7.bb b/meta-oe/recipes-dbs/mysql/mariadb-native_10.11.9.bb
index 578357b48..578357b48 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb-native_10.11.7.bb
+++ b/meta-oe/recipes-dbs/mysql/mariadb-native_10.11.9.bb
diff --git a/meta-oe/recipes-dbs/mysql/mariadb.inc b/meta-oe/recipes-dbs/mysql/mariadb.inc
index 4bfa1c9ca..39c9f4c9d 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb.inc
+++ b/meta-oe/recipes-dbs/mysql/mariadb.inc
@@ -23,20 +23,21 @@ SRC_URI = "https://archive.mariadb.org/${BP}/source/${BP}.tar.gz \
23 file://0001-sql-CMakeLists.txt-fix-gen_lex_hash-not-found.patch \ 23 file://0001-sql-CMakeLists.txt-fix-gen_lex_hash-not-found.patch \
24 file://lfs64.patch \ 24 file://lfs64.patch \
25 file://0001-Add-missing-includes-cstdint-and-cstdio.patch \ 25 file://0001-Add-missing-includes-cstdint-and-cstdio.patch \
26 file://0001-Remove-the-compile_time_assert-lines.patch \ 26 file://0001-Use-a-lambda-function-as-deleter-prototype-in-unique.patch \
27 file://0001-MDEV-33439-Fix-build-with-libxml2-2.12.patch \
28 " 27 "
29SRC_URI:append:libc-musl = " file://ppc-remove-glibc-dep.patch" 28SRC_URI:append:libc-musl = " file://ppc-remove-glibc-dep.patch"
30SRC_URI[sha256sum] = "5239a245ed90517e96396605cd01ccd8f73cd7442d1b3076b6ffe258110e5157" 29SRC_URI[sha256sum] = "0a00180864cd016187c986faab8010de23a117b9a75f91d6456421f894e48d20"
31 30
32UPSTREAM_CHECK_URI = "https://github.com/MariaDB/server/releases" 31UPSTREAM_CHECK_URI = "https://github.com/MariaDB/server/tags"
33 32
34BINCONFIG_GLOB = "mysql_config" 33BINCONFIG_GLOB = "mysql_config"
35 34
36inherit cmake gettext binconfig update-rc.d systemd multilib_script pkgconfig 35inherit cmake gettext binconfig update-rc.d systemd multilib_script multilib_header pkgconfig
37 36
38MULTILIB_SCRIPTS = "${PN}-server:${bindir}/mariadbd-safe \ 37MULTILIB_SCRIPTS = "${PN}-server:${bindir}/mariadbd-safe \
39 ${PN}-setupdb:${bindir}/mariadb-install-db" 38 ${PN}-setupdb:${bindir}/mariadb-install-db \
39 libmysqlclient-dev:${bindir}/mysql_config \
40 "
40 41
41INITSCRIPT_PACKAGES = "${PN}-server ${PN}-setupdb" 42INITSCRIPT_PACKAGES = "${PN}-server ${PN}-setupdb"
42INITSCRIPT_NAME:${PN}-server = "mysqld" 43INITSCRIPT_NAME:${PN}-server = "mysqld"
@@ -160,6 +161,7 @@ mariadb_sysroot_preprocess () {
160 161
161do_install() { 162do_install() {
162 oe_runmake 'DESTDIR=${D}' install 163 oe_runmake 'DESTDIR=${D}' install
164 oe_multilib_header mysql/mariadb_version.h mysql/server/my_config.h mysql/server/private/config.h
163 165
164 install -d ${D}/${sysconfdir}/init.d 166 install -d ${D}/${sysconfdir}/init.d
165 install -m 0644 ${UNPACKDIR}/my.cnf ${D}/${sysconfdir}/ 167 install -m 0644 ${UNPACKDIR}/my.cnf ${D}/${sysconfdir}/
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/0001-MDEV-33439-Fix-build-with-libxml2-2.12.patch b/meta-oe/recipes-dbs/mysql/mariadb/0001-MDEV-33439-Fix-build-with-libxml2-2.12.patch
deleted file mode 100644
index 3e42535da..000000000
--- a/meta-oe/recipes-dbs/mysql/mariadb/0001-MDEV-33439-Fix-build-with-libxml2-2.12.patch
+++ /dev/null
@@ -1,170 +0,0 @@
1From dae52f5916ef59434c93f0b716270f59dd0c3a94 Mon Sep 17 00:00:00 2001
2From: Jan Tojnar <jtojnar@gmail.com>
3Date: Sun, 7 Jan 2024 10:19:54 +0100
4Subject: [PATCH] MDEV-33439 Fix build with libxml2 2.12
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9libxml2 2.12.0 made `xmlGetLastError()` return `const` pointer:
10
11https://gitlab.gnome.org/GNOME/libxml2/-/commit/61034116d0a3c8b295c6137956adc3ae55720711
12
13Clang 16 does not like this:
14
15 error: assigning to 'xmlErrorPtr' (aka '_xmlError *') from 'const xmlError *' (aka 'const _xmlError *') discards qualifiers
16 error: cannot initialize a variable of type 'xmlErrorPtr' (aka '_xmlError *') with an rvalue of type 'const xmlError *' (aka 'const _xmlError *')
17
18Let’s update the variables to `const`.
19For older versions, it will be automatically converted.
20
21But then `xmlResetError(xmlError*)` will not like the `const` pointer:
22
23 error: no matching function for call to 'xmlResetError'
24 note: candidate function not viable: 1st argument ('const xmlError *' (aka 'const _xmlError *')) would lose const qualifier
25
26Let’s replace it with `xmlResetLastError()`.
27
28ALso remove `LIBXMLDOC::Xerr` protected member property.
29It was introduced in 65b0e5455b547a3d574fa77b34cce23ae3bea0a0
30along with the `xmlResetError` calls.
31It does not appear to be used for anything.
32
33Upstream-Status: Backport [https://github.com/MariaDB/server/pull/2983]
34Signed-off-by: Khem Raj <raj.khem@gmail.com>
35---
36 storage/connect/libdoc.cpp | 39 +++++++++++++++++++-------------------
37 1 file changed, 19 insertions(+), 20 deletions(-)
38
39diff --git a/storage/connect/libdoc.cpp b/storage/connect/libdoc.cpp
40index 67f22ce2..ab588dd4 100644
41--- a/storage/connect/libdoc.cpp
42+++ b/storage/connect/libdoc.cpp
43@@ -93,7 +93,6 @@ class LIBXMLDOC : public XMLDOCUMENT {
44 xmlXPathContextPtr Ctxp;
45 xmlXPathObjectPtr Xop;
46 xmlXPathObjectPtr NlXop;
47- xmlErrorPtr Xerr;
48 char *Buf; // Temporary
49 bool Nofreelist;
50 }; // end of class LIBXMLDOC
51@@ -327,7 +326,6 @@ LIBXMLDOC::LIBXMLDOC(char *nsl, char *nsdf, char *enc, PFBLOCK fp)
52 Ctxp = NULL;
53 Xop = NULL;
54 NlXop = NULL;
55- Xerr = NULL;
56 Buf = NULL;
57 Nofreelist = false;
58 } // end of LIBXMLDOC constructor
59@@ -365,8 +363,8 @@ bool LIBXMLDOC::ParseFile(PGLOBAL g, char *fn)
60 Encoding = (char*)Docp->encoding;
61
62 return false;
63- } else if ((Xerr = xmlGetLastError()))
64- xmlResetError(Xerr);
65+ } else if (xmlGetLastError())
66+ xmlResetLastError();
67
68 return true;
69 } // end of ParseFile
70@@ -505,9 +503,9 @@ int LIBXMLDOC::DumpDoc(PGLOBAL g, char *ofn)
71 #if 1
72 // This function does not crash (
73 if (xmlSaveFormatFileEnc((const char *)ofn, Docp, Encoding, 0) < 0) {
74- xmlErrorPtr err = xmlGetLastError();
75+ const xmlError *err = xmlGetLastError();
76 strcpy(g->Message, (err) ? err->message : "Error saving XML doc");
77- xmlResetError(Xerr);
78+ xmlResetLastError();
79 rc = -1;
80 } // endif Save
81 // rc = xmlDocDump(of, Docp);
82@@ -546,8 +544,8 @@ void LIBXMLDOC::CloseDoc(PGLOBAL g, PFBLOCK xp)
83 if (Nlist) {
84 xmlXPathFreeNodeSet(Nlist);
85
86- if ((Xerr = xmlGetLastError()))
87- xmlResetError(Xerr);
88+ if (xmlGetLastError())
89+ xmlResetLastError();
90
91 Nlist = NULL;
92 } // endif Nlist
93@@ -555,8 +553,8 @@ void LIBXMLDOC::CloseDoc(PGLOBAL g, PFBLOCK xp)
94 if (Xop) {
95 xmlXPathFreeObject(Xop);
96
97- if ((Xerr = xmlGetLastError()))
98- xmlResetError(Xerr);
99+ if (xmlGetLastError())
100+ xmlResetLastError();
101
102 Xop = NULL;
103 } // endif Xop
104@@ -564,8 +562,8 @@ void LIBXMLDOC::CloseDoc(PGLOBAL g, PFBLOCK xp)
105 if (NlXop) {
106 xmlXPathFreeObject(NlXop);
107
108- if ((Xerr = xmlGetLastError()))
109- xmlResetError(Xerr);
110+ if (xmlGetLastError())
111+ xmlResetLastError();
112
113 NlXop = NULL;
114 } // endif NlXop
115@@ -573,8 +571,8 @@ void LIBXMLDOC::CloseDoc(PGLOBAL g, PFBLOCK xp)
116 if (Ctxp) {
117 xmlXPathFreeContext(Ctxp);
118
119- if ((Xerr = xmlGetLastError()))
120- xmlResetError(Xerr);
121+ if (xmlGetLastError())
122+ xmlResetLastError();
123
124 Ctxp = NULL;
125 } // endif Ctxp
126@@ -590,6 +588,7 @@ void LIBXMLDOC::CloseDoc(PGLOBAL g, PFBLOCK xp)
127 /******************************************************************/
128 xmlNodeSetPtr LIBXMLDOC::GetNodeList(PGLOBAL g, xmlNodePtr np, char *xp)
129 {
130+ const xmlError *xerr;
131 xmlNodeSetPtr nl;
132
133 if (trace(1))
134@@ -649,11 +648,11 @@ xmlNodeSetPtr LIBXMLDOC::GetNodeList(PGLOBAL g, xmlNodePtr np, char *xp)
135 } else
136 xmlXPathFreeObject(Xop); // Caused node not found
137
138- if ((Xerr = xmlGetLastError())) {
139- strcpy(g->Message, Xerr->message);
140- xmlResetError(Xerr);
141+ if ((xerr = xmlGetLastError())) {
142+ strcpy(g->Message, xerr->message);
143+ xmlResetLastError();
144 return NULL;
145- } // endif Xerr
146+ } // endif xerr
147
148 } // endif Xop
149
150@@ -1079,7 +1078,7 @@ void XML2NODE::AddText(PGLOBAL g, PCSZ txtp)
151 /******************************************************************/
152 void XML2NODE::DeleteChild(PGLOBAL g, PXNODE dnp)
153 {
154- xmlErrorPtr xerr;
155+ const xmlError *xerr;
156
157 if (trace(1))
158 htrc("DeleteChild: node=%p\n", dnp);
159@@ -1122,7 +1121,7 @@ void XML2NODE::DeleteChild(PGLOBAL g, PXNODE dnp)
160 if (trace(1))
161 htrc("DeleteChild: errmsg=%-.256s\n", xerr->message);
162
163- xmlResetError(xerr);
164+ xmlResetLastError();
165 } // end of DeleteChild
166
167 /* -------------------- class XML2NODELIST ---------------------- */
168--
1692.44.0
170
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/0001-Remove-the-compile_time_assert-lines.patch b/meta-oe/recipes-dbs/mysql/mariadb/0001-Remove-the-compile_time_assert-lines.patch
deleted file mode 100644
index 9a6e28297..000000000
--- a/meta-oe/recipes-dbs/mysql/mariadb/0001-Remove-the-compile_time_assert-lines.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From cc5f1d0759b367265a1a000287e2ec15c31eb518 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Mon, 26 Feb 2024 14:56:02 +0800
4Subject: [PATCH] Remove the compile_time_assert lines
5
6Remove the problematic compile_time_assert lines to fix the below build
7failure on 32-bit arm.
8 In file included from TOPDIR/build/tmp/work/cortexa15t2hf-neon-yoe-linux-gnueabi/mariadb/10.11.7/mariadb-10.11.7/tests/mysql_client_test.c:38:
9 TOPDIR/build/tmp/work/cortexa15t2hf-neon-yoe-linux-gnueabi/mariadb/10.11.7/mariadb-10.11.7/tests/mysql_client_fw.c:1438:3: error: 'compile_time_assert' declared as an array with a negative size
10 1438 | compile_time_assert(sizeof(MYSQL) == 77*sizeof(void*)+656);
11 | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
12
13Upstream-Status: Inappropriate [Upstream will bring the asset back
14 in a new way [1]]
15[1] https://jira.mariadb.org/browse/MDEV-33429
16
17Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
18---
19 tests/mysql_client_fw.c | 8 --------
20 1 file changed, 8 deletions(-)
21
22diff --git a/tests/mysql_client_fw.c b/tests/mysql_client_fw.c
23index c9e64678..5c0c7ce2 100644
24--- a/tests/mysql_client_fw.c
25+++ b/tests/mysql_client_fw.c
26@@ -1430,14 +1430,6 @@ int main(int argc, char **argv)
27 tests_to_run[i]= NULL;
28 }
29
30-#ifdef _WIN32
31- /* must be the same in C/C and embedded, 1208 on 64bit, 968 on 32bit */
32- compile_time_assert(sizeof(MYSQL) == 60*sizeof(void*)+728);
33-#else
34- /* must be the same in C/C and embedded, 1272 on 64bit, 964 on 32bit */
35- compile_time_assert(sizeof(MYSQL) == 77*sizeof(void*)+656);
36-#endif
37-
38 if (mysql_server_init(embedded_server_arg_count,
39 embedded_server_args,
40 (char**) embedded_server_groups))
41--
422.25.1
43
diff --git a/meta-oe/recipes-dbs/mysql/mariadb/0001-Use-a-lambda-function-as-deleter-prototype-in-unique.patch b/meta-oe/recipes-dbs/mysql/mariadb/0001-Use-a-lambda-function-as-deleter-prototype-in-unique.patch
new file mode 100644
index 000000000..416b17ba2
--- /dev/null
+++ b/meta-oe/recipes-dbs/mysql/mariadb/0001-Use-a-lambda-function-as-deleter-prototype-in-unique.patch
@@ -0,0 +1,26 @@
1From 713c21880e25108bf0703433432acca58377cc7b Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 27 Sep 2024 11:55:53 -0700
4Subject: [PATCH] Use a lambda function as deleter prototype in unique_ptr
5
6Fixes build with clang/libc++ 20+
7
8Upstream-Status: Submitted [https://jira.mariadb.org/browse/MDEV-35040]
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 extra/mariabackup/backup_copy.cc | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/extra/mariabackup/backup_copy.cc b/extra/mariabackup/backup_copy.cc
15index a328f5e0ec7..2ab04b78bce 100644
16--- a/extra/mariabackup/backup_copy.cc
17+++ b/extra/mariabackup/backup_copy.cc
18@@ -1641,7 +1641,7 @@ is_aria_log_dir_file(const datadir_node_t &node)
19 bool
20 copy_back_aria_logs(const char *dstdir)
21 {
22- std::unique_ptr<ds_ctxt_t, void (&)(ds_ctxt_t*)>
23+ std::unique_ptr<ds_ctxt_t, std::function<void(ds_ctxt_t*)>>
24 ds_ctxt_aria_log_dir_path(ds_create(dstdir, DS_TYPE_LOCAL), ds_destroy);
25
26 datadir_node_t node;
diff --git a/meta-oe/recipes-dbs/mysql/mariadb_10.11.7.bb b/meta-oe/recipes-dbs/mysql/mariadb_10.11.9.bb
index b1d1355e2..b1d1355e2 100644
--- a/meta-oe/recipes-dbs/mysql/mariadb_10.11.7.bb
+++ b/meta-oe/recipes-dbs/mysql/mariadb_10.11.9.bb
diff --git a/meta-oe/recipes-dbs/postgresql/files/0003-configure.ac-bypass-autoconf-2.69-version-check.patch b/meta-oe/recipes-dbs/postgresql/files/0003-configure.ac-bypass-autoconf-2.69-version-check.patch
index 9df4d073f..342aeba85 100644
--- a/meta-oe/recipes-dbs/postgresql/files/0003-configure.ac-bypass-autoconf-2.69-version-check.patch
+++ b/meta-oe/recipes-dbs/postgresql/files/0003-configure.ac-bypass-autoconf-2.69-version-check.patch
@@ -13,12 +13,12 @@ Signed-off-by: Yi Fan Yu <yifan.yu@windriver.com>
13 1 file changed, 4 deletions(-) 13 1 file changed, 4 deletions(-)
14 14
15diff --git a/configure.ac b/configure.ac 15diff --git a/configure.ac b/configure.ac
16index 401ce30..27f382d 100644 16index 65715a4..4ad6340 100644
17--- a/configure.ac 17--- a/configure.ac
18+++ b/configure.ac 18+++ b/configure.ac
19@@ -19,10 +19,6 @@ m4_pattern_forbid(^PGAC_)dnl to catch undefined macros 19@@ -19,10 +19,6 @@ m4_pattern_forbid(^PGAC_)dnl to catch undefined macros
20 20
21 AC_INIT([PostgreSQL], [16.3], [pgsql-bugs@lists.postgresql.org], [], [https://www.postgresql.org/]) 21 AC_INIT([PostgreSQL], [16.4], [pgsql-bugs@lists.postgresql.org], [], [https://www.postgresql.org/])
22 22
23-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.69], [], [m4_fatal([Autoconf version 2.69 is required. 23-m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.69], [], [m4_fatal([Autoconf version 2.69 is required.
24-Untested combinations of 'autoconf' and PostgreSQL versions are not 24-Untested combinations of 'autoconf' and PostgreSQL versions are not
@@ -28,5 +28,5 @@ index 401ce30..27f382d 100644
28 AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c]) 28 AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
29 AC_CONFIG_AUX_DIR(config) 29 AC_CONFIG_AUX_DIR(config)
30-- 30--
312.25.1 312.34.1
32 32
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql.inc b/meta-oe/recipes-dbs/postgresql/postgresql.inc
index 2dd7dd6fd..4fc2e47b3 100644
--- a/meta-oe/recipes-dbs/postgresql/postgresql.inc
+++ b/meta-oe/recipes-dbs/postgresql/postgresql.inc
@@ -19,7 +19,7 @@ DESCRIPTION = "\
19" 19"
20HOMEPAGE = "http://www.postgresql.com" 20HOMEPAGE = "http://www.postgresql.com"
21LICENSE = "0BSD" 21LICENSE = "0BSD"
22DEPENDS = "libnsl2 readline tzcode-native" 22DEPENDS = "libnsl2 tzcode-native perl"
23 23
24ARM_INSTRUCTION_SET = "arm" 24ARM_INSTRUCTION_SET = "arm"
25 25
@@ -37,7 +37,7 @@ LEAD_SONAME = "libpq.so"
37export LDFLAGS_SL = "${LDFLAGS}" 37export LDFLAGS_SL = "${LDFLAGS}"
38export LDFLAGS_EX_BE = "-Wl,--export-dynamic" 38export LDFLAGS_EX_BE = "-Wl,--export-dynamic"
39 39
40inherit autotools pkgconfig perlnative python3native python3targetconfig useradd update-rc.d systemd gettext cpan-base multilib_header 40inherit autotools pkgconfig perlnative python3native python3targetconfig useradd update-rc.d systemd gettext perl-version multilib_header
41 41
42CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR} -I${STAGING_INCDIR}/tcl8.6" 42CFLAGS += "-I${STAGING_INCDIR}/${PYTHON_DIR} -I${STAGING_INCDIR}/tcl8.6"
43 43
@@ -55,7 +55,7 @@ pkg_postinst:${PN} () {
55 55
56PACKAGECONFIG ??= " \ 56PACKAGECONFIG ??= " \
57 ${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd', d)} \ 57 ${@bb.utils.filter('DISTRO_FEATURES', 'pam systemd', d)} \
58 openssl python uuid libxml tcl perl zlib icu \ 58 openssl python uuid libxml tcl perl zlib icu readline \
59" 59"
60PACKAGECONFIG[tcl] = "--with-tcl --with-tclconfig=${STAGING_BINDIR_CROSS},--without-tcl,tcl tcl-native," 60PACKAGECONFIG[tcl] = "--with-tcl --with-tclconfig=${STAGING_BINDIR_CROSS},--without-tcl,tcl tcl-native,"
61PACKAGECONFIG[perl] = "--with-perl,--without-perl,perl,perl" 61PACKAGECONFIG[perl] = "--with-perl,--without-perl,perl,perl"
@@ -71,6 +71,7 @@ PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
71PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4" 71PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4"
72PACKAGECONFIG[openssl] = "--with-ssl=openssl,ac_cv_file__dev_urandom=yes,openssl" 72PACKAGECONFIG[openssl] = "--with-ssl=openssl,ac_cv_file__dev_urandom=yes,openssl"
73PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu,icu" 73PACKAGECONFIG[icu] = "--with-icu,--without-icu,icu,icu"
74PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
74 75
75EXTRA_OECONF += "--enable-thread-safety --disable-rpath \ 76EXTRA_OECONF += "--enable-thread-safety --disable-rpath \
76 --datadir=${datadir}/${BPN} \ 77 --datadir=${datadir}/${BPN} \
@@ -122,6 +123,12 @@ python populate_packages:prepend() {
122 123
123} 124}
124 125
126# Same as the function in cpan-base.bbclass (but without the perl RDEPENDS)
127def is_target(d):
128 if not bb.data.inherits_class('native', d):
129 return "yes"
130 return "no"
131
125# This will make native perl use target settings (for include dirs etc.) 132# This will make native perl use target settings (for include dirs etc.)
126export PERLCONFIGTARGET = "${@is_target(d)}" 133export PERLCONFIGTARGET = "${@is_target(d)}"
127export PERL_ARCHLIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl5/${@get_perl_version(d)}/${@get_perl_arch(d)}" 134export PERL_ARCHLIB = "${STAGING_LIBDIR}${PERL_OWN_DIR}/perl5/${@get_perl_version(d)}/${@get_perl_arch(d)}"
diff --git a/meta-oe/recipes-dbs/postgresql/postgresql_16.3.bb b/meta-oe/recipes-dbs/postgresql/postgresql_16.4.bb
index 6df719cd9..1a47369e4 100644
--- a/meta-oe/recipes-dbs/postgresql/postgresql_16.3.bb
+++ b/meta-oe/recipes-dbs/postgresql/postgresql_16.4.bb
@@ -11,6 +11,6 @@ SRC_URI += "\
11 file://0005-postgresql-fix-ptest-failure-of-sysviews.patch \ 11 file://0005-postgresql-fix-ptest-failure-of-sysviews.patch \
12" 12"
13 13
14SRC_URI[sha256sum] = "331963d5d3dc4caf4216a049fa40b66d6bcb8c730615859411b9518764e60585" 14SRC_URI[sha256sum] = "971766d645aa73e93b9ef4e3be44201b4f45b5477095b049125403f9f3386d6f"
15 15
16CVE_STATUS[CVE-2017-8806] = "not-applicable-config: Ddoesn't apply to out configuration of postgresql so we can safely ignore it." 16CVE_STATUS[CVE-2017-8806] = "not-applicable-config: Ddoesn't apply to out configuration of postgresql so we can safely ignore it."
diff --git a/meta-oe/recipes-dbs/rocksdb/files/0001-CMakeLists.txt-Make-the-test-discovery-occur-on-targ.patch b/meta-oe/recipes-dbs/rocksdb/files/0001-CMakeLists.txt-Make-the-test-discovery-occur-on-targ.patch
new file mode 100644
index 000000000..b0a949fe3
--- /dev/null
+++ b/meta-oe/recipes-dbs/rocksdb/files/0001-CMakeLists.txt-Make-the-test-discovery-occur-on-targ.patch
@@ -0,0 +1,42 @@
1From 9abf6cd09c60f0be9a85c055dfdf43698f057f73 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Wed, 25 Sep 2024 13:47:37 +0800
4Subject: [PATCH] CMakeLists.txt: Make the test discovery occur on target
5
6Set DISCOVERY_MODE to PRE_TEST to delay test discovery until just
7prior to test execution on the target to fix the build failure as
8the default POST_BUILD behavior is not desirable in cross-compiling
9env.
10
11/build/tmp/work/core2-64-wrs-linux/rocksdb/9.0.0/build/env_basic_test: error while loading shared libraries: libgflags.so.2.2: cannot open shared object file: No such file or directory
12CMake Error at /build/tmp/work/core2-64-wrs-linux/rocksdb/9.0.0/recipe-sysroot-native/usr/share/cmake-3.30/Modules/GoogleTestAddTests.cmake:112 (message):
13 Error running test executable.
14
15 Path: '/build/tmp/work/core2-64-wrs-linux/rocksdb/9.0.0/build/env_basic_test'
16 Working directory: '/build/tmp/work/core2-64-wrs-linux/rocksdb/9.0.0/build'
17 Result: 127
18 Output:
19
20Upstream-Status: Inappropriate [oe specific]
21
22Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
23---
24 CMakeLists.txt | 2 +-
25 1 file changed, 1 insertion(+), 1 deletion(-)
26
27diff --git a/CMakeLists.txt b/CMakeLists.txt
28index 403ad1243..f34397798 100644
29--- a/CMakeLists.txt
30+++ b/CMakeLists.txt
31@@ -1502,7 +1502,7 @@ if(WITH_TESTS)
32 )
33 target_link_libraries(${exename}${ARTIFACT_SUFFIX} testutillib${ARTIFACT_SUFFIX} testharness gtest ${THIRDPARTY_LIBS} ${ROCKSDB_LIB})
34 if(NOT "${exename}" MATCHES "db_sanity_test")
35- gtest_discover_tests(${exename} DISCOVERY_TIMEOUT 120)
36+ gtest_discover_tests(${exename} DISCOVERY_TIMEOUT 120 DISCOVERY_MODE PRE_TEST)
37 add_dependencies(rocksdb_check ${exename}${ARTIFACT_SUFFIX})
38 endif()
39 endforeach(sourcefile ${TESTS})
40--
412.34.1
42
diff --git a/meta-oe/recipes-dbs/rocksdb/files/run-ptest b/meta-oe/recipes-dbs/rocksdb/files/run-ptest
new file mode 100644
index 000000000..45406fdfa
--- /dev/null
+++ b/meta-oe/recipes-dbs/rocksdb/files/run-ptest
@@ -0,0 +1,12 @@
1#!/bin/sh
2ptestdir=$(dirname "$(readlink -f "$0")")
3cd "$ptestdir"/tests || exit
4
5for test in *_test; do
6 if ./${test} >/dev/null 2>&1; then
7 echo "PASS: ${test}"
8 else
9 echo "FAIL: ${test}"
10 fi
11done
12
diff --git a/meta-oe/recipes-dbs/rocksdb/files/static_library_as_option.patch b/meta-oe/recipes-dbs/rocksdb/files/static_library_as_option.patch
new file mode 100644
index 000000000..9a85e8db4
--- /dev/null
+++ b/meta-oe/recipes-dbs/rocksdb/files/static_library_as_option.patch
@@ -0,0 +1,71 @@
1From 285d306494bde3e9c24c8cd6fea1eb380a304d03 Mon Sep 17 00:00:00 2001
2From: Bindu-Bhabu <bindudaniel1996@gmail.com>
3Date: Fri, 26 Jul 2024 15:14:45 +0530
4Subject: Add option to CMake for building static libraries
5
6ROCKSDB creates a STATIC library target reference by default.
7Modify the cmake so that the STATIC library is also an option
8just like creating a SHARED library and set default to ON.
9
10Upstream-Status: Submitted [https://github.com/facebook/rocksdb/pull/12890]
11
12Signed-off-by: Nisha Parrakat <nisha.m.parrakat@bmw.de>
13Signed-off-by: Bindu Bhabu <bhabu.bindu@kpit.com>
14---
15 CMakeLists.txt | 29 +++++++++++++++++------------
16 1 file changed, 17 insertions(+), 12 deletions(-)
17
18diff --git a/CMakeLists.txt b/CMakeLists.txt
19index 93b884dd9c1..2ca925d505c 100644
20--- a/CMakeLists.txt
21+++ b/CMakeLists.txt
22@@ -98,6 +98,7 @@ if (WITH_WINDOWS_UTF8_FILENAMES)
23 add_definitions(-DROCKSDB_WINDOWS_UTF8_FILENAMES)
24 endif()
25 option(ROCKSDB_BUILD_SHARED "Build shared versions of the RocksDB libraries" ON)
26+option(ROCKSDB_BUILD_STATIC "Build static versions of the RocksDB libraries" ON)
27
28 if( NOT DEFINED CMAKE_CXX_STANDARD )
29 set(CMAKE_CXX_STANDARD 17)
30@@ -1139,11 +1140,13 @@ string(REGEX REPLACE "[^0-9: /-]+" "" GIT_DATE "${GIT_DATE}")
31 set(BUILD_VERSION_CC ${CMAKE_BINARY_DIR}/build_version.cc)
32 configure_file(util/build_version.cc.in ${BUILD_VERSION_CC} @ONLY)
33
34-add_library(${ROCKSDB_STATIC_LIB} STATIC ${SOURCES} ${BUILD_VERSION_CC})
35-target_include_directories(${ROCKSDB_STATIC_LIB} PUBLIC
36- $<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}/include>)
37-target_link_libraries(${ROCKSDB_STATIC_LIB} PRIVATE
38- ${THIRDPARTY_LIBS} ${SYSTEM_LIBS})
39+if(ROCKSDB_BUILD_STATIC)
40+ add_library(${ROCKSDB_STATIC_LIB} STATIC ${SOURCES} ${BUILD_VERSION_CC})
41+ target_include_directories(${ROCKSDB_STATIC_LIB} PUBLIC
42+ $<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}/include>)
43+ target_link_libraries(${ROCKSDB_STATIC_LIB} PRIVATE
44+ ${THIRDPARTY_LIBS} ${SYSTEM_LIBS})
45+endif()
46
47 if(ROCKSDB_BUILD_SHARED)
48 add_library(${ROCKSDB_SHARED_LIB} SHARED ${SOURCES} ${BUILD_VERSION_CC})
49@@ -1238,13 +1241,15 @@ if(NOT WIN32 OR ROCKSDB_INSTALL_ON_WINDOWS)
50
51 install(DIRECTORY "${PROJECT_SOURCE_DIR}/cmake/modules" COMPONENT devel DESTINATION ${package_config_destination})
52
53- install(
54- TARGETS ${ROCKSDB_STATIC_LIB}
55- EXPORT RocksDBTargets
56- COMPONENT devel
57- ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}"
58- INCLUDES DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}"
59- )
60+ if(ROCKSDB_BUILD_STATIC)
61+ install(
62+ TARGETS ${ROCKSDB_STATIC_LIB}
63+ EXPORT RocksDBTargets
64+ COMPONENT devel
65+ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}"
66+ INCLUDES DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}"
67+ )
68+ endif()
69
70 if(ROCKSDB_BUILD_SHARED)
71 install(
diff --git a/meta-oe/recipes-dbs/rocksdb/rocksdb_9.0.0.bb b/meta-oe/recipes-dbs/rocksdb/rocksdb_9.0.0.bb
index 444351dbb..57d163bfc 100644
--- a/meta-oe/recipes-dbs/rocksdb/rocksdb_9.0.0.bb
+++ b/meta-oe/recipes-dbs/rocksdb/rocksdb_9.0.0.bb
@@ -17,6 +17,9 @@ SRC_URI = "git://github.com/facebook/${BPN}.git;branch=${SRCBRANCH};protocol=htt
17 file://0005-Implement-timer-implementation-for-mips-platform.patch \ 17 file://0005-Implement-timer-implementation-for-mips-platform.patch \
18 file://0006-Implement-timer-for-arm-v6.patch \ 18 file://0006-Implement-timer-for-arm-v6.patch \
19 file://0007-Fix-declaration-scope-of-LE_LOAD32-in-crc32c.patch \ 19 file://0007-Fix-declaration-scope-of-LE_LOAD32-in-crc32c.patch \
20 file://static_library_as_option.patch \
21 file://0001-CMakeLists.txt-Make-the-test-discovery-occur-on-targ.patch \
22 file://run-ptest \
20 " 23 "
21 24
22SRC_URI:append:riscv32 = " file://0001-replace-old-sync-with-new-atomic-builtin-equivalents.patch" 25SRC_URI:append:riscv32 = " file://0001-replace-old-sync-with-new-atomic-builtin-equivalents.patch"
@@ -26,7 +29,7 @@ SRC_URI:remove:toolchain-clang:riscv32 = "file://0001-replace-old-sync-with-new-
26 29
27S = "${WORKDIR}/git" 30S = "${WORKDIR}/git"
28 31
29inherit cmake 32inherit cmake ptest
30 33
31PACKAGECONFIG ??= "bzip2 zlib lz4 gflags" 34PACKAGECONFIG ??= "bzip2 zlib lz4 gflags"
32PACKAGECONFIG[bzip2] = "-DWITH_BZ2=ON,-DWITH_BZ2=OFF,bzip2" 35PACKAGECONFIG[bzip2] = "-DWITH_BZ2=ON,-DWITH_BZ2=OFF,bzip2"
@@ -39,10 +42,11 @@ PACKAGECONFIG[gflags] = "-DWITH_GFLAGS=ON,-DWITH_GFLAGS=OFF,gflags"
39# Tools and tests currently don't compile on armv5 so we disable them 42# Tools and tests currently don't compile on armv5 so we disable them
40EXTRA_OECMAKE = "\ 43EXTRA_OECMAKE = "\
41 -DPORTABLE=ON \ 44 -DPORTABLE=ON \
42 -DWITH_TESTS=OFF \ 45 -DWITH_TESTS=${@bb.utils.contains("DISTRO_FEATURES", "ptest", "ON", "OFF", d)} \
43 -DWITH_BENCHMARK_TOOLS=OFF \ 46 -DWITH_BENCHMARK_TOOLS=OFF \
44 -DWITH_TOOLS=OFF \ 47 -DWITH_TOOLS=OFF \
45 -DFAIL_ON_WARNINGS=OFF \ 48 -DFAIL_ON_WARNINGS=OFF \
49 -DROCKSDB_BUILD_STATIC=OFF \
46" 50"
47 51
48CXXFLAGS += "${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Og', '-DXXH_NO_INLINE_HINTS', '', d)}" 52CXXFLAGS += "${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Og', '-DXXH_NO_INLINE_HINTS', '', d)}"
@@ -52,6 +56,21 @@ do_install:append() {
52 sed -i "s#${RECIPE_SYSROOT}##g" ${D}${libdir}/cmake/rocksdb/RocksDBTargets.cmake 56 sed -i "s#${RECIPE_SYSROOT}##g" ${D}${libdir}/cmake/rocksdb/RocksDBTargets.cmake
53} 57}
54 58
59do_install_ptest() {
60 install -d ${D}${PTEST_PATH}/tests
61 # only cover the basic test as all the tests need to take about 6 hours
62 # time ./run-ptest
63 # real 356m32.956s
64 # user 252m32.004s
65 # sys 178m50.246s
66 install -m 0755 ${B}/env_basic_test ${D}${PTEST_PATH}/tests/
67 install -m 0755 ${B}/db_basic_test ${D}${PTEST_PATH}/tests/
68 install -m 0755 ${B}/agg_merge_test ${D}${PTEST_PATH}/tests/
69 install -m 0755 ${B}/testutil_test ${D}${PTEST_PATH}/tests/
70 install -m 0755 ${B}/cache_test ${D}${PTEST_PATH}/tests/
71}
72
55# Need toku_time_now() implemented for ppc/musl 73# Need toku_time_now() implemented for ppc/musl
56# see utilities/transactions/lock/range/range_tree/lib/portability/toku_time.h 74# see utilities/transactions/lock/range/range_tree/lib/portability/toku_time.h
57COMPATIBLE_HOST:libc-musl:powerpc = "null" 75COMPATIBLE_HOST:libc-musl:powerpc = "null"
76COMPATIBLE_HOST:armv5 = 'null'