diff options
Diffstat (limited to 'meta-oe/recipes-dbs/soci')
-rw-r--r-- | meta-oe/recipes-dbs/soci/soci/0001-Do-not-use-std-shuffle-with-clang-15.patch | 32 | ||||
-rw-r--r-- | meta-oe/recipes-dbs/soci/soci_4.0.3.bb | 4 |
2 files changed, 35 insertions, 1 deletions
diff --git a/meta-oe/recipes-dbs/soci/soci/0001-Do-not-use-std-shuffle-with-clang-15.patch b/meta-oe/recipes-dbs/soci/soci/0001-Do-not-use-std-shuffle-with-clang-15.patch new file mode 100644 index 0000000000..eb29627c6d --- /dev/null +++ b/meta-oe/recipes-dbs/soci/soci/0001-Do-not-use-std-shuffle-with-clang-15.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From e5f72c656829402c6f70e7416039bc18f0c26485 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 30 Aug 2022 22:17:14 -0700 | ||
4 | Subject: [PATCH] Do not use std::shuffle with clang 15 | ||
5 | |||
6 | This fails to compile although its preferred approach for c++11 and | ||
7 | newer | ||
8 | |||
9 | See | ||
10 | https://github.com/SOCI/soci/issues/984 | ||
11 | |||
12 | Upstream-Status: Inappropriate [Workaround] | ||
13 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
14 | --- | ||
15 | cmake/SociConfig.cmake | 1 + | ||
16 | 1 file changed, 1 insertion(+) | ||
17 | |||
18 | diff --git a/cmake/SociConfig.cmake b/cmake/SociConfig.cmake | ||
19 | index 492e1837..f24fd9a6 100644 | ||
20 | --- a/cmake/SociConfig.cmake | ||
21 | +++ b/cmake/SociConfig.cmake | ||
22 | @@ -94,6 +94,7 @@ else() | ||
23 | set(SOCI_CXX11 ON) | ||
24 | set(SOCI_CXX_VERSION_FLAGS "-std=c++11") | ||
25 | add_definitions(-DCATCH_CONFIG_CPP11_NO_IS_ENUM) | ||
26 | + add_definitions(-DCATCH_CONFIG_CPP11_NO_SHUFFLE) | ||
27 | |||
28 | set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${SOCI_GCC_CLANG_COMMON_FLAGS} ${SOCI_CXX_VERSION_FLAGS}") | ||
29 | |||
30 | -- | ||
31 | 2.37.3 | ||
32 | |||
diff --git a/meta-oe/recipes-dbs/soci/soci_4.0.3.bb b/meta-oe/recipes-dbs/soci/soci_4.0.3.bb index ff47e5033e..71ab80c48a 100644 --- a/meta-oe/recipes-dbs/soci/soci_4.0.3.bb +++ b/meta-oe/recipes-dbs/soci/soci_4.0.3.bb | |||
@@ -5,7 +5,9 @@ LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c" | |||
5 | SECTION = "libs" | 5 | SECTION = "libs" |
6 | DEPENDS = "boost" | 6 | DEPENDS = "boost" |
7 | 7 | ||
8 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BP}/${BP}.tar.gz" | 8 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BP}/${BP}.tar.gz \ |
9 | file://0001-Do-not-use-std-shuffle-with-clang-15.patch \ | ||
10 | " | ||
9 | SRC_URI[sha256sum] = "615e5f7e4b52007f3a3b4050a99aadf6346b56b5098eb08b3a650836083c6a33" | 11 | SRC_URI[sha256sum] = "615e5f7e4b52007f3a3b4050a99aadf6346b56b5098eb08b3a650836083c6a33" |
10 | 12 | ||
11 | TESTCONFIG = '-DSOCI_TEST_EMPTY_CONNSTR="dummy" -DSOCI_TEST_SQLITE3_CONNSTR="test.db" \ | 13 | TESTCONFIG = '-DSOCI_TEST_EMPTY_CONNSTR="dummy" -DSOCI_TEST_SQLITE3_CONNSTR="test.db" \ |