diff options
Diffstat (limited to 'meta-oe/recipes-core')
-rw-r--r-- | meta-oe/recipes-core/proxy-libintl/proxy-libintl-20100902/create-as-shared-lib.patch | 31 | ||||
-rw-r--r-- | meta-oe/recipes-core/proxy-libintl/proxy-libintl-20100902/stub-only.patch | 72 |
2 files changed, 0 insertions, 103 deletions
diff --git a/meta-oe/recipes-core/proxy-libintl/proxy-libintl-20100902/create-as-shared-lib.patch b/meta-oe/recipes-core/proxy-libintl/proxy-libintl-20100902/create-as-shared-lib.patch deleted file mode 100644 index 306e3b821..000000000 --- a/meta-oe/recipes-core/proxy-libintl/proxy-libintl-20100902/create-as-shared-lib.patch +++ /dev/null | |||
@@ -1,31 +0,0 @@ | |||
1 | --- a/src/proxy-libintl/Makefile.org 2009-09-12 23:19:04.989421607 -0700 | ||
2 | +++ a/src/proxy-libintl/Makefile 2009-09-12 23:21:14.100640001 -0700 | ||
3 | @@ -4,20 +4,20 @@ ZIPFILE = proxy-libintl-$(TIMESTAMP).zip | ||
4 | CC = gcc | ||
5 | CFLAGS = -Wall -I ../../include | ||
6 | |||
7 | -all : ../../lib/libintl.a ../../lib/intl.lib | ||
8 | +all : ../../lib/libintl.so ../../lib/intl.lib | ||
9 | |||
10 | -../../lib/libintl.a : libintl.o | ||
11 | - ar rc $@ libintl.o | ||
12 | +../../lib/libintl.so : libintl.o | ||
13 | + $(CC) -shared -o $@ libintl.o | ||
14 | |||
15 | -../../lib/intl.lib : ../../lib/libintl.a | ||
16 | - cp ../../lib/libintl.a $@ | ||
17 | - strip --strip-unneeded $@ | ||
18 | +../../lib/intl.lib : ../../lib/libintl.so | ||
19 | + cp ../../lib/libintl.so $@ | ||
20 | + $(STRIP) --strip-unneeded $@ | ||
21 | |||
22 | libintl.o : libintl.c | ||
23 | $(CC) $(CFLAGS) -c libintl.c | ||
24 | |||
25 | clean : | ||
26 | - rm -f *.o ../../lib/libintl.a ../../$(ZIPFILE) | ||
27 | + rm -f *.o ../../lib/libintl.so ../../$(ZIPFILE) | ||
28 | |||
29 | dist : clean all | ||
30 | - cd ../..; zip $(ZIPFILE) include/libintl.h lib/{libintl.a,intl.lib} src/proxy-libintl/{README.txt,COPYING.LIB.txt,Makefile,libintl.[ch]}; manifestify $(ZIPFILE) | ||
31 | + cd ../..; zip $(ZIPFILE) include/libintl.h lib/{libintl.so,intl.lib} src/proxy-libintl/{README.txt,COPYING.LIB.txt,Makefile,libintl.[ch]}; manifestify $(ZIPFILE) | ||
diff --git a/meta-oe/recipes-core/proxy-libintl/proxy-libintl-20100902/stub-only.patch b/meta-oe/recipes-core/proxy-libintl/proxy-libintl-20100902/stub-only.patch deleted file mode 100644 index 7186b13c0..000000000 --- a/meta-oe/recipes-core/proxy-libintl/proxy-libintl-20100902/stub-only.patch +++ /dev/null | |||
@@ -1,72 +0,0 @@ | |||
1 | Index: proxy-libintl/src/proxy-libintl/libintl.c | ||
2 | =================================================================== | ||
3 | --- proxy-libintl.orig/src/proxy-libintl/libintl.c | ||
4 | +++ proxy-libintl/src/proxy-libintl/libintl.c | ||
5 | @@ -18,9 +18,12 @@ | ||
6 | */ | ||
7 | |||
8 | #ifdef _WIN32 | ||
9 | -#include <windows.h> | ||
10 | +# include <windows.h> | ||
11 | #else | ||
12 | -#include <dlfcn.h> | ||
13 | +# include <stddef.h> | ||
14 | +# if !STUB_ONLY | ||
15 | +# include <dlfcn.h> | ||
16 | +# endif | ||
17 | typedef void* HMODULE; | ||
18 | #endif | ||
19 | |||
20 | @@ -65,11 +68,13 @@ static char * (*p_bind_textdomain_codese | ||
21 | static int | ||
22 | use_intl_dll (HMODULE dll) | ||
23 | { | ||
24 | -#ifdef _WIN32 | ||
25 | -#define LOOKUP(fn) p_##fn = (void *) GetProcAddress (dll, #fn); if (p_##fn == NULL) return 0 | ||
26 | -#else | ||
27 | -#define LOOKUP(fn) p_##fn = (void *) dlsym (dll, #fn); if (p_##fn == NULL) return 0 | ||
28 | -#endif | ||
29 | +#if !STUB_ONLY | ||
30 | +# ifdef _WIN32 | ||
31 | +# define LOOKUP(fn) p_##fn = (void *) GetProcAddress (dll, #fn); if (p_##fn == NULL) return 0 | ||
32 | +# else | ||
33 | +# define LOOKUP(fn) p_##fn = (void *) dlsym (dll, #fn); if (p_##fn == NULL) return 0 | ||
34 | +# endif /* _WIN32 */ | ||
35 | + | ||
36 | |||
37 | LOOKUP (gettext); | ||
38 | LOOKUP (dgettext); | ||
39 | @@ -82,7 +87,7 @@ use_intl_dll (HMODULE dll) | ||
40 | LOOKUP (bind_textdomain_codeset); | ||
41 | |||
42 | #undef LOOKUP | ||
43 | - | ||
44 | +#endif /* !STUB_ONLY */ | ||
45 | return 1; | ||
46 | } | ||
47 | |||
48 | @@ -171,13 +176,17 @@ setup (void) | ||
49 | |||
50 | if (!beenhere) | ||
51 | { | ||
52 | -#ifdef _WIN32 | ||
53 | - HMODULE intl_dll = LoadLibrary ("intl.dll"); | ||
54 | -#elif defined(__APPLE__) && defined(__MACH__) | ||
55 | - HMODULE intl_dll = dlopen ("libintl.dylib", RTLD_LAZY); | ||
56 | -#else | ||
57 | - HMODULE intl_dll = dlopen ("libintl.so", RTLD_LAZY); | ||
58 | -#endif | ||
59 | +#if !STUB_ONLY | ||
60 | +# ifdef _WIN32 | ||
61 | + HMODULE intl_dll = LoadLibrary ("intl.dll"); | ||
62 | +# elif defined(__APPLE__) && defined(__MACH__) | ||
63 | + HMODULE intl_dll = dlopen ("libintl.dylib", RTLD_LAZY); | ||
64 | +# else | ||
65 | + HMODULE intl_dll = dlopen ("libintl.so", RTLD_LAZY); | ||
66 | +# endif | ||
67 | +#else /* !STUB_ONLY */ | ||
68 | + HMODULE intl_dll = NULL; | ||
69 | +#endif /* STUB_ONLY */ | ||
70 | |||
71 | if (intl_dll != NULL && | ||
72 | use_intl_dll (intl_dll)) | ||