summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/packagegroups/packagegroup-boot.bb')
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-boot.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb b/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb
new file mode 100644
index 000000000..f50443d81
--- /dev/null
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-boot.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Basic task to get a device booting"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690"
4
5PR = "r58"
6
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8inherit packagegroup
9
10#
11# those ones can be set in machine config to supply packages needed to get machine booting
12#
13MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
14MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS ?= ""
15
16# Make sure we build the kernel
17DEPENDS = "virtual/kernel"
18
19#
20# minimal set of packages - needed to boot
21#
22RDEPENDS_${PN} = "\
23 base-files \
24 base-passwd \
25 busybox \
26 netbase \
27 ${@base_contains("MACHINE_FEATURES", "keyboard", "keymaps", "", d)} \
28 ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
29"
30
31RRECOMMENDS_${PN} = "\
32 kernel \
33 ${MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS} \
34"